Working with Keyframe animation

When compared with Stopframe animation (see Getting started with animation), Keyframe animation offers a more powerful and efficient animation technology—it saves having to declare every frame, letting your computer do the hard work! Essentially, the technique lets you create only user-defined keyframes through which objects animate, with each keyframe containing Key objects which can be assigned a position, rotation, attributes, etc.

Intermediate steps between Key objects are created automatically and produce a smooth professional-looking inter-object transition (this is called Tweening); Tweened objects are created as a result. You won't see these intermediate steps showing tweened objects by default, but they exist transparently between key objects throughout your animation.

The Storyboard tab is the workspace for laying out your animation "story" in a chronological keyframe-by-keyframe sequence (from left to right). On export, your animation will play in this direction. Using the above "bee" animation in the tab illustration as an example, the bee is animated, while the sun and "Buzzzz" text remain static objects.

By adding objects (bee and sun) to a starting keyframe it's possible to automatically copy (or more correctly run forward) those objects forward when you create subsequent keyframes. This in itself doesn't affect animation, but it's the repositioning of a run forward object (such as the bee) in later keyframes that creates "movement."

Once keyframes are created, the animator has a great deal of control over how objects are run forward (or even backwards). You can introduce objects anywhere on the storyboard (so they appear for a limited time), and either run them forward or backwards by a specific number of keyframes (or right to the start or end of the storyboard). The "Buzzzz" text in the above example will only show from keyframes 3 onwards (i.e., from 4 seconds).

Supporting tabs

Keyframe animation mode also presents other tabs that support the Storyboard tab. These are exclusively used within keyframe animation (and do not show in normal or stopframe animation mode), i.e.

Advanced keyframe animation

DrawPlus provides a range of features for the more experienced user, i.e.

Getting started

Keyframe animations are created in a specific order:

  1. Create your DrawPlus Animation file.

  2. Create object(s), either static or for animation, on the page.

  3. From the Storyboard tab, insert the number of keyframes and their duration via a dialog.

  4. Reposition objects in subsequent keyframes to effect animation.

  5. Export your keyframe animation as Adobe® Flash® (SWF).

To create a keyframe animation:

  1. Select Create>Keyframe Animation on the Startup Wizard.

  2. From Page Setup, review document types in the left-hand pane.

  3. Select a document type thumbnail from a Web, Screen, or Mobile category in the left-hand pane—ideal for presentation via website (banners, adverts, etc.), as a computer presentation, or on a handheld device.

  4. (Optional) In the Paper section at the right-hand of the dialog, swap your measurement units (e.g. to pixels), and change page size and/or orientation.

  5. (Optional) In the lower Animation section, you can configure animation-specific settings.

  6. Change the animation's Background Colour by clicking on the colour swatch.

  7. Set Transparent Background to Yes, then any exported Flash SWF file will possess a transparent background (even if a background colour is set).

  8. Increase/decrease the FPS, i.e. the frame rate setting (Frames Per Second).

  9. Set the Flash Version for backward compatibility to a specific version of Flash Player. Newer versions offer greater compression in exported Flash files.

  10. Set the Flash Bitmap Quality to a lower percentage setting to reduce Flash file sizes; this drops the resolution of placed bitmaps and any filter effects applied to objects.

  1. Click OK.

  2. You can convert your existing drawing to a keyframe animation by using File>Convert to Keyframe Animation.

  3. To change page and animation settings, use  Page Setup from the context toolbar (shown with Pointer or Rotate Tool selected) or File menu.

To view the Storyboard tab:

We'll assume that you've drawn objects on the first keyframe. You can run forward these automatically throughout your animation by creation of additional keyframes—this builds up your animation "story" quickly. Other methods exist to run objects forward (and backwards) but let's concentrate on the insertion of keyframes to do this.

To insert keyframes:

  1. From the Storyboard tab, select a keyframe and choose  Insert.

  2. From the dialog, choose the Number of keyframes to add to the Storyboard tab. Set a default Keyframe duration for each created keyframe.

  3. Choose to add keyframe(s) at a Location before or after the currently selected keyframe or before/after the first or last keyframe.

  4. (Optional) Check Insert blank keyframes if you don't want to include run forward objects in your keyframes. Blank frames are useful "filler" frames that add breaks in your animation for messages, logos, etc.

  5. Click OK.

An inserted frame will honour any animation runs that may transect it if the Insert blank keyframes setting remains unchecked (by creating an additional tweened object). If checked, the blank frame will break any transecting animation path(s) and not add tweened objects.

Once you've created a keyframe sequence you can sub-divide or split any selected keyframe further.

To split a selected keyframe:

To view or edit a particular keyframe:

To delete a keyframe:

Keyframe duration

Keyframe duration represents the amount of time in between each individual keyframe. The value is set according to how the keyframe was created, i.e.

  • Inserting keyframes (blank or otherwise) lets you set the keyframe duration in an Insert Keyframes dialog (default 1 second).

  • A splitting operation will create new keyframes whose duration will be a division of the selected keyframe's duration (by the number of keyframes to be split).

A keyframe's duration can be altered manually at any time.

To set the duration of an individual keyframe:

Storyboard control

Storyboard control is possible by using a selection of buttons grouped together on the Storyboard tab (equivalent options are on the Storyboard menu). They operate across the entire storyboard, as opposed to on an individual keyframe or key object.

 Break storyboard

Breaks the animation run that transects through a selected keyframe into two separate runs.

 Compact storyboard

A tool for tidying up your storyboard; any keyframes containing only tweened objects are removed from the storyboard.

 Scale storyboard

Expands or shrinks the whole storyboard. All keyframe durations are automatically adjusted to fit proportionately to the new Scale duration.

Adding sound

To complement the visual effect of your keyframe animation it's possible to add audio. Sounds can be added either for the duration of a specific keyframe, or when an action is applied to an object event (see Applying actions for details on actions and events).

To add an audio clip:

  1. On the Storyboard tab, click on the keyframe's  Sound icon (located below the frame's thumbnail).
    - or -
    Right-click the keyframe and select
    Background Sound....
    - or -
    Select
    Background Sound>Set Background Sound from the Insert menu.

  2. From the dialog, navigate to your audio file, select it and click the Open button.

To remove a selected keyframe's audio clip, right-click and select Clear Background Sound.

Adding movies

As well as using sound in your keyframe animation, you can introduce movie clips. The movie is inserted into your chosen keyframe as an object which like any other object (QuickShape, Text, etc.) will need to be run forward for the movie to play throughout the animation.

DrawPlus supports various video formats including Flash Video (FLV), Flash SWF, AVI, WMV, and QuickTime.

To add a movie:

  1. Select the keyframe to which the movie is to be added.

  2. Select Movie Clip... from the Insert menu.

  3. From the dialog, navigate to your movie file and select it.

  4. Click Open.

  5. Position the displayed  cursor where you want the movie to appear.

  6. Either:

  7. To insert the movie at the movie's original size, simply click the mouse.
    - or -

  8. To set the size of the inserted movie, drag out a region and release the mouse button.

  1. (Optional) Use the object toolbar controls to run forward/backward to the end/start of the storyboard (or by a set number of keyframes).

Previewing keyframe animations

You can preview your animation at any time either in a web browser or in Flash Player (This is a DrawPlus install option). This is a quick way of checking it prior to export.

To preview:

Click the down arrow on the  button on the Storyboard tab, then choose to either: