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To close all publications except current: 

• Right click a Publication tab on the Publications toolbar and choose 
Close All But This. 
 

 

To close PagePlus: 

• Click the program's  Close button. You'll be prompted to save 
changes to any unsaved publication. 

Updating and saving defaults 
Object defaults are stored property settings applied to new objects, e.g.: 

• lines and shapes (line and fill color, pattern, transparency, etc.) 

• frames (margins, columns, etc.)  

• text (i.e., font, size, color, alignment, etc.). Defaults are saved 
separately for artistic, shape, frame and table text.  

Default settings are always local—that is, any changed defaults apply to the 
current publication and are automatically saved with it, so they're in effect next 
time you open that publication. However, at any time you can use the Save 
Defaults command to record the current defaults as global settings that will be 
in effect for any new publication you subsequently create.  

To set local defaults for a particular type of object: 

1. Create a single sample object and fine-tune its properties as desired—
or use an existing object that already has the right properties. 

2. Select the object with the new defaults and choose Update Object 
Default from the Format menu.  
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Navigating pages 

To switch between pages: 

• Click the  Previous Page,  Next Page,  First Page or 

 Last Page button on the Hintline. 
- or - 
On the Studio's Pages tab, double-click the page's thumbnail for the 
page (or master page) you want to view. The lower Pages window of 
the tab displays normal pages, while the expandable Master Pages 
window shows only master pages. 

Adding, removing, and rearranging pages 

 

Use the Pages tab to quickly 
rearrange standard pages using drag-
and-drop, add/delete standard or 
master pages, or assign master pages 
to standard pages. The tab displays 
master pages in the upper Master 
Pages window (shown collapsed) 
and standard publication pages in 
the lower Pages window. 

 

The  Page Manager button provides additional options, such as duplicating 
a particular page, assigning a specific master page to a layer, or adding/deleting 
multiple pages.  
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To add a single page: 

1. On the Pages tab, click once to select a page in the Pages window. 
 
Note: The thumbnail that's shown as "selected" is independent of the 
page you're currently working on. To work on a particular page, 
double-click its thumbnail. 

2. Click  Add to add a page (or master page) before the one selected 
in the window. 
- or - 
To add a new page at the end of the publication, deselect all pages by 
clicking in the neutral gray region of the lower window, then click the 
Add button. 

To add master pages: 

For master pages, the above procedure applies but within the Master Pages 
window. The only exception is that you cannot create a new master page based 
on a design template's pages (no dialog opens). 

To delete a single page/master page: 

1. On the Pages tab, select the page (or master page) to delete on the 
appropriate window by clicking its thumbnail. 

2. Click the  Remove button. 

To rearrange pages: 

• On the Pages tab, in the lower Pages window, drag a page thumbnail 
to a new location in the page sequence. 
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Assigning master pages 

If you're only using one master page it is assigned to any newly created page by 
default. However, if you're using multiple master pages you can assign a specific 
master page to any standard page.  

To assign a master page: 

 

From the Page tab's expanded 
Master Pages window, drag a master 
page onto a target standard page in 
the lower window. 

 

If the page has more than one layer, 
you can specify the layer to which 
you want to assign the master page. 

 Alternatively, use the  Master 
Page Manager (use the Set tab) in 
the Pages tab. 

 

Working with layers  
Each new page or master page consists of a single layer. One layer may be 
enough to accommodate the elements of a particular layout, but you can create 
additional layers as needed. On each layer, objects such as text frames and 
pictures are stacked in the order you create them, from back to front, with each 
new object in front of the others. Layers themselves are stacked in a similar way, 
and of course you can juggle the order of objects and layers as needed. 
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Layers are useful when you're working on a complex design where it makes 
sense to separate one cluster of objects from another. You can work on one layer 
at a time without worrying about affecting elements on a different layer.  

Once you've displayed a page, you can normally edit any object on it—
regardless of which layer the object is on—simply by clicking the object. 

Each layer is situated along with 
other layers (if present) within a 
stack on the Layers tab. The 
uppermost layer is applied over 
any lower layer on the page. 

 

Layer 1 and Layer 2 above could represent the following: 
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In order to create new objects on a particular layer, you'll need to "activate" 
(switch to) that layer in the Layers tab. 

To activate a particular layer:  

• Click at the beginning of a layer entry to activate that layer. You'll see 
the  layer arrow jump to the now activated layer (Layer 1 in the 
Layers tab example above is currently active). 

Don't confuse this with simply selecting a layer (Layer 2 in the example is 
selected, but not activated), which is used to manage the layer itself (e.g., to 
move it, preview it, view/change layer options, etc.). 

To select a particular layer:  

• Click (or right-click) a layer name. The layer entry then possesses a 
blue background. 

 Right-clicking a layer name displays a menu of layer-related 
actions, as well as Options for that particular layer.  

Adding, removing, and rearranging layers 

When you add a new page or master page to the publication, you can specify 
whether to copy the layers and/or objects from a particular source page. Once 
you've created a page, it's easy to add, delete, move, or merge layers as needed. 
Moving a layer will place its objects in front or in back of those on other layers. 

To add a new layer to the current page or master page: 

1. In the Layers tab, click the  Insert new layer button. 

2. You'll be prompted to give the new layer a name and set its properties. 
When you've made your selections, click OK. 

To delete a layer: 

• In the Layers tab, select the layer's name and click the  Delete 
selected layer(s) button. 
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Drawing lines 

To draw a freeform line (with the Pencil Tool): 

1. Choose the  Pencil Tool from the Tools toolbar's Line flyout. 

2. Click where you want the line to start, and hold the mouse button 
down as you draw. The line appears immediately and follows your 
mouse movements. 

3. To end the line, release the mouse button. The line will automatically 
smooth out using a minimal number of nodes. 

4. To extend the line, position the cursor over one of its red end nodes. 
The cursor changes to include a plus symbol. Click on the node and 
drag to add a new line segment. 

To draw a straight line (with the Straight Line Tool): 

1. Choose the  Straight Line Tool from the Tools toolbar's Line 
flyout. 

2. Click where you want the line to start, and drag to the end point. The 
line appears immediately. 

 To constrain the angle of the straight line to 15-degree 
increments, hold down the Shift key as you drag. (This is 
an easy way to make exactly vertical or horizontal lines.) 

3. To extend the line, position the cursor over one of its red end nodes. 
The cursor changes to include a plus symbol. Click on the node and 
drag to add a new line segment. 

To draw one or more line segments (with the Pen Tool): 

1. Choose the  Pen Tool from the Tools toolbar's Line flyout. On 
the Curve context toolbar, three buttons let you select which kind of 
segment to draw:  
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 A Straight segment is simply a 
straight line connecting two nodes.  
(Shortcut: Press 1) 

 

 A Bézier segment is curved, 
displaying control handles for precise 
adjustment.  
(Shortcut: Press 2) 

 

 Smart segments appear without 
visible control handles, using 
automatic curve-fitting to connect 
each node. They are especially useful 
when tracing around curved objects 
and pictures.  
(Shortcut: Press 3) 

2. Select a segment type, then click where you want the line to start: 

• For a Straight segment, click again (or drag) for a new node 
where you want the segment to end. Shift-click to align the 
segment at 15-degree intervals (useful for quick right-angle 
junctions).  

• For a Bézier segment, click again for a new node and drag out a 
control handle from it. Click again where you want the segment 
to end, and a curved segment appears. The finished segment 
becomes selectable. 

• For a Smart segment, click again for a new node. The segment 
appears as a smooth, best-fitting curve (without visible control 
handles) between the new node and the preceding node. Before 
releasing the mouse button, you can drag to "flex" the line as if 
bending a piece of wire. If the preceding corner node on the line 
is also smart, flexibility extends back to the preceding segment. 
You can Shift-click to create a new node that lines up at 15-
degree intervals with the previous node. 
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3. To extend an existing line, repeat Step 2 for each new segment. Each 
segment can be of a different type. 

4. To end the line, press Esc, double-click, or choose a different tool. 

Editing lines 

Use the Pointer Tool in conjunction with the Curve context toolbar to adjust 
lines once you've drawn them. The techniques are the same whether you're 
editing a separate line object or the outline of a closed shape.  

See PagePlus help for information on editing lines. 

Setting line properties 
All lines, including those that enclose shapes, have numerous properties, 
including color, weight (width or thickness), scaling, cap (end), join (corner), 
and stroke alignment. You can vary these properties for any freehand, straight, 
or curved line, as well as for the outline of a shape. Note that text frames, 
pictures, tables, and artistic text objects have line properties, too. 

In PagePlus, you can control the position of the stroke (i.e., line width) in 
relation to the object's path, i.e. the line that defines the boundary of the object. 

To change line properties of a selected object: 

•  Use the Swatches tab to change the line's color and/or shade. 
Alternatively, use the Color tab to apply a color to the selected object 
from a color mixer.  

• Use the Line tab, context toolbar (shown when a line is selected), or 
Line and Border dialog to change the line's weight (thickness), type, or 
other properties. Select a line width, and use the drop-down boxes to 
pick the type of line. The context toolbar can also adjust line-end 
scaling as a percentage. 

On the Line tab, context toolbar, or Line and Border dialog, the styles drop-
down menu provides the following styles: None, Single, Calligraphic, and 
several Dashed and Double line styles as illustrated below. 
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Several techniques offer additional ways to customize lines: 

 
For dashed lines, select from one of five dashed line styles 
(see above). 
- or - 
(tab and dialog only) Drag the Dash Pattern slider to set 
the overall pattern length (the number of boxes to the left 
of the slider) and the dash length (the number of those 
boxes that are black).  

The illustrations below show lines with pattern and dash 
lengths of (1) 4 and 2, and (2) 5 and 4: 
 

  

 
For double lines, select from one of four Double line 
styles (see above).  

 
(Tab only) For Calligraphic lines of variable width (drawn 
as if with a square-tipped pen held at a certain angle), 
select the calligraphic line style (opposite) from the drop-
down menu then use the Calligraphic Angle box to set 
the angle of the pen tip. 

 
Choose a Stroke Alignment setting to fit the line's stroke 
to the middle, inside, or outside of the object's path (using 
Align Center, Align Inner, or Align Outer buttons, 
respectively). 

You can also vary a line's Cap (end) and the Join (corner) where two lines 
intersect.  
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Drawing and editing shapes 
QuickShapes are pre-designed objects that you can instantly add to your page, 
then adjust and vary using control handles, creating variations on the original 
QuickShape. 

 

Another way to create a shape is to draw a line (or series of line segments) and 
then connect its start and end nodes, creating a closed shape. 

Once you've drawn a shape, you can adjust its properties—for example, apply 
gradient or bitmap fills (including your own bitmap pictures!) or apply 
transparency effects. 

QuickShapes 

The QuickShape flyout contains a wide variety of commonly used shapes, 
including boxes, ovals, arrows, polygons, and stars.  

 

You can easily turn shapes into web 
buttons by adding hyperlinks or 
overlaying hotspots. The "QuickButton" 
(circled at left) is especially intended for 
creating stylish button outlines! 
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Applying solid fills 
PagePlus offers a number of ways to apply solid color fills to objects of different 
kinds: 

• You can apply solid colors to an object's line or fill. As you might 
expect, QuickShapes and closed shapes (see Drawing and editing 
shapes on p. 190) have both line and fill properties, whereas straight 
and freehand lines have only a line property. 

• Characters in text objects can have fill color or highlight color. Text 
frames and table cells can have a background fill independent of the 
characters they contain. 

• You can colorize a paint-type (bitmap) picture—that is, recolor it to 
use a different color. If you recolor a full-color picture, the colors will 
convert to tints or shades of the specified color. You can also apply 
tinting to a full-color picture to produce a low-intensity picture (useful 
for backgrounds behind text). 

You can use the Color tab, Swatches tab or a dialog box to apply solid colors to 
an object.  

To apply a solid color via the Color tab:  

1. Select the object(s) or highlight a range of text. 

2. Click the Color tab and select one of several color modes (RGB, 
CMYK, or HSL) from the drop-down list. 

3. Click the  Fill,  Line, or  Text button at the top of the 
tab to determine where color will be applied. The color of the 
underline reflects the color of your selected object.  

4. Select a color from the color spectrum or sliders depending on color 
mode selected. 
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To apply a solid color via the Swatches tab:  

1. Select the object(s) or highlight a range of text. 

2. Click the Swatches tab. 

3. Click the  Fill,  Line, or  Text button at the top of the 
tab to determine where color will be applied. 

4.   Select a color swatch from the Publication palette 
(commonly used colors and those previously applied to your 
publication) or Standard Palette (supplied preset swatches). 

Use Format>Fill... to apply color via a dialog. 

To change a solid color's shade/tint (lightness):  

1. Select the object and set the correct Fill, Line or Text button in the 
Color tab. 

2. From the Color mode drop-down menu, select Tinting. 

3. Drag the Shade/Tint slider to the left or right to darken or lighten your 
starting color, respectively. You can also enter a percentage value in 
the box (entering 0 in the input box reverts to the original color). 

 Adjust the  percentage tinting via slider or direct 
input to apply object tinting from the Swatches tab. 

PagePlus automatically adds used colors to the  Publication Palette in the 
Swatches tab. 

To change the current palette: 

• Click the  Palette button to view and adopt colors from a 
Standard RGB, Standard CMYK, or selection of themed palettes. 
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Using schemes 
In PagePlus, a color scheme is a cluster of five complementary colors that you 
can apply to specific elements in one or more publications. The Schemes tab 
displays preset schemes which can be selected at any point during the design 
process. Each publication can have just one color scheme at a time; the current 
scheme is highlighted in the Schemes tab. You can easily switch schemes, 
modify scheme colors, apply schemes to any publication, even create your own 
custom schemes. Color schemes are saved globally, so the full set of schemes is 
always available. 

How color schemes work 

Color schemes in PagePlus work much like a paint-by-numbers system, where 
various regions of a layout are coded with numbers, and a specific color is 
assigned (by number) to each region. For example, imagine a line drawing 
coded with the numbers 1 through 5. To fill it in, you'd use paint from jars also 
numbered 1 through 5. Swapping different colors into the paint jars, while 
keeping the numbers on the drawing the same, would produce quite a different 
painting.  

  

In PagePlus, the "paint jars" are five 
numbers you can assign to objects in your 
publication. They're known as "Scheme 
Color 1," "Scheme Color 2," and so on. 
When you apply Scheme Color 1 to an 
object, it's like saying, "Put the color from 
jar number 1 here." 
  

• The Schemes tab shows the various available schemes, each with a 
different set of five colors in the five "jars." Whichever named color 
scheme you select, that scheme's first color (as shown in its sample) 
will appear in regions defined as Scheme Color 1, its second color will 
map to Scheme Color 2, and so on throughout the publication. 
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The example below shows three different schemes as applied to a design that's 
been marked with Scheme Colors 1 through 5 as in the example above.  

  

To select a color scheme: 

1. Click the Schemes tab. The currently assigned scheme is highlighted 
in the list. 

2. Click a different color scheme sample. Objects in the publication that 
have been assigned one of the five color scheme numbers are updated 
with the corresponding color from the new scheme. 

You can repeat this selection process indefinitely. When you save a publication, 
its current color scheme is saved along with the document. 

Applying scheme colors to objects 

If you create new elements in a publication to which you have applied a color 
scheme, or start a publication from scratch, how can you extend the current 
color scheme to the new objects? Although you'll need to spend some time 
working out which color combinations look best, the mechanics of the process 
are simple. Recalling the paint-by-numbers example above, all you need to do is 
assign one of the five current scheme color numbers to an object's line and/or 
fill.  
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Working with transparency 
Transparency effects are great for highlights, shading and shadows, and 
simulating "rendered" realism. They can make the critical difference between 
flat-looking publications and publications with depth and snap. PagePlus fully 
supports variable transparency and lets you apply solid, gradient, or bitmap 
transparencies easily. 

You can also export transparent graphics as GIFs, PNGs, or TIFs and preserve 
transparency effects in both your printed output and your web pages. 

Transparencies work rather like fills that use "disappearing ink" instead of color. 
The more transparency in a particular spot, the more "disappearing" takes place 
there, and the more the object(s) underneath show through. Just as a gradient fill 
can vary from light to dark, a transparency can vary from more to less, i.e. from 
clear to opaque, as in the illustration: 

  

In PagePlus, transparency effects work very much like grayscale fills. Just like 
fills... 

• Transparency effects are applied from the Studio—in this case, using 
the Transparency tab. (Transparency is also an option with the 3D 
Pattern Map filter effect.)  

• The Transparency tab's gallery has thumbnails in shades of gray, 
where the lighter portions represent more transparency. To apply 
transparency, you click thumbnails or drag them onto objects. 

• Most transparency effects have a path you can edit—in this case, with 
the Transparency Tool. 
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Transparency types available in the Transparency tab are as follows: 

• Solid transparency distributes the transparency equally across the 
object. 

• Gradient transparencies include linear, elliptical, and conical effects 
(each thumbnail's tooltip identifies its category), ranging from clear to 
opaque. 

• Bitmap transparencies  include categorized texture maps based on the 
Swatches tab's selection of bitmaps. 

Applying transparency 

You can apply transparency to shapes, text frames, table cells, and to any 
artistic, frame, and table text. 

To apply transparency with Transparency tab: 

1. With your object selected, go to the Transparency tab. 

2. For solid transparency, select the  Solid button and pick a 
thumbnail from the solid transparency gallery. The lighter thumbnails 
represent more transparency (expressed as percentage Opacity). 
- or - 

For gradient transparency, choose the  Gradient button and pick 
your thumbnail. 
- or - 

For bitmap transparency, choose the  Bitmap button and pick a 
thumbnail from a range of categories. 

3. The transparency is applied to the object(s). 

Alternatively, drag the desired thumbnail from the gallery to an object, and 
release the mouse button. 
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To apply gradient transparency with the Transparency Tool: 

1. Select a colored object. 

2. Click the  Transparency Tool on the Attributes toolbar's 
Transparency flyout. 
- or - 
 
Select Format>Transparency. 

3. Drag your cursor across the object and release the mouse button. 

4. The object takes a simple Linear transparency, grading from 100% 
opacity to 0% opacity (fully transparent). 

Editing transparency 

Once you've applied a gradient transparency, you can adjust or replace its path 
on the object, and the level of transparency along the path. You can even create 
more complex transparency effects by adding extra nodes to the path by clicking 
and assigning different levels to each node. 

To adjust the transparency path: 

• Use the  Transparency Tool to drag individual nodes, or click on 
the object for a new start node and drag out a new transparency path. 
The effect starts where you place the start node, and ends where you 
place the end node. For bitmap transparencies, the path determines the 
center and two edges of the effect. 

Editing a gradient transparency path is similar to editing a comparable fill 
path. Adding a level of transparency means varying the transparency gradient; 
simply add a new node and assign it a particular value. For transparencies with 
multiple nodes, each node has its own value, comparable to a key color in a 
gradient fill. Note that you cannot alter the values in a bitmap transparency. 
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To edit a gradient transparency directly: 

1.  Select an object with gradient transparency and click 
the Transparency Tool button. The object's transparency path 
appears, with start and end nodes. 

2. Display the Studio's Transparency tab. 

3. To add a transparency node, drag from any solid transparency 
sample in the Transparency tab to the point on the path where you 
want to add the node. 

 
The higher the percentage value assigned to a transparency node, the 
more transparent the effect at that point. Note: The hue of the color 
doesn't matter, only its percentage value—so it's much easier just to 
choose from the set of gallery thumbnails. 

4. To change the transparency value of any existing node, including the 
start and end nodes, select the node and click on a new thumbnail in 
the Transparency tab's Solid transparency gallery (you can also drag 
your chosen thumbnail onto the selected node) 

5. To move a node you've added, simply drag it to a new position along 
the transparency path. 

6. To delete a node you've added, select it and press Delete. 

Setting the default transparency  

The default transparency means the transparency that will be applied to the 
next new object you create. Local defaults only affect objects in the current 
project. For information on setting defaults in PagePlus, see Updating and 
saving defaults on p. 25. 
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To create a new web publication from scratch: 

1. Launch PagePlus or choose New>New from Startup Wizard from 
the File menu. 

2. In the Startup Wizard, select the Start New Publication option, select 
the Web Page category on the left, and choose a Standard (VGA) or 
Wide (SVGA) page. 

3. Click OK. PagePlus will enter Web Publishing mode automatically. 

To create a new web publication using a design template: 

1. Launch PagePlus or choose New>New from Startup Wizard from 
the File menu.  

2. In the Startup Wizard, select the Use Design Template option, select 
the Web Publishing>Web Sites category on the left, and examine the 
samples on the right. Click the sample that's closest to the site you 
want to create, then click Open. 

3. Enter custom user details to personalize your website immediately. 

If you'd like to build on previous work you've done with PagePlus, you can also 
take an existing paper publication and convert it to a web publication. 

To turn an existing PagePlus (paper) publication into a website:  

• Open the publication in Paper Publishing mode and choose Switch to 
Web Publishing from the File menu.  

To adjust size/orientation of the current publication: 

1. Choose Page Setup... from the File menu. 

2. Set page dimensions as Standard for VGA monitors (recommended), 
Wide for SVGA, or Custom. For a custom setting, enter page 
dimensions in pixels.  

As with a paper publication, preparing a website means checking and rechecking 
the content. You can use the regular PagePlus checking functions such as Spell-
checking, proofreading, using the thesaurus, etc. In addition, the Web Site 
Layout Checker can inspect and correct a wide range of common problems. 
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Viewing hyperlinks in your publication  
The Hyperlink Manager gives you an overview of all the hyperlinks in your 
publication. 

To display the Hyperlink Manager: 

• Choose Hyperlink Manager... from the Tools menu. 

The Hyperlink Manager dialog displays both object and text hyperlinks in your 
publication, listed by page number. The entries show each link's source object 
type (Text, Linked bitmap, etc.) and its destination page or URL, plus the target 
name.  

To display a hyperlink for closer inspection: 

• Click to select the link entry and click the Display button. 

To remove or modify a hyperlink:  

• Click to select the link entry and click the Remove or Modify button. 
To modify the hyperlink, select a new link destination type and target. 

Adding hotspots 
A hotspot is a transparent hyperlink region on a web page. Usually placed on top 
of images, hotspots act like "buttons" that respond when clicked in a web 
browser. They are especially useful if you want the visitor to be able to click on 
different parts of a picture (such as a graphic "menu" or map of your site). 

To define a hotspot: 

1. On the Insert menu, choose Web Object, and then click Hotspot. 

2. Click and drag to draw a rectangular hotspot region. From the dialog, 
click to select the link destination type, and enter the specific 
hyperlink target—an Internet page, a page in your website, an email 
address, local file, or an object's anchor.  

3. Click OK. 
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To modify a hotspot hyperlink: 

• Using the Pointer Tool, double-click the hotspot, and edit the 
hyperlink. 
- or - 

Click to select the hotspot, then click the  Hyperlink button on 
the Standard toolbar. 

Editing hotspots 

You can move and resize hotspots on the page, using its outer bounding box. An 
inner outline lets you drag the outline's corner nodes, add nodes by clicking on 
the line, and delete nodes to alter the shape of the "active" hotspot area, 
especially useful for pictures set at different angles.  

  

To move or resize a hotspot: 

• Click to select the hotspot. 

• To move, drag from the center, or from the hotspot's bounding box. To 
constrain the hotspot to vertical or horizontal movement, hold down 
the Shift key while dragging. 

• To resize, drag on its outer (bounding box) handles.  
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By editing the inner outline, you can convert rectangular hotspots into freeform 
shapes that closely match the parts of the underlying graphic you want to be 
"hot." To edit the outline, first move the mouse pointer over the hotspot's inner 
outline until the cursor changes to indicate whether you're over a node or a line.  

 

Choosing website colors 
A website may have an adopted color scheme, selected by using the Schemes 
tab. Each scheme has a name and consists of five complementary basic colors 
(plus additional web colors) which you can apply to any design element (see 
Using color schemes on p. 219).  

A selection of schemes (named "WWW 1" through "WWW 9") appearing at the 
bottom of the tab's scheme list are specifically designed for web use.  

The currently set color scheme is also shown at the bottom of the Swatches tab 
for convenience. For example for the color scheme "WWW3", numbers or 
letters represent basic or web color sets, respectively: 

 

Web colors 

Websites have several special web color settings, usually defined as part of a 
color scheme in the Scheme Manager. You'll need to know about these 
settings, even if you haven't applied scheme colors to other elements in your 
site.  
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• The Hyperlink color (labeled H above) applies to hyperlinked text 
before it's been clicked on. 

• The Followed Hyperlink color (labeled F), applies to hyperlinked 
text after a visitor has clicked to "follow" the link. 

• The Active Hyperlink color (labeled A), applies to hyperlinked text 
when a visitor's mouse button is depressed. Typically this is the color 
shown after clicking and before the hyperlink's page is displayed. 

• The Rollover color (labeled R), applies to hyperlinked text when a 
visitor's mouse button rolls over it. 

• A website's Background (labeled B) is a solid color with the option of 
overlaying a tiled (repeated) picture, usually a bitmap pattern. The 
tiled picture option works just like desktop "wallpaper," so a small 
bitmap can go a long way. The background will fill any blank space 
left in the browser when displayed on a larger screen. 
 
If you use a picture background with transparent regions, the 
Background color is still active and will show through; otherwise the 
picture will cover the background color. 

• The On-page color (labeled O) allows you to have a distinct color for 
the defined page area. If set to transparent, it will display the current 
background color. 

 Click the  button to access the Scheme Manager. 

 

 

In Web Publishing mode, color 
scheme samples in the Schemes tab 
show some web colors along with 
the five basic scheme colors, as 
shown at left. 

The easiest way to apply new web colors is to select a different color scheme by 
clicking a sample on the Schemes tab. 

You can also change any of the web colors within a scheme using the Scheme 
Manager, in the same way that you would modify the scheme's five basic colors. 
See Using Color Schemes on p. 219. 
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Setting custom page backgrounds 

The web colors defined in the Scheme Manager normally apply throughout the 
site, but you can override the Scheme Manager's Background picture/color 
setting for any particular page. 

To set a custom page background: 

1. Choose Web Site Properties... from the File menu.  

2. On the Background tab, uncheck Use Scheme Manager settings and 
set new options for Background color and/or Use picture and/or On-
page color.  

 The settings apply only to the current page.  

Setting web picture display options 
When you export a publication as a website, PagePlus applies certain global 
settings to determine how each image—whether drawn, pasted in, or imported—
ends up as a separate bitmap displayed on the web page.  

The following conversion settings are used for web publishing: 

• Each image in the publication is exported as a separate file. 

• Any image you inserted is exported as the original file, using its 
original file name. 

• Inserted metafiles and all other graphics are converted to JPEG 
images, using a compression quality setting of 10 (low compression, 
high detail). For these images, PagePlus automatically generates file 
names, using incremental numbering (IMG1, IMG2, etc.) that 
continues each time you export. 

Global export options and setting export formats are described in more detail in 
the PagePlus Help.  
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Choosing web page properties 
There's more to creating a successful website than designing the pages. It's a 
good idea to browse the Site Properties dialog, accessible from File>Web Site 
Properties and review a variety of settings you might not otherwise have 
considered!  

Site Properties/Page tab 

Some of the options on the dialog's Page tab pertain just to the current page, 
while others apply to the site as a whole. The web page title, which will appear 
in the title bar of the visitor's web browser, can serve to unify the pages and 
focus the site's identity, as well as aid navigation. Each page in your site can 
have its own title, but you may prefer to use the same title on multiple pages (in 
effect, a site title). An easy way to do this is to start with a blank page, give it a 
title, then replicate that page. Copies of that page will have the same title. 

Each page also has a file name when it's published. You can specify file names 
individually; otherwise PagePlus automatically generates them.  
 
Check the instructions from your web service provider as to their naming 
conventions for Home Pages and file extensions. By default, PagePlus names 
your first (Home) page index.html—the standard file name a browser will be 
looking for. Depending on the particular server in use, however, some other 
name may be required. Likewise, the extension .htm is sometimes used for 
pages. 

Adding animation effects 
PagePlus lets you add two varieties of eye-catching animation effects to any web 
page: animated marquees and GIF animations. Either way, you can preview 
the animation and/or customize the effect. Once placed into your web 
publication, the animations appear static, but they will spring to life once the site 
has been exported and a visitor views your page in a web browser. 

Adding sound and video 
PagePlus lets you augment your web pages with sound and video files in a 
variety of standard formats, including both non-streaming and streaming 
media.  
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(Non-streaming files must download in entirety to a user's computer before they 
begin playing; streaming files require a special player that buffers incoming data 
and can start playing before the whole clip has arrived.) 

There are actually two sound playback options—background sound, where a 
sound loads and plays automatically when a specific page is first displayed in 
the visitor's web browser, and linked sound, triggered by a mouse click (for 
example on an icon or hyperlinked object).  

Linked video works like linked sound. 

To add background sound to a page: 

1. Choose Web Site Properties... from the File menu and select the 
Background tab. 

2. Check Use sound file, then browse to the sound file you want to add. 

3. If you do not wish to embed the file in your publication, uncheck 
Embed sound files in site. 
Note: If you choose not to embed your source files, we suggest you 
keep them together in a subfolder named "Media" or the like. When 
you publish your site, PagePlus exports and copies both embedded and 
non-embedded files into a common folder. 

4. To have the sound play back as a continuous loop, check Loop sound. 
Otherwise, it will play just once. 

The sound file will download and play back when the web page displays in a 
browser. 

With both linked sound and linked video, the basic question is how you want the 
visitor to be able to trigger the playback of a given media file. PagePlus offers 
the same basic options for both kinds of media: 

1. From a hyperlinked object or hotspot: You start with an existing 
object in the publication, and hyperlink it to the media file, or use a hotspot 
over an image. 

2. From an icon: PagePlus provides an icon pre-linked to the media file. 
You then position the icon on your page. 
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3. From a picture: You select an external picture file, which PagePlus then 
imports and links to the media file.  

4. Inline: A media "player" will be visible on your published web page 
(rather than appearing after the user clicks a link, icon, or picture). In 
PagePlus, you'll see a marker on the page where the player will appear. 

With option 1, the media file remains external and can't be embedded in your 
publication. Options 2 to 4 give you the choice of embedding the media file. 

To add linked sound or video to a page: 

• To link from an object or hotspot (option 1 above), choose 
Hyperlink... from the Insert menu and select A file on your hard 
disk as the link target, then locate the media file. For details, follow 
the links given in option 1. 
- or - 

1. To link from an icon, picture, or inline player (options 2 to 4), choose 
Web Object... from the Insert menu and select either Sound... or 
Video... from the submenu. 

2. Browse to locate the media file name. 

3. Select a link display option.  

4. If you do not wish to embed the file in your publication, uncheck 
Embed sound files in site. 

5. Click OK to close the dialog, then click (or click and drag) with the 
cursor to place the icon, picture, or marker on your page. 

Adding Java applets 
Java is a cross-platform, object-oriented programming language used to create 
mini-applications called applets that can be attached to web pages and that run 
when the page is viewed in a web browser. PagePlus lets you add Java applets to 
your web publications. You don't have to write your own! Plenty of applets are 
available online—for example animation, interface components, live 
information updating, two-way interaction, and many more.  
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Publishing a website to a local folder 
Even though you may have saved your website as a PagePlus publication, it's 
not truly a "website" until you've converted it to HTML and image files—in 
other words, a format that can be viewed in a web browser. In PagePlus, this 
conversion process is called publishing the site. You can publish the site either 
to a local folder (on a hard disk) or to the web itself. 

Publishing the site to a local folder lets you preview the pages in your own 
browser prior to publishing them on the web. You may find it convenient to 
keep your browser program open, and go back and forth between PagePlus and 
the browser. This way you can make changes to a single page in PagePlus, 
publish just the one page, then switch to your browser and preview that page to 
make sure everything appears just as you want it.  

To publish the site to a local folder: 

1. Choose Web Site Properties... from the File menu and double-check 
export settings, particularly those on the Graphics tab. 

2. Choose Publish Site> from the File menu and select to Disk Folder... 
from the submenu. 

3. In the dialog, locate the folder where you wish to store the output files 
by clicking the Choose Folder... button. You can create a new folder 
under any selected folder with the Make New Folder button. Click 
OK. 

4. Either check the Publish All Pages option, or in the site structure tree, 
check which specific page(s) to publish. This can save a lot of time by 
skipping the export of pages you haven't changed. 

5. Click OK. 

After PagePlus has finished exporting the selected pages, you'll be asked if you 
want to launch your web browser to view your page. Click Yes if you wish to do 
this. 
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Previewing your website in a browser 
Previewing your site in a web browser is an essential step before publishing it to 
the web. It's the only way you can see just how your PagePlus publication will 
appear to a visitor. 

We'll assume you've already published your website to a local folder. 

To preview your website from a local hard disk: 

• Choose Preview in Browser> from the File menu, then choose a 
Preview Page in <browser name>... or Preview Site in <browser 
name>... to use an external browser. The <browser name> will reflect 
which browsers are currently installed, e.g. the entry may read 
"Preview Page in Internet Explorer." If you have more than one 
browser installed, you can select which browser(s) to display on the 
submenu. 

Publishing to the web 
Publishing to the web involves a few more steps, but is basically as simple as 
publishing to a local folder! You can specify that all web pages are published or 
only pages updated since your last "publish." 

To publish your site to the web: 

1. On the File menu, choose Web Site Properties... and verify your 
export settings, particularly those on the Graphics tab. 

2. On the File menu, choose Publish Site> and then select to Web.... 

If this is your first time publishing to the web, the Account Details dialog opens 
(with no account information present). You'll need to set up at least one account 
before you can proceed.  

3. In the Account Details dialog, enter FTP account details before 
clicking OK. 

• The Account name can be any name of your choice. You'll use it 
to identify this account in PagePlus (in case you have more than 
one). 
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• The FTP address of your web host will be a specific URL as 
supplied by your Internet service provider (ISP) . 

• Unless directed by your provider, leave the Port number set at 
"21." If changing your port number, remember to change your 
firewall settings to reflect new port numbers. 

• Leave the Folder box blank unless directed by your provider, or 
if you want to publish to a specific subfolder of your root 
directory. 

• You'll also need a Username and Password. These are pre-
assigned by your provider and will most likely correspond to 
email login settings. Enter the password exactly as given to you, 
using correct upper- and lower-case spelling, or the host server 
may not recognize it. If you don't want to re-enter your password 
with each upload, check Save password to record the password 
on your computer.  

• Passive mode: Leave checked unless you have FTP connection 
problems (check with your ISP). ISPs can operate passive or 
active FTP modes of operation. 

• Web site URL: Set your site's URL. This allows you to view 
your site from a dialog after any FTP upload. 

• In the Advanced box, you can optionally enable security on file 
transfer by uploading using one of two encryption protocols—
TLS 1.0 and SSL 3.0. Check Encrypt connection, then choose 
the Protocol. You'll need to confirm with your ISP whether 
encryption (and which protocol) is supported, implied or 
otherwise. The SSL Implied option makes the ISP's FTP server 
encrypt on initial contact to default port 990 or a custom port 
(edit Port number).  

4. If you've set up at least one account, the Upload to Server dialog 
opens. In the dialog, the last used account name is shown in the drop-
down menu; its settings are displayed in subsequent boxes. You can 
use the drop-down menu to switch to another account, if set up. 
 
You can also use the dialog to Add another account, and Copy, Edit, 
or Delete an account selected from the drop-down menu. It's a good 
idea to test your new or modified account by clicking the Test 
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button—if the account details are valid, a dialog indicating successful 
connection displays. 

5. Click the Upload button. PagePlus seeks an Internet connection, then: 

• If uploading for the first time, selected files will be uploaded 
directly. 
- or - 

• If uploading to an existing site (must be created with 
PagePlus), an Uploading Files dialog is displayed showing 
local file action (whether files will be added (Add), will 
replace the live files (Replace), or will not be updated 
(Leave)). 
 
In the dialog, select either the Incremental Update or Full 
upload button. Choose the former to upload only files that 
have altered since the last upload. You'll see a message 
when all files have been successfully copied. Click Close. 

Gathering server information 

If you have an email account, your contract with the email service provider may 
allow you a certain amount of file space (e.g., 25MB) on their server where you 
can store files, including the files that comprise a website. Or you may have a 
separate "web space" arrangement with a specialized Internet service provider. 
It's up to you to establish an account you can use for web publishing.  

Maintaining your website 
Once you've published your site to the web, you'll need to maintain the pages on 
your site by updating content periodically: adding or changing text, pictures, and 
links, also file/folder deletion or renaming. 

To maintain files and folders on your website: 

1. Choose Publish Site> from the File menu and select Maintain Web 
Site... from the submenu. 

See online Help for more information.
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