## Contents

### 1. Welcome .......................................................... 1
   - Welcome! .................................................................................................................. 3
   - New features ............................................................................................................ 4
   - Installation ................................................................................................................ 7

### 2. Getting Your Site Online ................................... 9
   - Start WebPlus ....................................................................................................... 11
   - Pick a design ......................................................................................................... 12
   - Edit title and text ................................................................................................. 15
   - Insert a picture ..................................................................................................... 16
   - Add a new blank page ...................................................................................... 17
   - Add an Under Construction graphic ........................................................................ 18
   - Get Serif web hosting ........................................................................................ 20
   - Publishing your site ........................................................................................... 23

### 3. Setting up Sites and Pages ............................ 25
   - Creating a site using a design template ..................................................... 27
   - Opening an existing site .................................................................................. 31
   - Starting a site from scratch ............................................................................. 33
   - Creating mobile sites and pages ................................................................. 34
   - Understanding site structure.......................................................................... 38
   - Setting site properties .................................................................................... 41
   - Understanding pages and master pages ................................................... 42
   - Adding, removing, and rearranging pages ............................................... 47
   - Setting page properties .................................................................................... 53
   - Adding backgrounds.......................................................................................... 54
Contents

Using color schemes ................................................................. 59
Dynamic guides .............................................................................. 62

4. Layout Items ................................................................. 65
   Inserting text frames ................................................................. 67
   Inserting pictures ........................................................................ 70
   Inserting panels .......................................................................... 76
   Inserting a Photo Gallery ....................................................... 81
   Inserting tables .......................................................................... 87
   Inserting a calendar ................................................................... 88
   Inserting sliders ......................................................................... 92

5. Navigation Items ............................................................. 97
   Inserting navigation bars ....................................................... 99
   Inserting pop-up menus .......................................................... 102
   Inserting buttons ....................................................................... 104
   Adding hyperlinks and actions .............................................. 108
   Adding an anchor ....................................................................... 112
   Using lightboxes ....................................................................... 113

6. Interactive Objects ......................................................... 117
   Inserting rollovers ................................................................. 119
   Rollover options ...................................................................... 119
   Inserting pop-up rollovers .................................................... 121
   Inserting a site search ............................................................ 123
   Inserting Google Maps .......................................................... 125
   Inserting an advert ................................................................. 126
7. External / Managed Content ................................. 129
   Inserting framed documents .................................................. 131
   Inserting a blog ...................................................................... 133
   Inserting a news window .......................................................... 135
   Inserting a forum .................................................................... 137
   Inserting an RSS reader ............................................................ 141
   Access control .......................................................................... 143
   Using Smart objects ............................................................... 151

8. Social Media .............................................................. 159
   Inserting a Facebook widget .................................................. 161
   Inserting a Twitter widget ....................................................... 163
   Inserting a Google +1 button .................................................. 167
   Inserting a social bookmarking button strip .............................. 168

9. Media ............................................................................. 171
   Adding sound and video ............................................................. 173
   Inserting Flash SWF files ......................................................... 175
   Inserting YouTube videos ....................................................... 176

10. Forms ............................................................................. 179
    Inserting forms ................................................................. 181
    Submission of forms ............................................................. 184

11. E-Commerce Objects ................................................... 189
    Understanding e-commerce .................................................. 191
    Inserting an e-commerce object (PayPal) .............................. 194
Screenshots used in this User Guide were taken from
the UK English version of WebPlus X6.
In memory of Jim Baumgartner,
a valued WebPlus forum contributor over many years.
Welcome
Welcome!

Welcome to WebPlus X6 from Serif—the easiest way to get your business, organization, or household on the web!

To make life so much easier, WebPlus comes with an impressive selection of design templates, page navigation bars, creative assets, and styles for you to use. As a result, publishing to the web to a professional standard is easily achievable for experienced and inexperienced users alike! You'll also be able to reuse existing textual content by importing word processing documents.

To make the most of pictures in your site you can use Cutout Studio for cutting pictures out and PhotoLab for powerful image adjustment and effect combinations. You simply cannot afford to miss them!

WebPlus X6 doesn't just stop at "static" web publishing. The real power comes when adding and managing dynamic content, such as blogs, forums, and third-party RSS feeds, as well as modern essentials such as panels, sliders, and Google maps, plus Facebook, Twitter, and Google+ widgets. You can even make use of E-commerce tools for money-making shopping cart functionality.

Once you’re happy with your WebPlus site, simply publish to the web to share with business colleagues, customers, friends and family alike.

For a more detailed summary of what WebPlus can offer, see Key features in WebPlus Help.

Upgrading?

If you've upgraded from a previous version, this new edition of WebPlus includes a host of exciting new features (p. 4) which keeps WebPlus ahead of its competitors and at a fraction of the price! We hope you also enjoy the additional power and performance edge.

Registration

Don’t forget to register your new copy, using the Registration Wizard, on the Help menu. That way, we can keep you informed of new developments and future upgrades!
This User Guide

The WebPlus X6 User Guide is provided for the new or inexperienced user to get the very best out of WebPlus. As the program is packed with a wealth of features, this User Guide doesn't cover all product functionality, but instead focuses on core and frequently used features. For comprehensive assistance, please use WebPlus Help (press your F1 key).

New features

- **Site Structure View for Site Organization** (p. 39)
  Ideal for larger websites, this full-screen visual overview of your site structure gives a perfect "heads up" of your site. Page thumbnails in a tree structure show how pages relate to each other. You can easily reorganize a page(s) by drag and drop—even make a top-level page become a child page (and vice versa).

- **Sliders for Animating Panels** (p. 92)
  For advertising banners, news stories, or showcasing content, bring your panels to life using a range of transition styles including From the Left/Right/Top/Bottom, Medley, Accordion, Overlay, Scroller, and more. Timed panel displays let you choose what content gets displayed, and when!

- **Mobile-ready Theme Layouts** (p. 34)
  With mobile-ready Theme Layouts you can add mobile pages to your existing site or simply create a new standalone mobile site—each layout is fully optimized for cell phone access! Smart phone users can access your vital business information while on the move!

- **Desktop-to-Mobile Redirect** (p. 37)
  Automatically redirect smart phone users from desktop to mobile pages within either the same mixed-page "desktop - mobile" site or completely separate desktop and mobile sites! Redirect works by phone recognition or detected screen dimensions.
Welcome

• **Quick Build Tab for Easy Web Design**
  Access the most popular tools using the Quick Build tab—split into categories such as Layout Items, Navigation Items, Social Media, and Interactive Objects, as well as External / Managed Content, and many more. Large icons help you easily identify the type of content you need, then simply click-drag an icon onto the page for quick results—no prior knowledge of the user interface needed!

• **More Actions for Advanced Object Interactivity** (p. 111)
  Make your object hidden until rollover or change order in relation to other objects. For sliders, use "actioned" buttons for slider playback control with optional slider-controlled button state changes.

• **Website Google and Bing Validation** (p. 243)
  Prove ownership of your site, allowing you to view SEO-related site information and access a range of WebMaster tools (i.e., Analytics and AdSense).

**Ease of Use**

• **User Interface Improvements**
  With an eye on simplicity, toolbars have been slimmed down, while menus and right-click context menus are now more logically structured.

• **Starting New Sites is Easier Than Ever!** (p. 33)
  The Start New Site feature (via Startup Wizard) guides you through the key steps in setting up your website from scratch. Choose your web address, page sizing, number of pages, color scheme, and navigation bar in advance, avoiding unnecessary redesign later.

• **Studio Toolbar for Better Tab Control**
  This new toolbar gives you the flexibility of showing or hiding the Assets tab, Fonts tab, How To tab, or all tabs selectively.
Welcome

Creative

- **Assets for a Creative Boost!** (p. 219)
  Get creative with WebPlus's new Assets tab—the powerful new tab that lets you browse and search for professionally designed content (called assets). Web-related categories such as Sliders/Panels and Buttons are available, along with Graphics, Pictures, Picture Frames, Backgrounds, Page Content and entire Pages—all ready to drag and drop straight into your site! The tab also lets you store custom designs for global or current site use only. And finally... import PagePlus Pack Files into WebPlus!

- **Colors Toolbar for Easy Color Assignment**
  This new toolbar lets you apply Fill, Line, or Text colors from your current color scheme or Site Palette.

- **Multi-picture Backgrounds** (p. 56)
  Create more eye-catching backgrounds by adding combinations of pictures. For ultimate flexibility, each picture can be positioned individually. Great for independent header, footer, tiled, and logo designs!

- **Named Scheme Colors** (p. 62)
  To help keep track of what your scheme colors are used for, give them a name that reflects their use, e.g. "Background" or "Text - html".

Social Networking

- **Social Networking Feeds and Buttons** (p. 159)
  Facebook, Twitter, and Google Plus widgets let you add feeds and buttons to your web page. Website visitors can like or recommend your site (or any URL) on the social networking site of their own choosing.

- **Button Strip for Social Bookmarking** (p. 168)
  A Social Bookmarking Button Strip allows visitors to promote your site via Facebook, Twitter, Delicious, Digg, Google Bookmarks, and many more. E-mail and Print functions are also available from the strip.
WebPlus Help lists additional minor product improvements on previous versions. See the New Features topic in WebPlus Help for more details.

Installation

System Requirements

Minimum:

- Windows-based PC with DVD drive and mouse
- Microsoft Windows® XP (32 bit), Windows® Vista, or Windows® 7 operating system
- 512MB RAM
- 434MB free hard disk space
- 1024 x 768 monitor resolution
- Internet Explorer 7
- Internet connection required for Publishing to web and accessing online resources

Additional disk resources and memory are required when editing large and/or complex sites.

Optional:

- Windows-compatible printer
- TWAIN-compatible scanner and/or digital camera
- .NET 2.0 for text import filters (Word 2007/2010 + OpenOffice) (installed by default)
First-time install

To install WebPlus X6, simply insert the WebPlus X6 Program disc into your disc drive. The AutoRun feature automatically starts the Setup process. Simply answer the on-screen questions to install the program.

Repairing or changing your install

To repair or change the installation at a later date, select Control Panel from the Windows Start menu and then click on the Programs - Uninstall a program icon. Make sure the program disc is inserted into your disc drive, select the Serif WebPlus X6 entry and click either the Change or Repair button; simply follow the on-screen instructions to complete.
2 Getting Your Site Online
Start WebPlus

On program launch, the Startup Wizard is displayed which offers different routes into WebPlus:

For this Getting Your Site Online chapter, we'll concentrate on the Use Design Template and WebPlus Hosting options. Along the way, you'll be able to edit title and body text, insert a picture, add a new page, an Under Construction graphic, and publish your site (via Serif or other web hosting provider).
Pick a design

You don't need to start from scratch with WebPlus. Instead, you can create a complete website based entirely on a theme layout (i.e., a set of pre-designed template pages with a similar look and feel).

To pick your design, simply select a theme layout and a color scheme to suit your taste.

Choosing a theme layout and color scheme


2. From the Startup Wizard, select Use Design Template.

3. From the dialog, select a Theme Layout design from the main pane. We'll choose Eco as an example.
4. Pick a **Color Scheme** from the drop-down list at the top of the dialog (the first three schemes are designed specifically for the chosen template). The page thumbnails refresh to reflect the new page's appearance.

5. In the right-hand pane, uncheck all pages except the Home page.

💡 Use your up/down arrow keys for a live preview of each scheme in turn.
6. Click **Open**. Your web page is added to the Site tab.

Choosing a Pro Template

Instead of a theme layout, you could choose a Pro Template, i.e. a ready-to-go multi-page template already populated with royalty-free pictures. These templates are more trade/occupation-based (e.g., Painter & Decorator) rather than being based on a theme.

1. From the Startup Wizard, select **Use Design Template**.

2. From the dialog, scroll down the main window to the WebPlus X6 Pro Templates category and select a template.

3. Click **Open**. Your web pages are added to the Site tab.
Edit heading and text

Edit the page heading

1. On the Site tab, double-click the entry for the Home page.

2. Double-click on the heading text.

3. Type new text.

Edit body text

1. On your page, triple-click on a text frame to select a paragraph.

2. Type your text.
Instead of editing an existing text frame, you can create new text frames by using the **Text Frame** option on the Quick Build tab.

## Insert a picture

### Adding pictures to WebPlus

1. From the **Assets** tab (Pictures category), click **Add...**
2. From the dialog, navigate to a folder, and select your picture(s).
3. Click **Open**. Your pictures appear as thumbnails within the Pictures category.

To make a picture permanently available in your site, hover over the picture and click the icon.
Adding pictures to the page

- From the Assets tab (Pictures category), drag a picture thumbnail directly onto the page, inline into artistic/frame text (at a chosen insertion point), or into a picture placeholder (below).

- or -

- Click a picture placeholder to add a picture from your computer drive directly.

Add a new blank page

1. From the Site tab, click the down arrow on the tab's Add new page or link button. From the drop-down list, choose New Blank Page....

2. In the Page Properties dialog, enter a new Page name for the new page.

3. Click OK.
Add an Under Construction graphic

Before you establish a web presence by publishing your site, it's a good idea to add an "Under construction" graphic to your pages until you've finished your site. On publishing, you'll make web visitors aware that your site is in development and subject to change.

Graphics that you want to display throughout your site can be added to a page's master page.

1. On the Site tab, select Master Pages.
2. Double-click the master page used by your page. This is shown as a letter (e.g., A) on the page entry.
3. From the Assets tab, click Browse....
4. From the top-left Search box in the Asset Browser, enter "construct".
5. Select an "Under construction" graphic.
6. Click **Close**.

7. From the **Assets** tab, drag the graphic onto the bottom of the master page.

8. Right-click the graphic and select **Arrange > Attach to Bottom of Page**. On publishing, the under construction graphic always appears at the bottom of the page.

As you're on a master page you may like to add your company/club name, by double-clicking the placeholder text and typing.
Get Serif web hosting

Serif web hosting provides Serif-supplied web space for the user to publish to. By signing up to the hosting service you can simplify web publishing with the option of upgrading your web hosting package over time.

When you sign up, you'll be able to decide which name to use as your web address, depending on the package you've chosen. This is simply the address that web visitors would type into their web browser in order to visit the home page of your site. For example, addresses could be of the format (depending on your chosen package):

- `<prefix>.webplus.net`
- `<prefix>.com`

where `<prefix>` is the part of the address that you choose for yourself during sign up.

Be sure to visit www.serif.com/hosting/ for the very latest hosting packages available.

Setting up a Serif web hosting account

On WebPlus startup, you'll be able to set up Serif web hosting easily.

1. From the Startup Wizard, select **WebPlus Hosting**.
2. Follow the web hosting sign-up instructions available online. You'll need to:
   • Enter a valid email address and contact details.
   • Activate the link in an activation email that Serif will send to you.
   • Create the web hosting account, using your email address and password. You'll also need to enter your chosen <prefix> that makes up your web address.
   • In the Hosting details screen, select a hosting package.

💡 If you have a WebPlus hosting voucher, type it in the space provided in the above screen.

   • Enter payment details.

3. From the final screen, print out (or keep a record of) your hosting FTP account details. You'll need to keep these details safe, as well as transfer the account details into WebPlus via copy and paste.
Transferring your account details

WebPlus will check if you have no hosting account details set up in the program. If none are present, you’ll be prompted to add account details.

1. In WebPlus, click Publish site on the Standard toolbar.

2. From the pop-up dialog, in the Use existing hosting & domain name box, select Add Details.

3. In the Account Details dialog, transfer, by copy and paste, your web hosting account details (created on serif.com previously) into equivalent fields.

4. Click OK.
5. In the subsequent **Upload to server** dialog, click **Test** to check that your added details are valid. If a connection isn’t established successfully, review your hosting account details and your Internet connection, then retry.

⚠️ If you would like to use your own hosting and domain name rather than use Serif hosting, see Publishing your site (below).

## Publishing your site

To get your site online, you'll need to publish your page to your web space. For Serif hosting, we'll assume that you've set up your web hosting previously and transferred the account details to WebPlus. (See Get Serif web hosting on p. 20.)

⚠️ If you would like to use your own hosting and domain name rather than use Serif hosting the following instructions also allow you to enter third-party FTP details.

1. On the **Standard** toolbar, from the **Publish Site** flyout, click **Publish to Web**.

2. If no account details are detected you'll get a pop-up dialog to allow you to activate Serif hosting or to add your own third-party hosting details. From the pop-up dialog, in the **Use existing hosting & domain name** box, select **Add Details**, then enter your FTP account details.

3. From the dialog, ensure your account is shown in the **FTP Account** drop-down list. If not, click the down arrow to select it. The account details are displayed.

4. Click **Update Account**, then click **OK**. Your files are uploaded to your website.. and are now online!!

5. Click **Close**, and then enter your web address in your favorite browser.
You should now have a site online which can be used as a building block for further web development. The additional chapters let you explore WebPlus further, and will help you maximize your web design skills.

To keep to key principles, many assumptions have been made in this chapter about your site. By understanding WebPlus as a whole, you'll be able to customize your site's design to further fit your needs.
3 Setting up Sites and Pages
Creating a site using a design template

WebPlus comes complete with a whole range of categorized design templates which will speed you through the creation of all kinds of websites.

Each template offers:

- **Complementary design**—Professionally designed layout with high-visual impact.

- **Schemes**—choose a named color scheme to apply a specific look and feel.

- **Page selection**—select some or all template pages (e.g., Home, Products, About Us, etc.) to base your new site on.

Design templates come in two types—theme layouts and ready-to-go Pro templates.

**Theme layouts**
These offer a choice of themes (e.g., Eco) on which to base your site. Simply add your own pictures to placeholders and personalize placeholder text, then publish.
Pro templates
These are categorized templates containing royalty-free pictures which can be adopted to fast-track you to your completed website. You just need to personalize placeholder text, then publish.

Equivalent mobile-ready theme layouts are available that can be used to create your own site optimized for smart phone access. (See Creating mobile sites and pages on p. 34).

To create a site using a design template:

1. Launch WebPlus, or choose Startup Wizard... from the File menu, to display the Startup Wizard.
2. Select Use Design Template.
3. From the dialog, select a Theme Layout (desktop or mobile choices) or Pro template design from the main pane.
If needed, use the scroll bar or collapse a category to reveal more options (click the button next to the category name). On template selection, the right-hand pane refreshes to display thumbnails of that template's available pages.
4. From the right-hand pane, decide which pages you wish to be part of your site. Check or uncheck under each page to select, or click **Select All** to select all pages (click **Deselect All** to clear the current selection).

5. Pick a **Color Scheme** from the drop-down list at the top of the dialog (the first three schemes are designed specifically for the chosen template). With the drop-down list open, you can preview your pages as you scroll through the schemes by using your keyboard up/down arrow keys. The page thumbnails will refresh to reflect the new page's appearance.

6. Click **Open**.
The site opens to the first (Home) page, with the Studio's Site tab displayed on the right, showing the various pages that comprise the site in its Site Structure tree.

*The Get More Templates* category lets you access additional purchasable templates from Serif.

*All theme layouts contain assets, e.g. individual professional graphics, pictures, buttons, icons, picture frames, or backgrounds, to complement your theme layouts.*

**Opening an existing site**

You can open an existing WebPlus site from the Startup Wizard, via the **Standard** toolbar, or via the **File** menu. It is also possible to import web pages from existing HTML websites via the **File** menu. (See WebPlus Help for more details.)

**To open an existing WebPlus site (Startup Wizard):**

1. From the Startup Wizard, review your sites from the Open section. The most recently opened site will be shown at the top of the list. To see a thumbnail preview of any site before opening, hover over its name in the list.

2. Click the file name to open it.
To open existing WebPlus sites (during WebPlus session):

1. Click **Open** on the **Standard** toolbar.

2. In the **Open** dialog, select the folder and file name(s). For multiple sites, **Shift**-click to select adjacent multiple files or **Ctrl**-click to select non-adjacent files.

3. Click the **Open** button.

To open sites by drag-and-drop:

- From Windows Explorer, drag and drop the site’s preview thumbnail anywhere onto the WebPlus workspace.

To revert to the saved version of an open site:

- Choose **Revert** from the **File** menu.

**Font substitution**

WebPlus supports automatic font substitution as you open a WebPlus site which has fonts which are not stored on your computer. The dialog that shows also lets you manually substitute a missing font if necessary. See WebPlus Help for more details.
Starting a site from scratch

Although design templates (p. 27) can simplify your design choices, you can just as easily start out from scratch with a new, blank site. Your site is created by following a step-by-step wizard which helps cover the key aspects of your site's creation.

Steps involve configuring or adding the following:

- Site Name and Site URL
- Page Size/Height and number of pages
- Scheme colors
- Navigation Bar
- Assets

You can change these settings at any time after you've exited the wizard.

💡 The page size and height will be identical for all pages, including a master page that also gets created and assigned to every new page. Your navigation bar is added to this master page automatically.

To start a new site from scratch using the Startup Wizard:

1. Launch WebPlus.
   - or -

   Click [New Site] from the [Standard] toolbar.

2. Select Create>Start New Site.

3. From the dialog, follow the instructions at each step, then click [Next>] to move to the next screen.

4. Click [Finish] to exit the wizard.
To start a new blank site during your WebPlus session:

- Choose New from the File menu. The new site opens with a blank page using default page properties.

If you click Cancel from the Startup Wizard, you'll get the same result.

Creating mobile sites and pages

Before the advent of cell phone technology, your website was just termed a website. Nowadays, we can make a distinction in terminology between sites designed to be viewed via a desktop computer and those viewed via mobile devices (e.g., Apple iPhone, Blackberry, and other "Android" or "Windows Mobile"-based Smart phones). We call these desktop sites and mobile sites.

Mobile sites are distinct from desktop sites, as their pages are designed with easy reading in mind despite the Smart phone's smaller screen size. Not only is the page size reduced, but the general page design is simplified; the page will autoscale to the phone's screen dimensions.

Mobile sites with WebPlus
WebPlus lets you create mobile solutions for your website in several ways:

- Create a **standalone mobile site**.
- Create a **hybrid desktop - mobile site**, with redirection from desktop pages to mobile site pages (and vice versa), all within the same WebPlus project.
- Create a **separate desktop and mobile site** (above), with redirect from desktop pages to a separately hosted mobile site. Your mobile site is created from a separate WebPlus project.

### Creating mobile pages within your site

For page redirection, you'll need to create mobile pages to redirect to. WebPlus lets you include mobile pages from mobile-ready theme layouts (p. 27) to complement "desktop" theme layouts; they can be added to your site like any other template page.

#### To add a mobile page:

1. From the Site tab, click the down arrow on the **Add new page or link** button directly above the Pages window. From the drop-down menu, choose **New Template Page**....

2. From the dialog, ensure **Compare and Copy Master Page** is selected in the first drop-down list.

3. Select a mobile theme layout from the left-hand pane, and check the page(s) for addition. Mobile theme layouts complement any desktop theme layout you've created your site from—an "Arctic (mobile)" theme layout could be used with the "Arctic" theme layout.

4. Click **Open**.

In the Site tab, you'll see your mobile pages added to the end of your Site Structure tree.

💡 You can still create your own mobile site from scratch (p. 33).
Mobile file management

One important aspect of hybrid sites is how you keep your mobile pages separate from your desktop pages. This is recommended for efficient page management and for providing independent navigation bars for your desktop and mobile pages.

Some useful tips include:

- **Rename your mobile file names**: Mobile pages are named differently when added (e.g., index0.html instead of index.html), to prevent files being overwritten. You can also give your mobile pages an identifiable prefix, e.g. "m.index0.html" instead of "index.html", to make a distinction between file names. To do so, right-click **Page Properties...**, and edit the **File name** field to include a "m." prefix.

![Image showing page properties with "m." prefix]

- In the Site tab, ensure your desktop and mobile pages are made children of each Home page, by dragging desktop pages onto your desktop Home page, and mobile pages onto your mobile Home page. Your site will have two Home pages—one for desktop and one for mobile.

![Image showing site structure with desktop and mobile Home pages]
For navigation control, edit the navigation bar on both the desktop and mobile page’s master page. Right-click the navigation bar and select Edit Navigation Bar…. Select Child Pages Of..., then choose the appropriate Home page in the lower drop-down list, ensuring that Include child pages and Include home page are also checked.

Redirecting to/from mobile

Redirection assumes that you have pages to redirect from, and "target" pages to redirect to. Typically desktop pages redirect to mobile pages, but the opposite is also true. All redirection is carried out from the currently viewed page, according to certain conditions (if a mobile device or desktop computer is recognised, or the device's screen dimensions are matched). The browser's UserAgent value is used for browser recognition.

To redirect to/from a page or site:

1. Right-click the page and select Page Properties....
2. In the Page Properties dialog, select the Redirect menu option.
3. Click the Link... button which will provide a list of link destination types. (See Selecting a hyperlink target on p. 108). Select either Site Page for a mobile-ready page within your project or Internet Page to link to a page on a separate mobile site (e.g., m.mywebsite.com/products/productX).
4. Check Redirect only on condition to make the redirection occur in the event of a cell phone or desktop computer accessing the published web page. By default, redirection occurs when accessing via mobile device but you can enable a redirection condition from mobile to desktop pages or when a device’s screen dimensions are matched.
5. Set a suitable Time delay. This will allow your web visitor to view the desktop page for a time before redirection to the mobile page is attempted.
6. Click OK.

💡 By default, redirection occurs by sensing the web visitor’s browser type (e.g., Firefox or Firefox Mobile).
For effective search engine optimization, always try to redirect users between pages containing equivalent content. For example, redirect a ProductX desktop page to a ProductX mobile page.

Understanding site structure

The "structure" of a website has nothing to do with its physical layout, or where pages are stored. Rather, it's a way of logically arranging the content on the site so that visitors have an easier time navigating through it. One of the most useful organizing principles—which WebPlus strongly reinforces—is an "inverted tree" structure that starts with the Home page and then branches out to other pages. To the visitor navigating your site, this arrangement presents your content in a familiar, hierarchical way, structured into sections and levels.

- A **section** is a content category, each being a separate page, e.g. "Home," "About Us," "Gallery," "Products," and "Contact." The various major sections are typically listed on the site's Home page (and other section pages) in a navigation bar.

- The **level** is the number of steps (i.e., jumps) a given page is removed from its "parent" page. The Home page will always reside at Level 1, normally along with "section" pages. This allows navigation bars to work easily and automatically. Pages one step below the "section" pages reside at Level 2, and are considered to be child pages of the "parent" page. For example, a parent Products page could have two child pages called Product1 and Product2.
**Viewing site structure**

Two ways of viewing the site structure are possible: via the Site tab or via the **Site Structure View**. The latter is ideal for viewing larger sites.

**Via Site tab**

In WebPlus, the Site Structure tree (in the Site tab) provides a visual aid that lets you organize the content on your site into sections and levels. Here's how the above structure might appear:

The tab makes it easy to visualize relationships between pages and lay out your site in a way that makes sense for the content you have to offer. Of course, a website is truly an interconnected web of pages, and the tree structure doesn't prevent you from installing links between any two pages. But it does expose the major pathways within your site—up, down, and sideways. Logical section/level design makes your site easier to navigate, and WebPlus makes it simple to create **navigation bars** that mirror your site structure and help guide your visitors along those "main roads."
Via Site Structure View

For larger websites, **Site Structure view** can be used instead of the Site tab to provide a full-screen display that previews your "section and level" site structure as page thumbnails presented in a tree-based structure.

To view your site structure:

- From the **Standard** toolbar, select **Site Structure**.

For a selected page, you can perform normal page control functions such as insert, clone, or delete page, as well as edit page properties, all via the Site Structure context toolbar (or right-click).

The toolbar also lets you show and preview pages, include/exclude pages in navigation, and even Quick Publish the selected page(s).

A key feature is the ability to rearrange your site structure by dragging a selected page to a new position on the same or a different level. For multiple pages, you can select (by marquee select or **Ctrl**-select for non-adjacent thumbnails) on the same level or across levels and then **Ctrl**-drag to move the selected pages.

You can drag the page(s) to a "target" page, it will reveal square handles. Simply drag onto the appropriate handle to position your page correctly.
.drag to (A) adds page before the target page on the same level, (B) after the target page on same level, or (C) as a child of a target page.

If you drag a parent page, its child pages move too.

Setting site properties

Site properties allow settings to be made which will be applied across the entire site. Generally speaking, important site properties (page width, height, etc.) are automatically set on selecting a template or when starting from scratch. Other settings do not normally need to be modified (although you can at any time).

Some site properties such as page appearance and search-engine optimization settings are also mirrored on individual pages (via Page Properties; see p. 53). This lets you override or complement the "global" Site Properties, respectively, and apply "local" settings to specific pages.

To view or change site property settings:

- Choose Site Properties... from the Edit menu. The Site Properties dialog appears, with each displayed menu option reflecting an aspect of site properties.
Understanding pages and master pages

Looking at individual pages from a design standpoint, each WebPlus page has a "foreground" page and a "background" master page.

Master pages provide a flexible way to store background elements that you would like to appear on more than one page—for example a logo, background, header/footer, border design, or navigation bar. The key concept here is that a particular master page is typically shared by multiple pages, as illustrated over. By placing a design element on a master page and then assigning several pages to use that master page, you ensure that all the pages incorporate that element. Of course, each individual page can have its own elements.
The Studio's **Site tab** includes an upper Master Pages section containing your master page(s), and a lower Site Structure in the Pages window containing your standard pages. Each page shown in the window indicates the master page being used for that page.

For more varied page designs across your site, you can create more than one master page (see Adding, removing, and rearranging pages on p. 47). Once you have multiple master pages, they can be attached to separate pages or in combination on the same page.
Attaching different master pages

By default, pages created in new sites have a master page (Master A) automatically attached to them. However, if you want to use a different master page, you can attach it to the page instead of the original master page.

To attach a different master page to a page:

1. In the Site tab, right-click the page and select Page Properties....
2. From the dialog's Master Pages menu option, uncheck the original master page, then check the master page you want to use.
3. Click OK.

To detach a master page:

- Uncheck its entry in the Page Properties dialog (Master Page menu option).

Unchecking all master pages means that the page will use the site appearance (Edit>Site Properties...).

Attaching multiple master pages

WebPlus lets you apply multiple master pages to the currently selected web page for more complex page designs. This also lets you arrange the order of master pages in relation to each other and the page content itself.
As an example, let's say you have two designs existing on two separate master pages—"Master A" and "Master B". From Page Properties, you can place "Master B", containing the IPSUM text, in front of the selected page, with Master A used as the page background.

To attach multiple master pages to a web page:

1. In the Site tab, right-click the page and select Page Properties....
2. From the dialog's Master Pages menu option, check multiple master pages.
3. Click OK. The page will now be using the page elements of all master pages.

The Site tab’s Site Structure shows a web page with a plus sign if multiple master pages are attached (instead of A, B, C, etc.).
To reorder the page content and master pages:

- Select the master page entry in the Page Properties dialog (Master Pages menu option) and click the Up or Down button.

Editing master page objects

If you’re working on pages which have master pages attached, then master page objects will contribute to your page design. These objects can be edited quickly and easily from the page by using a control bar under the selected object.

To edit the master page object:

1. On your web page, select the master page object, to reveal the control bar.

2. Click Edit on Master Page. The master page is displayed for editing.

On occasion, you may want to make a master page object on your page independent from its master page. These objects can become editable by being promoted from the master page to the web page, with the original master page object being replaced by a freely editable copy.

To promote a master page object:

1. On your web page, select the master page object, to reveal the control bar under the object.

2. Click Promote from Master Page. This makes a copy of the original object, which can then be edited independently without affecting the master page.

All other pages using the master page will remain unaffected.
If you change your mind at any point you can reattach the object to the master page, leaving your page as it was originally.

**To reattach object:**

1. On your standard page, select the promoted object, to reveal the control bar under the object.
2. Click **Revert to Master Page**.

### Adding, removing, and rearranging pages

Using the Studio's Site tab, you can:

- Add pages.
- Delete pages.
- Add one or more master pages.
- Use drag-and-drop to rearrange pages within your site structure.
- Add pages from installed design templates.
- Add offsite links.
- Add HTML pages.
- Set a page to be the home page.

Use the upper Master Pages window of the Site tab to access master pages, and the Pages window (tab's central Site Structure tree) to access pages.
Incidentally, WebPlus also supports **HTML pages** and **offsite links** which can be inserted as for any other page. Page icons for both are slightly different in design to a standard web page to indicate that it is based only on HTML code (See WebPlus Help) or that it points to a location outside of the website.

As an example, compare the HTML page "Overview," the standard web page "Sales," and the offsite link "Member's forum."

Besides the Site tab, WebPlus offers a variety of other ways to manipulate pages:

- **Site Structure View** for a tree view of your site as page thumbnails, with supporting page manipulation.

- **Master Page Manager** for adding and copying master pages, as well as controlling multiple master pages.

**Adding pages**

**To add a new blank page:**

1. In the Pages Window of the Studio's **Site** tab, select a page after which you want to add the new page.

2. Click the down arrow on the **Add** button directly above the **Site** tab's Pages window. From the drop-down menu, choose **New Blank Page**.

3. In the Page Properties dialog, specify options for the new page from each of the menu options in turn (see **Setting page properties** on p. 53).

4. Click **OK**.
A new page appears at the specified location in the site structure. The page uses Site Properties (p. 41) for its dimensions. You can always move the page to a different position or level, or make it use a different master page (see Rearranging pages or Assigning master pages on p. 50 and 44).

- Any new page created will use the currently set Site Properties (Edit menu), such as the default page size and alignment, but you can overwrite site properties by editing Page Properties.

- The "blank" page may also be based on a master page, e.g. if the site was created from a template, and may therefore contain page content as defined by the blank page's master page.

**Adding master pages**

**To add a new master page:**

1. On the Studio’s Site tab, ensure the Master Pages button is clicked to expand the Master Page Window.

2. Click the Add button above the Master Pages window.

A new master page appears in the Site tab's Master Pages window.

- To reassign pages to particular master pages, see Understanding pages and master pages on p. 42.

**Deleting pages**

**To delete a page or master page:**

1. On the Studio's Site tab, select the page (or master page) to delete by clicking its entry.

2. Click Delete selected page above the appropriate window to delete the page.

- When you delete a page, you'll have the option to remove any hyperlinks in your site that point to it, or redirect the hyperlinks to another specified page (hyperlinks to anchors on the deleted page can optionally be deleted).
Adding HTML pages

HTML pages can be added to any Site tab’s Site Structure. Such pages are included in navigation as for standard pages.

To add an HTML page:

1. In the Pages Window of the Studio’s Site tab, select a page after which you want to add the new page.

2. Click the down arrow on the Add new page or link button directly above the Pages window. From the drop-down list, choose New HTML Page.

A new HTML page is added to the Site tab. See Creating HTML pages in WebPlus Help for more information.

Rearranging pages

Besides using the Site tab to add or delete pages, you can use it to rearrange pages as needed. Using the parent/child site structure, rearranging pages is an intuitive process whether you use drag-and-drop or convenient buttons. You can move a page:

- To a different sequential position (up or down) at the same level of the structure
- To a higher (parent) level
- To a lower (child) level

To move a page:

1. Display the Studio’s Site tab.

2. Click to select the page in the Site Structure tree.
3. (Using drag-and-drop) Drag the page entry up or down and drop it at a new position in the tree. Watch the cursor for feedback on the new position relative to that of the page just below the cursor:

- moves the page to the same level as, and following, the highlighted target page.
- makes the page a child of the page below the highlighted target page.

Adding template pages

While adding standard pages lets you start page design from scratch, you can make life a little easier by adopting "ready to go" pages from your installed WebPlus templates. To maintain the page's original design, any master page associated with the added page is "imported" with the page.

To add a new page from a template:

1. From the Site tab, select a page after which you want to add the new page.

2. Click the down arrow on the Add new page or link button directly above the Pages window. From the drop-down list, choose New Template Page....

3. From the Add New Page from Template dialog, select a template from the left-hand pane, and check the page for addition (check further pages for inclusion if needed).
4. WebPlus lets you control if an associated master page is copied with the page. Pick from the top-left drop-down list, choosing one of:

- **Copy Master Page.** To always copy the master page into your site.
- **Compare and Copy Master Page.** Checks if the master page already exists in your site then copies it if not present.
- **No Master Page.** The page's master page is never copied to the site.

5. Click the **Open** button. The page is added to the Site tab.

### Adding offsite links

You can also add an **offsite link** to your site structure. Typically, this would be a page or resource separate from your site that you wanted to include in your site's navigation structure. The offsite link appears in the Site Structure tree and in navigation bars, so you can manipulate it just as if it were a page in your site.

**To add an offsite link:**

1. From the **Site** tab, select a page after which you want to add the new page.

2. Click the down arrow on the **Add new page or link** button directly above the Pages window. From the drop-down menu, choose **New Offsite Link**.

3. In the dialog's Offsite Link tab, apply various link options:

   - Type a **Menu name** to identify the offsite link in the Site Structure tree (the equivalent of its page name).
   - Keep **Include in Navigation** checked if the link is to appear in site-wide navigation.
   - Check **Before** and/or **After** to apply horizontal separator lines above/below the page as a submenu item in navigation bars.
   - Add a **Description** to add extra page-related text information on the bar's submenu item.
4. In the Hyperlinks tab, select the link destination type (e.g., Smart Object) for the offsite link, and the specific offsite hyperlink target (e.g., a previously created Forum). (See Selecting a hyperlink target on p. 108).

5. In the Target Window tab, select a window or frame in which you want the target to appear.

6. Click OK.

**Setting your home page**

**To make a web page your home page:**

- Right-click on a standard page in your Site tab then select **Set as Home Page**.

**Setting page properties**

Your WebPlus site has its own general framework, consisting of the site itself; one or more **master pages**; and a number of individual **pages**. Each aspect of the framework has various **property** settings that contribute to the look and behavior of your site when it's published. Whether you start with a WebPlus template or from scratch, you can choose whether to stick with the default property settings or alter them to suit your needs.

**To view or change page (master page) property settings:**

- Right-click the active page and select **Page Properties**....
Adding backgrounds

WebPlus provides a wide range of backgrounds that you can apply to specific web pages or all site pages.

Backgrounds are available as assets (p. 219), stored in Asset Packs such as Footers, Gradients, Headers, Patterns, Photo, and Textures.

In addition, you can apply on-page or background colors to specific pages or all your site pages via page properties and site properties (p. 53 and p. 41, respectively); these can either be schemed or non-schemed.

💡 Site properties means all your created web pages will adopt the background settings, although you have the option to override on-page and settings per page.
Adding background pictures

To add a background picture:

1. From the Assets tab, select Browse....

2. In the Asset Browser dialog, select Backgrounds from the Categories section.

3. Navigate the Asset Packs to locate a background, then select an individual background or click Add All to include all the backgrounds from that pack. A check mark will appear on selected thumbnails.

4. Click Close. The background(s) will appear in the tab's Backgrounds category.

5. With the target page currently displayed, drag the background thumbnail onto the page.
6. From the displayed dialog, select an option to apply the background to all pages (i.e., site default background), or to just the current page. The first option replaces all backgrounds for pages that use site-wide settings simultaneously.

7. Click **OK**.

Alternatively, you can add a background picture via Edit>Site Properties... or Edit>Page Properties.... (Both using the Background menu option).

**Using multi-picture backgrounds**

For more advanced background design, WebPlus lets you base your background on a combination of pictures. Each picture can represent an important background page element such as a header, footer, tile, or logo design.

(A) Header, (B) Footer, (C) Tiled background, and (D) Company Logo.

💡 Use multi-picture backgrounds along with picture transparency and object gradient transparency for professional results.
To create a multi-picture background:

1. From Edit>Site Properties (Background menu option), click Add to include each picture in your background.

2. Select Repeat and Position settings as described above. Pictures are placed relative to the edges of the browser window.

3. Click OK.

Each added picture is displayed in the Background Pictures list. The multi-picture background example (see p. 56), was based on the following list.

<table>
<thead>
<tr>
<th>Image</th>
<th>Repeat</th>
<th>Position</th>
</tr>
</thead>
<tbody>
<tr>
<td>company_logo.png</td>
<td>None</td>
<td>Bottom Right</td>
</tr>
<tr>
<td>header_gradient.png</td>
<td>Horizontal</td>
<td>Top Centre</td>
</tr>
<tr>
<td>footer_gradient.png</td>
<td>Horizontal</td>
<td>Bottom Centre</td>
</tr>
<tr>
<td>tile_pattern.png</td>
<td>Tiled</td>
<td>Top Centre</td>
</tr>
</tbody>
</table>

The buttons adjacent to the list lets you move a selected picture up or down in the list. This rearranges the order in which each picture displays in relation to the other. A picture highest in the list will appear above all other pictures in your background.

Setting on-page and background colors

To set on-page and background colors:

1. Select Edit>Sites Properties....

2. From the dialog's Page>Background menu option, click the down arrow for the On-page Color or Background Color you want to change.

3. Select a different color from the drop-down list, which shows numbered scheme colors and other colors. Select More Colors... to optionally pick from a Color Selector dialog.

4. Click OK.
If you make the on-page color transparent, any background color shows, making the page boundaries invisible (content is still constrained to page dimensions).

If you've used a picture background with transparent regions, the Background color is still active and will show through; otherwise the picture will cover the background color.

For more details on other menu option settings, see WebPlus Help.

### Adding custom backgrounds

For a particular master page or standard page, you can override the site's on-page color, background color or background picture settings. Changing master page settings will affect all pages that share that master page. Pages that don't use a master page default to the site’s background appearance, but you can also override this via the Page Properties dialog in a similar way.

#### To add a custom background:

1. From the dialog's Background menu option, select Use page background from the Background drop-down list.

2. Click the down arrow for On-page color and select a color. Schemed colors are numbered.

3. Repeat the previous step for Background color.
   - or -
   For Background Pictures, click Add, then locate and select a picture(s) from the dialog.

4. Click OK.
Using color schemes

WebPlus offers an impressive selection of **color schemes** that can be selected when creating a site using a design template or from scratch. If you choose a template-based site, your color scheme selection will set the look and feel of your site—all templates are already "schemed". Selecting a different scheme dramatically changes the colors of page elements in your page layout with just one click!

*Color schemes: (A) Coral, (B) Smoothie, and (C) Default.*

When you initially create your site from a template you can select either one of three color schemes designed specifically for that template design, or just use any of the global color schemes. See Creating a site using a design template on p. 27.
Color schemes in WebPlus work much like a paint-by-numbers system, where page elements in a layout are assigned specific scheme colors by number.

These colors are stored in "paint jar" swatches, numbered 1 to 12, hosted on the Swatches tab.

These swatches represent the site color scheme. From here, you can assign scheme colors to page elements to make them schemed (this process is done already with templates).

Swapping to a different color scheme produces a completely different look with respect to color.

Give your schemed colors custom names to help you remember each color's main purpose—you can use the descriptions on the right as a guide. See Naming color scheme colors on p. 62.
Selecting color schemes

To select a preset color scheme:

1. Click **Color Scheme Designer** on the default context toolbar.

2. From the dialog’s Color Schemes tab, click a different color scheme sample from the list and click **OK**.

Any regions in the site that have been assigned one of the twelve color scheme numbers are updated with the corresponding color from the new scheme.

Each site can have just one color scheme active at any one time; this is called the **site color scheme** and is always shown in the Swatches tab. When you save a site, its current color scheme is saved along with the site.

💡 The **Color Scheme Designer** also lets you modify scheme colors and even create your own custom color schemes (see WebPlus Help for details).
Naming color scheme colors

With 12 separate scheme colors, it can sometimes be difficult to keep track of the primary use for each color. In this situation you can customize the name of each scheme color using the **Color Scheme Designer**.

**To name color scheme colors:**

1. Click **Color Scheme Designer** on the default context toolbar.
2. From the dialog's **Site Color Names** tab, type in a name to describe the main use for any schemed color and click **OK**.

Your custom schemed color names now display in the tooltip when hovering over a color scheme swatch on the **Swatches** tab.

For more information about applying scheme colors to site backgrounds, on-page color, hyperlinks, text styles, and other page objects, see WebPlus Help.

Dynamic guides

By default, WebPlus offers accurate object alignment and resizing using **dynamic guides** instead of setting page guides manually (or performing selection, transform, and alignment operations).

As you manipulate an object, WebPlus "visually suggests" possible snapping options such as snap to the placed object's left, right, top, or bottom edge, or to the object (or page) center.

You can only include up to three objects to snap to by dragging over or selecting those placed objects in advance.

💡 By default, dynamic guides are enabled, but they can be switched off (or back on again).
To switch off/on dynamic guides:

1. From the default context toolbar, click Options.
2. Select the Layout>Snapping menu option, then uncheck/check Use dynamic guides.

To snap to page centers, you must additionally check Page center.

Aligning objects

The use of dynamic guides is illustrated in the examples below and over. The darker object is already placed on the page, while the lighter object is being dragged into position.
Object center

Page center

💡 You can also align using combinations of the above, e.g. right and bottom, depending on the position of your dragged object.

💡 Dynamic guides are red or blue when alignment is in relation to other objects or the page, respectively.

Resizing objects

The use of dynamic guides when resizing objects is illustrated below. The darker object is already placed on the page, while the lighter object is being dragged into position.
4 Layout Items
Inserting text frames

Typically, text in WebPlus goes into **HTML text frames**, which work equally well as containers for single words or standalone paragraphs and articles. You can also use **artistic text** for standalone text with special effects, or **table text** (see Inserting tables on p. 87) for row-and-column displays.

What's a text frame?

A text frame is effectively a mini-page, typically containing frame text in one or more paragraphs that flow through the frame. In WebPlus, frame text is called a story.

- When you select a frame you'll see its bounding box, indicated by a border line plus corner and edge handles, and (if you clicked with the Pointer Tool) a blinking insertion point in the frame's text. In this mode, you can edit the text with the Pointer Tool. (For details, see the topic Editing text on the page on p. 207.)
- When you move a text frame, its story text moves with it.
- When you resize a text frame, its story text reflows to the new dimensions.

Creating frames

You add frames to a page as you would any other object. You can select, move, and resize any frame, but you cannot alter its basic shape. (See WebPlus Help for details.)

**To create a frame:**

1. From the **Quick Build** tab (Layout Items category), click **Text Frame**.
   - or -
   From the **Basic** toolbar, select **Text Frame Tool**.
2. Drag out to place the text frame at your chosen dimensions. 
   - or -

   Click on the page or pasteboard to create a new frame at a default size.

**To delete a frame:**

- Select the frame and press the **Delete** key. (If there's a selection point in the text, pressing **Delete** will remove characters after the cursor.)

**Putting text into a frame**

You can put text into a frame in one of several ways. The text will be converted to compliant HTML code.

**WritePlus story editor:** With a selected frame, click **WritePlus** on the Frame context toolbar.

**Importing text:** Right-click on a frame and choose **Insert>Text File...** (shortcut **Ctrl+T**) to import text.

**Typing into the frame:** Select the Pointer Tool, then click for an insertion point to type text straight into a frame, or edit existing text. (See Editing text on the page on p. 207.)

**Pasting via the Clipboard:** At an insertion point in the text, press **Ctrl+V**.

**Drag and drop:** Select text (e.g., in a word processor file), then drag it onto the WebPlus page. If you drop onto a selected frame, the text is pasted inline after existing text. Otherwise, a new frame is created for the text.
Frame setup and layout

The frame layout controls how text will flow in the frame. When a frame is selected and values for the margins are defined, its frame margins appear as dashed gray guide lines. These guides actually determine how text flows within the frame by providing padding between the text and frame edge. Text won't flow outside the frame margins.

To create frame margins:

- Click the frame edge, then drag column margin lines to adjust the boundaries of the column.

The illustration above shows how the cursor will change when hovering over the bounding box (1), after dragging inwards the frame margin can be adjusted (2), and after dragging downwards, the top frame margin can be moved (3).

To allow frame margins to be set, ensure the frame is selected (and not frame text). The frame should show a solid bounding box.

For precise margin positioning, you can optionally create frame margins via dialog by defining the Left, Right, Top, or Bottom Frame Margins.

To create frame margins using Frame Setup:

1. Select the frame and click Frame Setup on the Frame context toolbar.

2. From the dialog, you can define Frame Margins by setting Left, Right, Top and Bottom values.
Controlling overflowing frame text

Fitting story text precisely into text frames is part of the art of laying out websites. If there’s too much story text to fit in your text frame, WebPlus stores it in an overflow area hidden from view (but not lost!) at the bottom of the frame.

The Text overflow button displays under the overflowing frame to indicate this hidden text, so it’s important to ensure the text is made to display again, otherwise your story will remain truncated.

To do this, several options are open to you:

- Physically resize your text frame if you have space.
- Consider rewriting your story, making it more concise!
- Resize your text, as described below.

To resize frame text once frames are sized and positioned, various text sizing and AutoFit options are available on the Frame context toolbar.

Inserting pictures

The Assets tab (Pictures category) acts as a "basket" for initially gathering together and then including pictures in your site. Its chief use is to aid the design process by improving efficiency (avoiding having to import pictures one by one) and convenience (making pictures always-at-hand). For picture-rich websites in particular, the tab is a valuable tool for dragging pictures directly into bordered or unbordered picture frames or for simply replacing existing pictures on the page.

For photos from your digital camera, you can simply navigate to the folder containing your already downloaded photos (i.e., on your hard disk) and include them in the tab. Similarly, scanned images already saved to your hard disk can be added by this method.

WebPlus also lets you insert pictures from the Quick Build tab or Drawing toolbar.
Adding pictures to the Assets tab

To add pictures to the tab:

1. Select the Assets tab’s Pictures category, and click Add...
2. From the dialog, navigate to a folder, and select your picture(s).
3. Click Open. Your pictures appear as thumbnails within the Assets tab's Pictures category.

To reorder pictures in the tab:

- Select and drag a picture to a new position in the tab.

To delete a picture from the tab:

- Right-click a picture and select Delete Asset.

Adding pictures to the page

Pictures can be added to your site by dragging directly onto your page.
To add a picture to your page:

- From the **Assets** tab (Pictures category), drag a picture thumbnail directly onto the page, inline into artistic/frame text (at a chosen insertion point), or into a picture frame. Once added, the picture thumbnail indicates the number of times the picture has been used in the site (📸).

When placed, pictures are linked to your project by default and not embedded.

Photos can be embedded using 📸 **Import Picture** on the Basic toolbar (select **Embed Picture** in the dialog) or at any time using the Resource Manager.

**AutoFlow—adding content automatically**

**AutoFlow** lets you flow the pictures present in the tab's Pictures category throughout empty picture frames spread throughout your site (you can't reflow pictures once frames are populated with content).

**To automatically flow your pictures:**

- Click **AutoFlow** at the bottom of the **Assets** tab (Pictures category).

The pictures are placed sequentially in your site's available picture frames in the order they appear in the tab (reorder beforehand if needed).
**Searching for tagged pictures**

WebPlus lets you retrieve pictures by individual tag, i.e. XMP metadata stored within each picture. You can tag photos by using the Asset Manager.

**To search for pictures by tag:**

- Click in the search box at the bottom of the Assets tab and enter a search term, e.g. vacation. Matching pictures will appear directly above the search box in a temporary Search Results tab.

**Adding pictures with resizing and embed/link control**

As well as dragging a picture thumbnail from the Assets tab, pictures can be added to WebPlus by copy and paste or dragging a file from an external Windows folder directly onto your page.

WebPlus also lets you import pictures via Import Picture... on the Basic toolbar. You’ll be able to size the picture and embed/link the picture in your site. See WebPlus Help for more information.

**Replacing pictures**

You can swap a picture at any time, especially useful when you want to retain the position and dimensions on the page but want to update the picture itself. It can be used on any image (uncropped or cropped).

**To replace an image:**

- Click Replace Picture directly under the selected picture, locate and select the picture. Click Open.

**Displaying pictures in lightboxes**

Lightboxes are a simple way of displaying pop-up larger sized versions of pictures from thumbnails you add to your web page. A great advantage of lightboxes is that bigger pictures can be displayed on demand and are superimposed over your web page after a gliding animation.
To create a lightbox for a picture on your web page:

1. Select the picture (preferably a thumbnail).
2. Create a hyperlink to it (click **Hyperlink**... from the **Format** menu or right-click).
3. Select **Picture** from the menu, then from the Target Window tab, choose Lightbox from the **Type** drop-down list.

**Cutting out pictures**

**Cutout Studio** offers a powerful integrated solution for cutting objects out from their backgrounds. Depending on the make up of your pictures you can separate subject of interests from their backgrounds, either by retaining the subject of interest (usually people, objects, etc.) or removing a simple uniform background (e.g., sky, studio backdrop). In both instances, the resulting "cutout" image creates an eye-catching look for your site.

To launch Cutout Studio:

1. Select an image to be cut out.
2. Select **Cutout Studio** from the displayed Picture context toolbar. Cutout Studio is launched.
3. Click either `Keep brush` or `Discard brush` from the left of the Studio workspace, and paint regions to be kept or discarded. Follow the How To Help in the studio for more detailed information.

**Picture adjustments and effects**

*PhotoLab* is a powerful studio for applying adjustment and effect filters to pictures, either individually or in combination!

(A) main toolbar, (B) main workspace, (C) filter stack, (D) filter tabs, (E) Images tab

**To launch PhotoLab:**

1. Select the picture that you want to apply a filter to.
2. Click *PhotoLab* on the Picture context toolbar.
3. Select a filter from the filter tabs (Favorites, Adjustments, or Effects).
4. Adjust the filter's settings to your liking in the lower-right **Trial Zone**, then click **Commit**.
5. Repeat for additional filters.

6. Click **OK**.

For more information, see WebPlus Help.

**Inserting panels**

Panels are information boxes superimposed over your web page, which can host pictures and text (below), as well as shapes and line art.

The ability to superimpose panels means that you can increase the amount of information available to the web visitor without altering the underlying web page content. Panels can also be made to display only when required as you click or roll over buttons, pictures, or other assets. They can also be made to display permanently—great for navigation bars that never disappear on window scrolling!

Panels are versatile, and can be used for presenting:

- Showcased Events
- Sales information
- PayPal Buy Now Forms
- Useful tips and tricks
• Quick access information such as contact details and keyboard shortcuts.
• "Always-on" navigation (converted from a navigation bar; see p. 99).
• Image magnifier

Panels are also used as building blocks for creating animated sliders (p. 92). Like revolving advertising hoardings around sports stadiums, sliders can be made to change which panel is displayed at set time intervals.

To help you create professional panels, WebPlus provides a wide selection of modern backgrounds to base your panel on. Alternatively, you can customize a background preset further or create a panel background from scratch in WebPlus's Design Studio (see p. 80).

**Inserting your panel**

**To insert a panel:**

1. From the **Quick Build** tab (Layout Items category), click **Panel**.
2. Drag the cursor across your page to define the size and shape of your panel region.
3. (Optional) From the dialog, provide an HTML ID for the panel. This can be kept as is, as the ID will always be unique.
4. From the dialog, click the panel preview box.
5. Select a preset panel type from the flyout.

![Preset panel types](image)

The preview box updates with your chosen panel design.

6. (Optional) Drag the **Transparency** slider to set how transparent the panel appears against its background. You’ll need to preview your page to see your changes.

7. (Optional) Check **Align panel to browser window** to make your panel always available and fixed to a position when the web visitor scrolls the web page. Set a **Horizontal Alignment** and **Vertical Alignment** to control panel positioning.

8. (Optional) Check **Allow the panel to be dragged around the page** to let a web visitor move the panel around the page.

9. (Optional) Check **Panel is initially hidden** to make the panel hidden on dialog exit. Normally, this can be left unchecked to allow you to design your panel first.

10. Click **OK**.

    ![Default panel creation](image)

    A panel of default size can be created by dragging from the Quick Build tab directly onto the page. Alternatively, a default basic panel (without editing via dialog) can be created by **Ctrl**-dragging to the page.

    **To edit a panel:**

    - Double-click the panel and edit as described above.
Adding content to your panel

You should treat your panel as an empty building block which can be developed using WebPlus standard tools and features. By creating objects within the panel area, they belong to the panel. This extends to objects such as text frames, artistic text, tables, QuickShapes, and pictures. Dragging the panel will also move its associated objects.

Hiding/showing your panel

Why would you want to hide your panel once you've designed it? The power of panels comes with their ability to be hidden and then be shown as a result of rolling over or clicking a page object. This means that buttons, pictures, and gallery objects can reveal more detailed information only when needed.

To allow this to happen, the object has to be "brought to life", i.e. by assigning it an action (p. 111) that is triggered in response to a rollover or click. The action also connects the already created panel to the object.

To assign an action to a panel:

1. Right click the object and select Actions....
2. From the dialog, click Add... and choose Visibility from the flyout.
3. Select the panel from the Panel ID drop-down list, then an event from the Event drop-down list. The event relates to the behavior that occurs when you perform an action (i.e., when you click or rollover the object).
4. Click OK.
Finally, the panel can be hidden with a single click once you've finished designing it.

**To hide a selected panel:**

- From the context toolbar, select **Hide Panel**.

  The panel is replaced with a **Hidden Panel** icon. The panel is still there, and can be revealed again by disabling the Hide Panel button (by clicking). The Hide Panel option is the same as the dialog's **Panel is initially hidden** option.

On publishing your page, a rollover of the page object will display the panel.

**Creating custom panel backgrounds**

If you’re looking to further modify your chosen background preset (or work from scratch) you can use **Design Studio**, a background design environment similar to Button Studio. This allows you to focus on your background design without the distractions of other objects on the page, i.e. the design is displayed in isolation and centered on the page.
To create a custom background:

1. (Optional) From the Panel Properties dialog, select a preset from which to base your new background.

2. From the same dialog, click the Edit button. The Design Studio is launched with your background zoomed in to fit your workspace.

3. Using standard WebPlus X6 tools and tabs, customize your background to your liking, using the accompanying How To tab to interactively design your background.

4. Click Commit Changes on the main toolbar to exit. The modified background is updated in its original position.

The Design Studio lets you selectively prevent panel objects from scaling or stretching—Horizontal and Vertical scale flyouts on the Studio’s toolbar offer absolute object control. See the How To tab for more information.

Inserting a Photo Gallery

In WebPlus you can add a Flash™- or JavaScript-based photo gallery to any web page, using one of a range of eye-catching gallery types, styles, and a choice of photo navigation methods.
### Gallery types

Different Flash or JavaScript gallery types can be used to create your Photo Gallery.

<table>
<thead>
<tr>
<th>Gallery type</th>
<th>Features</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Professional Flash Photo Gallery</strong></td>
<td>Provides a top or bottom control bar (hosting preview thumbnail rollovers) on top of your main photo display.</td>
</tr>
<tr>
<td><strong>Professional Flash Photo Gallery (Live Feed)</strong></td>
<td>As for Professional Flash Photo Gallery but photo content is sourced online from your Flickr photostream (as an RSS feed), another RSS 2.0-compatible image host, or SlideShowPro Director.</td>
</tr>
<tr>
<td><strong>Flash Photo Gallery</strong></td>
<td>Provides a top or bottom control bar on top of your main photo display which offers basic navigation control and/or scrollable horizontal/vertical preview thumbnail rollovers. Photo grids and photo stacks are also available. You can also accompany your photo gallery with background music.</td>
</tr>
<tr>
<td><strong>JavaScript Photo Gallery</strong></td>
<td>Like Flash Gallery but offers JavaScript-based photo galleries. Photo grids, photo stacks, and lightboxes are available.</td>
</tr>
</tbody>
</table>

### Inserting a Photo Gallery

The Photo Gallery is inserted on the page, just like an individual photo, except that the currently displayed photo is surrounded by a background, navigation bar and preview thumbnails.

**To insert a Photo Gallery:**

1. From the **Quick Build** tab (Layout Items category), click **Photo Gallery**.
2. To insert the gallery at a default size, position the displayed cursor where you want the gallery to appear on the page, then simply click the mouse.
   - or -
   To set the size of the inserted gallery, drag out a region and release the mouse button.

3. Select the **Gallery Type** as described above.

4. Click **Next>**. For all Gallery types (except the Live Feed type) from the dialog, choose whether to:
   - **Add individual files**
     Click the **Add Files** button to navigate to then select the photo file(s) to open. Use Ctrl-click or Shift-click to select multiple non-adjacent or adjacent files.
     - or -
   - **Add all photos in a folder**
     Click the **Add Folder** button to navigate to a folder then select it to add its content.
     - or -
   - **Add from a digital camera or scanner**
     Click the **Add TWAIN** button. If needed, select your TWAIN source in advance of the acquisition process via **Select Source**... from the drop-down menu. You can also specify a folder in which to save the photos to once they have been acquired via **Set Export Folder**... from the drop-down menu. Click **Acquire**... to get your photos.

   - To delete one or all thumbnails, select and click the **Delete** button.

5. (Optional) Check next to any photo thumbnail(s) for manipulation;
   - To adjust photo order, use the **Up** and **Down** buttons at the bottom of the dialog.
• To add a caption, click the Caption column and input text, numbers and characters.

• 🎥 (Professional Flash Photo Gallery only) To add hyperlinks to photos, click Edit hyperlink. From the dialog, choose a Hyperlink Type—you can set no hyperlink, hyperlinks to the original image, or hyperlinks to a different link destination (e.g., Site Page or Internet Page).

6. To include selected photos within your site, check Embed Images. By default, photos are kept separate from the WebPlus file (using a link to the source file).

7. Click Next.

8. Select a Gallery style from the Gallery Style pane running across the top of the dialog.

9. (Optional) For the selected style, use the pane on the right to modify various gallery-wide options (autoplay, background/frame/font color, caption and navigation bar control, etc.).

10. Click Finish.

Editing the Photo Gallery

Once added to the web page, the Photo Gallery can be edited at any time.

To edit a Photo Gallery:

1. Select a gallery already present on your web page.

2. Double-click the gallery. The Photo Gallery dialog is displayed. The options available are the same as those available when the gallery was created.

3. To edit an attribute on all of the photos simultaneously, select all the photos using the check box at the top of the Image column and then make your changes using the options at the bottom of the photo list.

Once a gallery is placed on the page it's also possible to drag a corner of the gallery object to resize. Use the Shift key while dragging to maintain the aspect ratio.
Using online photo content

Instead of sourcing photos locally from your computer drive(s), your photo gallery can be populated with photos already online on Flickr or SlideShowPro Director via a live feed.

The key advantage of using a live feed for your photo gallery is that your published website's photo gallery is automatically updated as you upload new photo content to Flickr or SlideShowPro Director independently of WebPlus. This avoids having to add photos to your photo gallery and republish your website.

An essential pre-requisite is that you have to visit your Flickr or SlideShowPro Director website in advance of creating your "live feed" photo gallery. This is necessary because you have to copy the link to your photos and transfer it to WebPlus via copy and paste.

**To copy your photo link from Flickr website:**

1. Go to flickr.com, and sign in to your account.
2. Click **Your photostream**.
3. Scroll down the page to the [RSS feed icon](https://flickr.com), right-click the icon and select **Copy shortcut**.

💡 Ensure the copied link will still be on your clipboard when you’re ready to paste it into WebPlus.
To copy your photo link from SlideShowPro Director:

1. Go to the SlideShowPro Director website, and sign in to your account.
2. Locate your album and, under Publish, click the Copy button (in the Copy XML File Path option) to your clipboard.

To insert a live-feed photo gallery:

1. From the Photo Gallery dialog, select Professional Flash Photo Gallery (Live Feed).
2. Click Next>.
3. Enable RSS 2.0 media or SlideShowPro Director according to the photo source you want to use.
   - For the former, you can paste the copied RSS feed's link (described above) into the accompanying drop-down list.
     
     http://ap.flickr.com/services/feeds/photos_public.gne?id=77051211@N03&lang=en-us&format=rss_200

   - or -

   - For the latter, you can paste the copied XML file path (described above).
     

The remaining dialogs are configured as for other photo gallery types.
## Inserting tables

Tables are ideal for presenting text and data in a variety of easily customizable row-and-column formats, with built-in spreadsheet capabilities.

<table>
<thead>
<tr>
<th></th>
<th>£/€</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ranunculus aquatilis</td>
<td>345-56</td>
</tr>
<tr>
<td>Myosotis scorpiodes</td>
<td>334-B299</td>
</tr>
<tr>
<td>Nymphoides peltata</td>
<td>089-78</td>
</tr>
<tr>
<td>Menyanthes trifoliata</td>
<td>455-01</td>
</tr>
<tr>
<td>Caltha palustris</td>
<td>345-33</td>
</tr>
</tbody>
</table>

Each cell in a table behaves like a mini-frame. Like frame text you can vary character and paragraph properties, apply named text styles, embed inline images, apply solid text color fills, and use proofing options such as Spell Checker and Proof Reader. Some unique features include number formatting and formula insertion.

Rather than starting from scratch, WebPlus is supplied with a selection of pre-defined table formats, i.e. templates, that can be used. Simply pick one and fill in the cells with content.

WebPlus lets you:

- Edit the pre-defined format before adding a new table to the page.
- Create your own custom formats without creating a table. See Creating custom table formats in WebPlus Help.
- Edit existing tables to fit a different format (pre-defined or custom).
To insert a table:

1. From the **Quick Build** tab (Layout Items category), click **Table**.  
   - or -

   Select **Table Tool** from the **Basic** toolbar.

2. Click on your page, or drag out to set the size of your table. The Create Table dialog appears with a selection of preset table formats shown in the **Format** window.

3. Step through the list to preview the layouts and select one (use up/down keyboard arrows for a "live" preview of each). To begin with a plain table, select **(Default)**.

4. (Optional) Click **Edit** if you want to further customize your chosen format.

5. Set the **Table Size**. This is the number of rows and columns that make up the table layout.

6. Click **OK**. The new table appears on the page.

To modify the structure and cell contents of tables, please see Manipulating tables in WebPlus Help.

**Inserting a calendar**

The **Calendar Wizard** helps you design month-at-a-glance calendars for use on your web page.

The calendar is created as a scalable text-based table so you can edit text using the standard text tools. The properties of a selected calendar are similar to those of a table, and can be modified identically (see Manipulating tables in WebPlus Help). Like custom table formats you can create your own custom calendar formats.

The wizard lets you set up the month/year and calendar style/format, and controls the inclusion of personal events and/or public holidays. The **Calendar**
Event Manager lets you add personal events before or after adding a calendar to the page.

For calendar-specific properties, a context toolbar lets you change an existing calendar's month/year, modify calendar-specific properties, and manage calendar events (both personal and public holidays).

At any time, you can update calendar details throughout your site via Set User Details—in the same way that you'd set up the date (along with the time) on some alarm clocks. This is especially useful if you want to update the year on a year-to-view web page, composed of 12 monthly calendars—you only need to change the year in one place.

To insert a calendar:

1. From the Quick Build tab (Layout Items category), click Calendar.

2. Click on your page, or drag out to set the size of your table.

3. From the displayed Calendar Wizard, define options for your calendar including setting the year and month, calendar style (square, or in single or multiple column format), week start day, display options, switching on personal events/holidays, and calendar format.

To have your country's public holidays shown, check Add public holidays in the wizard and select a Region from the associated drop-down menu. To add personal events, check Add personal events additionally.

4. Click Finish to complete the wizard.

If you plan to use your calendar in subsequent years, simply update the Year setting in Tools>Set User Details.
To view and edit a selected calendar's properties:

1. Click the **Edit Calendar** button on the Calendar context toolbar.

2. Choose an appropriate tab (Date, Style, Events, etc.) and make your modification, then press **OK**.

Right-click (with the **Calendar** option selected) also lets you select, insert, distribute, delete, and adjust widths/heights for rows (or columns), as well as autofit to cell contents, but take care not to corrupt your table formatting!

### Adding public holidays

When you create a calendar you can set up the appropriate public holidays for the country you reside in. The days will show up in your calendar automatically if **Add public holidays** is checked in Calendar Properties.

#### To enable public holidays:

1. Select your calendar's bounding box, and click **Edit Calendar** on the context toolbar.

2. From the Events tab, check **Add public holidays**.

3. (Optional) Swap to a different country's public holiday settings by using the **Region** drop-down list.

4. Click **OK**.

#### To display public holidays:

1. Select your calendar's bounding box.

2. Click **Calendar Events** on the context toolbar.

3. Enable the **Show public holidays** option.
Adding personal events

You can complement your public holiday listings (e.g., Easter) by adding personal events such as birthdays and business launches so that the events show up on your calendar—simply use the Calendar Events button on a selected calendar’s context toolbar. Events show automatically on your calendar under the chosen date.

<table>
<thead>
<tr>
<th>May 2012</th>
</tr>
</thead>
<tbody>
<tr>
<td>M</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>T</td>
</tr>
<tr>
<td>W</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>T</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>F</td>
</tr>
<tr>
<td>S</td>
</tr>
<tr>
<td>S</td>
</tr>
</tbody>
</table>

To add an event:

1. Select your calendar’s bounding box.

2. Click Calendar Events on the context toolbar.

3. (Optional) Check Show events by date to add, edit, or delete events using a traditional calendar layout. Leave unchecked for a row-by-row Date/Event listing.

4. Click New event.

5. From the dialog, type, use the up/down arrows, or click Browse to select a date.

6. Enter your event text into the text input box. This displays in your calendar under the chosen date.

7. If the event is an annual event, check Event recurs annually.

8. Click OK. The event appears in the event list under the chosen date.

9. When you have finished adding events, click the Save button.
Inserting sliders

Sliders are a fun and exciting way to animate panels, and are ideal for a whole range of uses including advertising banners, news tickers and as alternative navigation bars.

Each slider is made up of a series of panels, with just one panel visible at any one time.

Each panel can show a mixture of pictures, text, and line/shape art. Like a slideshow, each panel can be made to appear automatically at set intervals, manually via navigation buttons, or at a set time.
Various **animation styles** can be used to control how each panel is displayed. You can pick from directional styles (e.g., Left to right, Top to bottom, etc.) as well as Medley (mixed styles), Accordion, Overlays, and Scroller styles. Time-based displays are also configurable so you could make each panel appear for a Start and End date (or time).

Pre-designed professional sliders are available from the **Assets** tab, and are typically customized once on the page. Panels can be added, reordered, or deleted to create the slider of your choosing.

**To insert a slider:**

1. From the **Assets** tab, select **Browse**....

2. In the **Asset Browser** dialog, select **Sliders / Panels** from the **Categories** section.

3. In the main pane, navigate the themed sub-categories to locate your slider, then select an individual slider or click **Add All** to include all sliders from the sub-category. A check mark will appear on selected thumbnails.

4. Click **Close**. The slider(s) appears in the **Assets** tab (Sliders / Panels category).

5. Drag a chosen thumbnail to your page.
To select a slider:

- From the **Objects** tab, select the Slider entry. You'll see the slider context toolbar appear above your workspace allowing you to edit the slider.

If you're editing the contents of a panel and need to select the panel itself, select **Edit>Select Parent**. Subsequently, the parent slider can then be selected by choosing **Edit>Select Parent** again.

The Asset Browser also provides some sliders which have a separate supporting navigation bar for moving between panels. Simply modify each slider panel, to customize its look and feel.

**Editing your slider**

Your slider comes with a set of panels by default. It's likely that you'll want to:

- **Add**, copy, or **delete a panel** within the slider.

- **Add content** to any currently visible panel. Remember that, like standalone panels, each panel in the slider can have any content added to it.

- **Swap a picture** for one of your own by clicking **Replace picture** under the panel's picture.

- **Add hyperlinks** from a panel's pictures, buttons, or other objects to another destination (e.g. to a main product page per panel), that displays in a new window or lightbox.

- **Change the Animation style** to one of:
  
  **Basic**: loops between panels, no animations
  
  **Opaque Fade**: loops between panels, each panel fades in over the previous one
  
  **From the Left/Right/Top/Bottom**: loops between panels, each panel slides in from the direction specified
  
  **Medley**: a combination of the above
  
  **Accordion horizontal/vertical**: panels are ‘stacked’ on top of each other with one edge showing
Overlay slide/fade: only uses two panels, on mouse over the second panel appears on top of the first
Scroller: panels are arranged in a grid and the view scrolls from one panel to the next
Date & Time: used to hide or show content depending on the current date and time

In addition, the slider's panel order and playback controls can also be modified.

To add a new panel:

1. Select the slider.

2. From the context toolbar, select Add Panel....

A blank panel is added at the end of the last panel in your slider. You can then add content to your panel (see p. 79).

💡 You can reorder panels within your slider via the toolbar’s Edit Slider option.

To navigate between panels:

- Click the navigation buttons directly under the selected slider.
- or -
  Select the Panel Selector from the Slider context toolbar.

Every slider also has a Foreground panel that displays its contents permanently. The panel is perfect for adding contact details, sale buttons, telephone numbers, or a picture that you always want to show.

The slider properties can be modified to change the animation style and various playback controls. Panels within the slider can also be reordered and made to display at set times.
To modify slider properties:

1. Double-click the slider.

2. From the **Options** tab, select a style from the **Animation style** drop-down list. The lower window will automatically preview the new style once chosen.

3. Select other playback controls using check boxes or drop-down lists.

4. From the **Panels** tab, you can **Add Panel**, **Copy Panel**, **Delete Panel**, or rearrange panel order by drag and drop (or by using **Panel Left/Panel Right**). Enter a new **Name** to uniquely identify each panel, and/or change its **Background Color**.

5. If the Animation style (in Options tab) is set to "Date & Time", enter a **Start Date**, **End Date**, **Start Time**, and **End Time** for each selected panel (except foreground panel).

6. Click **OK**.
5 Navigation Items
Inserting navigation bars

Navigation bars are used to allow the site visitor to jump between pages serving different purposes, e.g. Home page, Gallery, Products, and Contact Us. They are programmed to understand your site structure, making it easy to design a site that’s simple to navigate.

Technically, navigation bars facilitate movement between the various sections and levels of a site (see p. 38), providing links to your Home page and other top-level section pages, while pop-up menus link to child pages within each section.

In the varied navigation bar examples above, the pages in your site make up the navigation bar options, with any "second-level" child pages, such as Product 1 and Product 2, showing as pop-up menus (shown on the front-most navigation bar only).

You can easily install navigation bars at any level of your site, reconfigure them to link to a particular part of the site, change the appearance of the navigation bar, and exclude particular pages from navigation as needed.

Inserting navigation bars

Navigation bars can be added to any page but are typically added to the master page—as this saves you the trouble of pasting the same element to multiple pages.
When inserting a navigation bar, you can choose how your navigation will appear on your page by choosing:

- **Type**: The intrinsic design of your navigation bar (e.g., block, speech, traditional).

- **Navigation Type**: The site or custom structure on which the navigation bar is based.

- **Appearance**: The button, separator, and background design of the navigation bar. Either preset or custom designs can be used.

- **Pop-Up Menus**: The design of the text-based or button-based pop-up menu displaying off the navigation bar (if using child pages in your site structure).

**To insert a navigation bar:**

1. Select the page (or master page).

2. From the **Quick Build** tab (Navigation Items), click **Navigation Bar**.

3. Position your cursor and click at the point where you want your navigation bar to be placed (the bar will be aligned centrally from this point).

4. From the dialog’s **Type** tab, browse navigation bar categories, clicking + to expand if necessary.

5. Review each navigation bar in turn (or scroll through the bars using the keyboard arrows for quick browsing)! Select your chosen navigation type, e.g. Traditional 2.

6. From the **Navigation Type** tab choose whether to base your navigation bar directly on the site’s Site Structure (enable **Based on site structure**).

   - or -

   Customize the navigation bar’s options (enable **Custom**; see Customizing navigation bars on p. 101).
If choosing Site Structure, you can:

- Select the page level whose pages will be included in the navigation bar: Top Level, Parent Level, Same Level, etc.

- Depending on the main selection, you can opt to include the child page, anchors, home page, parent page, and/or Hide current page or disabled links.

- Set Target Frame/Window to change where the new page will open. Choose from Same Window (most common), New Window (useful for off-site pages), Top of Current Window, Parent Frame, Named Window, Document Frame, or Lightbox.

7. Click OK. The navigation bar appears on your page.

💡 For navigation bars from any Asset Pack, you can use the Asset Browser. From the Assets tab, click Browse..., then select the Page Content category. You'll see a range of navigation bars available for selection amongst other assets.

💡 Some navigation bars are color schemed, allowing further control of the bar's appearance. See Using color schemes on p. 59.

To edit a navigation bar:

1. Double-click the navigation bar.

2. Change settings available from each tab as described above.

Customizing navigation bar structure

By default, the navigation bar's structure will be based on your site structure. If you're looking to rearrange the order or hierarchy of your navigation bar items to be different from your Site Structure, WebPlus will allow you to customize any navigation bars by creating a custom navigation tree. You can add, edit, or delete elements which will access a range of link destination types (see Adding hyperlinks and actions on p. 108).
Once you're working with a custom navigation tree, the navigation bar will no longer automatically update when new pages are added to your site. If you still want this to happen, you'll have to base your bar on the site’s Site Structure.

To customize a selected navigation bar:

1. Double-click the navigation bar.
2. From the Navigation Type tab, enable the Custom option.
3. Rearrange the order of the navigation bar items by drag and drop (or use the Move Up, Move Down, Make Child or Make Parent buttons).
4. Click Add Link to add a new link to the end of your custom navigation tree, typically to add a page you’ve subsequently added to your site. The element is assigned a link destination, a target frame or window and a title in the displayed dialog. Click OK.
5. Click OK again. The navigation bar now uses the custom navigation tree to present menu options.

Click Reset to revert the navigation tree back to the site’s structure or Delete All to remove all entries in the custom tree.

The custom navigation tree can also be saved in your site, for use in other navigation bars.

It’s also possible to customize buttons, separators, and backgrounds for your own navigation bar styles. See WebPlus Help.

Inserting pop-up menus

Pop-up menus form an integral part of multi-level navigation bars (p. 99), showing as menus that display only on button hover over. The pop-up menu items represent child pages at lower levels of your site.

In WebPlus X6, you can also add pop-up menus to any object (a QuickShape, image, a gallery item, but most typically a button), the menu being essentially the same as those integrated with navigation bars. Like navigation bars, the pop-up menu items that display can be configured, either adopting the entire site structure (or part of it) or your own custom structure.
Pop-up menus are especially useful when you may want to show a limited, perhaps related, set of navigation links such as a set of products.

You have full control of what level of your site you want to present in the pop-up menu. In the example opposite, the pop-up menu is based on child pages belonging to a Products parent page (which would probably host the button and pop-up menu).

**To create a pop-up menu:**

1. Select an object to attach the pop-up menu to.
2. Select **Pop-Up Menu...** from the **Format** menu.
   - or -
   
   Right-click an object and select **Pop-Up Menu...**.
3. From the dialog's **Navigation Type** tab, check the **Show a pop-up menu...** option to enable navigation links to be associated with the object.
4. Enable **Based on site structure** or **Custom** to either use your site's navigation links as part of the menu or base the pop-up menu on your own custom structure (p. 101), respectively. With the former, you can base your menu on child pages of a top-level "Products" page.
5. From the dialog's **Menu Appearance** tab, select **Text pop-up menus** or **Graphical pop-up menus**. The latter implements buttons objects to make up its menus.

6. Select a menu option from the box, then edit input boxes, drop-down lists, radio buttons, and check boxes to suit your pop-up menu design. Graphical pop-up menu settings for buttons, separators, and background share similar settings to those of buttons.

All options are described in detail in Changing pop-up menus in WebPlus Help.

7. Click OK.

**Inserting buttons**

**Buttons** are an integral part of WebPlus navigation bars (see p. 99) but can also be added onto your web page, either standalone or as part of a form. When clicked by the web visitor, they can be made to display a hyperlink destination, pop-up menu, or trigger an action.

In WebPlus, buttons can be either a preset design or be created from scratch in the Button Studio. It's quite common to choose a preset and then customize it to fit your requirements (e.g., change the label text or its color).
To insert a preset button:

1. From the **Quick Build** tab (Navigation Items category), click **Button**.

2. Position your cursor and click at the point where you want your button to be placed. Alternatively, to set the size of the button, drag out a region and release the mouse button.

3. From the **Edit Button** dialog, click the button preview box.

4. Select a preset button type from the flyout.

The preview box updates with your chosen button design.

5. Enter a **Button Label** to identify the button, such as "Home", "Images", "Help", etc.
6. (optional) From the Form tab, select **Submit Form** or **Reset Form** if the button is within a form and is intended to have a submit or reset function.

7. From the Hyperlinks tab, select a link destination type which will direct the user to a target (e.g., Internet page, site page, file) via a hyperlink (see p. 108).

8. From the Target Window tab, select a window or frame type from the Type drop-down list. For example, you could open the target page in a "New Window".

9. Click **OK**.

Additional tabs, called Advanced and Actions, offer accessibility and search engine relationship (REL) attributes, and a range of actions (p. 111) which can control user interactivity with your button.

For a range of theme layout and website buttons stored in Asset Packs, you can use the Asset Browser. From the **Assets** tab, click **Browse...**, then select the Buttons category.

**To edit a button:**

- Double-click a button and edit as described above.
Creating custom buttons

If you’re looking to further modify your chosen button preset (or work from scratch) you can use **Button Studio**, a button design environment integrated into WebPlus. This allows you to focus on your button design without the distractions of other objects on the page, i.e. the design is displayed in isolation.

![Button Studio interface](image)

See WebPlus Help for more information.

**To edit a button design:**

- Select **Edit Button Design** from the context toolbar.
Adding hyperlinks and actions

Hyperlinking an object such as a box, some text, or a picture means that a visitor to your website can click on the object to trigger an event. The event is most commonly a jump to one of the following hyperlink targets:

- Site page
- Internet page (somewhere on the web)
- Internet Email
- Anchor (a designated target within a web page)
- File on your local disk or network
- Shopping cart
- Smart object (e.g., a forum, blog or CMS)
- RSS feed (or podcast)
- Navigation element
- User Data
- Picture

Actions are conceptually like hyperlinks, in that something happens on object click or rollover. They differ from hyperlinks in that a click or rollover produces an on-page user interaction with the object, rather than take you to a target destination. (See Applying actions on p. 111.)

Adding hyperlinks

To add a hyperlink:

1. Use the Pointer Tool to select the single or grouped object or highlight the region of text to be hyperlinked.

3. Click to select the link destination type, i.e. a Site Page, Internet Page, Smart Object, etc.

4. Depending on the link type, choose type-specific options in the right-hand pane as your hyperlink target.

5. Click OK.

You can view and manage all hyperlinks and anchors throughout your site by using the Site Manager, accessible from the Default context toolbar (and Tools menu).

**To modify or remove a hyperlink:**

1. Use the Pointer Tool to select the object, or click for an insertion point inside the linked text. (It's not necessary to drag over a hyperlinked region of text.)

2. Select Hyperlink from the Web Properties toolbar.

The Edit Hyperlink dialog appears with the current link target shown.

- To modify the hyperlink, select a new link destination type, target, and/or options.

- To remove the hyperlink, click No Hyperlink.
Selecting a target window

The Hyperlink dialog’s Target Window tab offers a range of target windows, frames, or a lightbox in which the link destination will be displayed.

To select a target window:

1. From the Edit Hyperlink dialog, select the Target Window tab.
2. Select an option from the Type drop-down list.

For artistic, frame, or table text, several options exist in the dialog's Appearance tab for how you want to derive your text hyperlink colors.

To change hyperlink appearance:

1. Choose other properties such as Title name (shown as hover-over text describing the hyperlink destination).
2. Use the Style drop-down list to choose how text hyperlink is formatted (if text is being hyperlinked).

To view or edit existing hyperlinks:

- Choose Site Manager>Hyperlink Manager... on the Tools menu to view, rename, or remove hyperlinks.
Applying actions

Actions can be associated with objects (not text) to allow for greater user interactivity. Available actions, triggered typically by a click or mouse rollover of the object, are as follows:

- **Alert**: Displays a pop-up alert box (on click).
- **Visibility**: Displays a panel (on rollover/click).
- **Opacity**: Makes objects transparent (until rollover), e.g. to only show navigation buttons on panel hover over.
- **Z-Index**: Changes the order (Z-index) of the object in relation to other objects (on rollover). A high Z-index value (e.g. 150) ensures the object appears in front of other objects on rollover. For example, a usually hidden picture in a picture stack can be promoted to the front on rollover.
- **Print**: Prints the current page via a Print dialog (on click).
- **Slider**: Adds an action (Play, Pause, etc.) to a supporting navigation button to control slider playback. You can add an appropriate action to each type of navigation buttons, i.e. a Play action can be applied to a Play button. (See Sliders on p. 92.)
- **Slider Feedback**: Changes the button state dynamically according to the slider's current playback state.
- **Custom**: Runs your own JavaScript code in response to a click, mouse, key press, and more.

💡 The Actions tab is only displayed when you select an object (but not on text selection).

💡 You'll need to create a panel in advance before you can assign an action to it, allowing it to display. For more information, see Inserting panels on p. 76.
To apply an action:

1. Select **Edit Actions** from the **Web Properties** toolbar.

2. From the dialog, click **Add...** and choose an option from the flyout.

3. From the dialog, configure the action.

4. Click **OK**.

On previewing or publishing, a click or hover over of the object will trigger the action chosen.

**Adding an anchor**

An anchor is a specific location on a page that can serve as the target for a hyperlink (see p. 108). Invisible to the web page visitor, it typically marks a point within some text (such as the start of a particular section) or a picture at some point down the page.

**To insert an anchor:**

1. Use the **Pointer Tool** to select the target object, or click for an insertion point inside the target text.

2. Select **Anchor** from the **Web Properties** toolbar.

3. In the dialog, type a name for the anchor.
4. (Optional) Check **Include Anchor in Navigation** to allow the anchor (typically a selected object) to be accessed via a navigation bar instead of a hyperlink. You'll need to ensure **Include anchors** is checked on your navigation bar settings. Give the anchor a title.

5. Click **OK**.

**To view or edit existing anchors:**

- Choose **Site Manager>Anchor Manager...** on the **Tools** menu to view, rename, or remove an anchor attached to a particular object. You can also include the anchor in page navigation.

### Using lightboxes

Lightboxes are a fun and modern way of displaying all kinds of web content superimposed over your web page. When you click an object, the light box presents your chosen content "on demand" in a pop-up window.
Lightboxes can be used to display:

- Pictures, as a larger sized version of a picture thumbnail already added to your web page.
- Forms in your site.
- A login box for access control.
- Pages (Site or Internet).
- A blog, forum, or RSS feed.
- A Word file, PDF, or any other file type.

**To create a lightbox for a picture on your web page:**

1. Select the picture (preferably a thumbnail).
2. Click **Hyperlink...** from the **Web Properties** toolbar.
3. From the Hyperlinks tab, select **Picture** from the menu.
4. From the Target Window tab, choose **Lightbox** from the **Type** dropdown list.
5. (Optional) Add a caption to the picture in the lightbox using the **Caption** box. You can also make the picture part of a slideshow using the **Slideshow Name** dropdown list. (See Lightbox slideshows on p. 115.)
6. Click **OK**.

To restrict the display size of this linked "lightboxed" picture, WebPlus scales down outsized pictures to a maximum width and height (default 800 x 600 pixels) always preserving their aspect ratios. Images with native dimensions less than these maximum dimensions are left unchanged. The maximum width and height can be modified. (See Setting site properties on p. 41).

**To create a lightbox to a local picture:**

- As above but choose the **File** option instead of Picture.

You'll have the option to embed or link the picture; either way, the picture always displays using its native image dimensions.
**Lightbox slideshows**

Simple lightbox slideshows can be created which are based on the pictures already placed on the same web page. The lightbox itself will display controls to navigate through your slideshow.

**To create a lightbox slideshow:**

1. Create a lightbox for a picture on your web page (as above).
2. From the **Edit Hyperlink and Actions** dialog, select the Target Window tab.
3. Enter a slideshow name in the **Slideshow Name** drop-down list. This will be used for other pictures to be added to this slideshow. Click **OK**.
4. Repeat for the next picture. The previously created slideshow name will show for other pictures. Select the slideshow name to include this picture.
5. (Optional) Enter caption text.
6. Click **OK**.

Lightbox slideshows only apply to pictures on the same page. If pictures are added to a slideshow from different pages, then a new slideshow will be created for each page.

**Lightboxes to any hyperlink target**

Lightboxes are not just limited to the display of pictures. As a light box is actually a type of window, any hyperlink target (p. 108) can be displayed within it—typically a form, login box, page in your site, Internet page, blog, forum, or RSS feed. You can also view a Word file, PDF, or any other file type (using the **File** option) in your lightbox.

**To create a lightbox to any hyperlink target:**

1. Select an object (picture, button, navigation bar, or any other object) or text.
2. Click ![Hyperlink](image) from the **Web Properties** toolbar.
3. From the Hyperlinks tab, select a hyperlink target from the menu.
4. From the Target Window tab, configure the lightbox as described previously.

**Setting global lightbox properties**

As with most settings in WebPlus, you can customize lightbox settings for the current site. Settings can be adjusted for general lightbox controls (including border type), caption controls (font, font size, font color, opacity), and background settings (color and opacity).

**To modify lightbox properties for your site:**

1. From Edit>Site Properties..., select the Features>Lightbox menu option.
2. Modify settings in the General, Caption, and Background Settings sections.
3. (Optional) Preview your lightbox using the Preview Lightbox... button, fine-tuning your settings between previews.

**Photo gallery lightboxes**

You can create lightbox-style photo galleries (see p. 81) if using a JavaScript Photo Gallery; a gallery style is available specifically for lightboxes.

If you choose this style, you can configure lightbox settings which will override the global Site Properties settings.
6 Interactive Objects
Inserting rollovers

A picture whose appearance changes in response to a mouse event is called a rollover graphic. Mouse events could typically be a hover over or mouse button press.

You can directly import rollover graphics created in Serif DrawPlus. (See WebPlus Help for more information.)

Rollover options

Adding rollovers is basically a matter of deciding which state(s) you’ll want to define, then specifying an picture variant for each chosen state. WebPlus provides several choices:

Normal State is the "resting" state of the picture before any rollover, and is always defined.

Over State is the state triggered by a mouseover—when the mouse pointer is directly over the picture.

Down State is triggered by clicking the mouse then keeping the button depressed while on the picture.

Another state, Down+Over (not illustrated) implies a mouseover that occurs when the picture is already Down, i.e. after it's been clicked.

You can also specify a hyperlink event—for example, a jump to a targeted web page—that will trigger if the user releases the mouse button while in down state.
And you can even group buttons on a page so they work together—and only one button in the group can be 'down' at any one time.

**To create a rollover graphic:**

1. In a suitable image-editing program, create the variant source pictures for each state you'll be defining.

2. Click **Rollover** from the **Quick Build** tab (Interactive Objects) and drag the insert cursor across your page to set the rollover size.

3. In the Edit Rollover dialog, on the **Rollover Graphic** tab:
   - Specify which rollover states (see above) you want to activate for each picture by checking boxes in the Rollover states section. For each one, use the **Browse...** button to locate the corresponding source picture and specify **Export Options...** for that picture (see **Setting image export options in WebPlus Help**).
   - Check **Embed files in site** if you want to incorporate the picture(s) in the site.
   - Check either **Normal** or **Down** as the button's initial rollover state.
   - Check **Radio button** if you want to link this rollover to others on its page (that have also got this option checked), so that only one is in a 'down' state at one time.

4. (Optional) On the **Hyperlinks** tab, define a hyperlink target for the rollover.

5. Click **OK**.

WebPlus displays the picture assigned to the Normal state. It's a good idea to preview the page and test each rollover picture, then return to WebPlus and revise as needed.

**To edit a rollover graphic:**

- Double-click the rollover graphic, to display the Edit Rollover dialog. Modify settings as appropriate.
Inserting pop-up rollovers

The most common use for pop-up rollovers in WebPlus is to hover over a picture thumbnail to show its larger representation, usually offset next to the thumbnail.

WebPlus lets you choose the position and size of the pop-up in relation to the "hovered over" thumbnail; even the thumbnail can be selected and resized at any time.

To insert a pop-up rollover:

1. Click **Pop-up Rollover** from the **Quick Build** tab (Interactive Objects) and drag the insert cursor across your page to set the rollover size.

2. From the Edit Pop-Up Rollover dialog, on the **Rollover Graphic** tab:
   - For the Normal rollover image click the **Browse**... button, and navigate to and select the image. Click **Open**....
   - For the Over image, the previously chosen Normal image is used by default (typically for photo thumbnails). However, you can **Browse**... to use a completely different image.
   - (Optional) For either image, specify **Export Options**... (see Setting image export options in WebPlus Help).
   - (Optional) Check **Embed image files in site** if you want to incorporate the image(s) in the site.
If captioning is required on pop-up rollovers this can be made to appear next to your Over image (see WebPlus Help for details).

For pop-up rollovers to work effectively you'll need to position the Normal and Over images on your page. Positioning is carried out from a dedicated dialog, where each state image can be moved and resized by dragging (or by setting absolute pixel values).

**To position rollover images:**

1. In the Edit Pop-Up Rollover dialog, on the Rollover Graphic tab, click the Set Rollover Position... button.

2. In the Rollover Position dialog, select an image. The drop-down list indicates the current selection status, i.e.
   - **Normal Selection**: a Normal image is selected and shows a green border.
   - **Over Selection**: an Over image is selected showing a blue border.
   - If you deselect an image, the drop-down list shows No Selection.

3. Reposition selections by dragging and/or resize selections from corner handles (aspect ratio is always maintained when dragging). Alternatively, enter exact **Left**, **Top**, **Width**, and **Height** values in the input boxes for fine positioning. The box's down arrows offer a drop-down list showing the last three values used for Normal, Over, and Captions (from top to bottom)—this lets you align images exactly.

4. (Optional) Check **Position relative to Normal image** to maintain the Over image's position in relation to the Normal image (when the Normal image is resized).

5. (Optional) Uncheck **Maintain aspect ratio** to allow your Normal or Over image resizing to be unconstrained. You have to then use the input boxes (not dragging) to affect unconstrained resizing.

The Normal image will show on your page, but the Over image will only pop-up after previewing or publishing.

By building up additional Normal images as separate pop-up rollovers on your web page you can create a stylish pop-up gallery of images, with each Normal image being part of a sequence of rollover thumbnails.
To edit a pop-up rollover:

- Double-click the Normal image on the page, to display the Edit Pop-Up Rollover dialog. Modify settings as appropriate.

Inserting a site search

WebPlus uses a powerful search facility which matches user search terms with text that appears in your site in artistic text, text frames or tables.

The search facility is created by combining a **Site Search Form** object with a **Site Search Results** window.

**Site Search Results**—creates a window in which the search results are displayed. Typically, this is placed and sized onto its own page, and does not appear in the site navigation structure.

You'll normally position the search results box ahead of adding the **Site Search Form** object.

**Site Search Form** object—the text box in which users type the word or phrase they want to search for. This text box is usually added to a master page and appears on all pages of the site.
The search results show a hyperlinked page name heading plus associated web page text for reference. Simply click the hyperlink to access the web page.

**To add Site Search Results:**

1. Choose **Site Search** from the **Insert** menu and select **Site Search Results** from the submenu.

2. Drag the insert cursor across your page to place your search results window.

💡 Keep the search results on a separate, perhaps new, page which can also have its own look and feel (double-click the object to alter site results appearance).

**To add the Site Search Form object:**

1. Choose **Site Search** from the **Insert** menu and select **Site Search** from the submenu.

2. Click the insert cursor to place your site search form object.

💡 Add the search object to the top of your master page to allow site-wide access to the search feature.

**To edit the appearance of search object:**

- Double-click the search object, to display its edit dialog. Modify settings as appropriate.
Inserting Google Maps

Use embedded Google Maps in your web page if want to make sure that a client can locate your headquarters, attendees can find that special meeting (or event), or identify special interest locations.

Each map will allow markers to be placed on the map to identify each location.

To insert a Google Map:

1. Click Google Map from the Quick Build tab (Interactive Objects) and drag the insert cursor across your page to set the map size.

2. From the Google Map dialog, enter your zip code, post code, or address in the Search for a location field, then click Search. As Google's geolocator is being used, WebPlus will sense your locale, and display local addresses preferentially.
Adding markers

You can add an unlimited number of markers to your Google Map. Each marker can display further details on hover over and mouse click.

To add a marker:

1. From the Google Map dialog, click Add.
2. In the Google Map Marker dialog, click a chosen location using the cursor.
3. Enter a Name for the marker. This "tooltip" displays on hover over and could represent a company or site name.
4. Assign a Click action to the marker, i.e. what gets displayed on button click.
5. Click OK. The marker appears on the map preview in green (to indicate it is currently selected). Repeat the process for each marker in turn.

Inserting an advert

Google AdSense is a free Google service which allows you to place advertising space on your web pages. Visitors to your pages will be served adverts according to the type of content your site is publishing.
To advertise, web developers must have an approved Google AdSense account (www.google.com/adsense), where you’ll be able to choose the type and format of adverts to be displayed, each advert being called a **unit**. You can copy and paste a generated code snippet **per unit** from the Google AdSense website and paste it into WebPlus’s Google AdSense advertisement dialog.

**To log in to Google AdSense:**

- Visit [www.google.com/adsense](http://www.google.com/adsense) to sign up or sign in to Google AdSense. Click the **Sign Up Now** button if you’re a new user or simply login using your existing user details; new users will be asked to enter your site’s URL, language, and agree to Google’s terms and conditions.

  > When you register, you’ll have to wait for Google to check that your website is considered suitable. You’ll be contacted by email with Google’s response. If successful, you can then create and manage adverts.

  > The registration process will analyze your website and provide advertising suitable to your website content.

**To create and manage adverts:**

1. Login to Google AdSense.

2. From **AdSense Setup**, choose **AdSense for Content**, then follow the wizard to select an ad unit, its format, corner style, and a tracking channel.

3. Copy the generated AdSense unit code snippet provided for the ad unit. You’ll need this to paste into WebPlus.

**To insert adverts in your web page:**

1. Select a web page (or master page) on which you want to place your advert.

2. Drag **Google AdSense** from the **Quick Build** tab (Interactive Objects) directly onto your page to set a default size.

  > The advert cannot be resized from its original Google AdSense advert size.
3. Paste the code snippet previously copied for the unit by clicking **Paste from Clipboard**. The snippet appears in your dialog and cannot be edited.

![Image of AdSense code snippet]

4. Click **OK**.

**To edit your advert:**

1. Change the format and color of your ad unit from **AdSense Setup** on the Google AdSense website, then copy the code snippet.

2. Double-click the advert on your page.

3. Paste the code snippet into the text box by clicking **Paste from Clipboard**.

4. Click **OK**.
7 External / Managed Content
Inserting framed documents

WebPlus allows one or more frames, also known as Iframes, to be placed on a single page, each accessing another page within your site. Just like a picture, a frame can be placed anywhere on the page and can be drawn to any size. While it's typical to link to a page, you can also link to a range of other link destinations (an Internet page, local file, Smart object, or stored user data) as well.

If adding a frame to a master page, ensure that the frame's destination page does not use that same master page (this avoids an unwanted page-in-page effect).

WebPlus also supports Active document frames. These are useful when you have a framed site and want to open a particular page in a frame. The name of the active document frame is identified by a combination of page and frame name. For example, "Home: ifrm_6" represents the "Home" home page and "ifrm_6" an automatically generated frame. Pages can redirect to the frame that should contain them—useful when found by search engine. To activate this for each page that will appear within a frame use Page Properties (Navigation menu option) and choose Open in active document frame and Redirect to this frame if necessary.
To create a framed site:

1. Select the page on which you would like to add a frame.

2. From the Quick Build tab (External/Managed Content category), click Document Frame.

3. Drag the cursor across your page to define the size and shape of your frame.

4. A dialog is displayed immediately into which you can apply various framed document settings. Choose from:

   - **HTML ID**: This is the uniquely assigned identifier for the frame. Normally this doesn’t need to be changed.
   - **Active Document Frame**: Check to allow hyperlinks to open a page in a frame on another page.

5. From the Contents tab, specify a link destination. Choose an icon representing a page in your site, e.g. Site Page, Internet page, Smart object, or a file on your hard disk.

6. Set the Frame Contents Information (the page name, internet page, etc.) which will differ depending on the link destination.

7. Click OK.

**Absolute URLs**

Since frames divide a web page into panes which each display their own HTML document, you need to make sure that each part of the frame is referenced using absolute URLs. To use Absolute URLs, you will need to set a Site Base URL—the part of the URL common to all pages, e.g. www.serif.com. WebPlus will use this to create the rest of the URL, making the absolute URL.
Inserting a blog

A blog acts as a personal journal on your web page which hosts your own published articles in an easy-to-use text editor. Articles can be commented on by visitors to the web page.

ForzaFootball blog

Forza Football Blog is about exploring the current football issues of the football day. Ecstatic, glum, angry, or laid back - have your say, your way!

Top goals in World Cups?
Posted by acapstick at 13:00, February 28th 2012.

Ever tried to do this? It’s not easy - i’ve had to redo my list at least 30 times!! Have a go yourself and let us know how you get on. Here’s ours!

- Bergkamp (Holland vs Argentina 1998)
- Owairian (Saudi Arabia vs Belgium 1994)
- Baggio (Italy vs Czechoslovakia 1990)
- Maradona (England vs Argentina 1986)
- Cruyff (Holland vs Brazil 1974)
- Alberto (Brazil vs Spain 1970)

Post to: Delicious, Digg, StumbleUpon, Reddit

6 Comments  |  Make a comment

In WebPlus, blogs are actually Smart objects, a common term to indicate that they are intelligent server-sided objects hosted on the secure online service called Serif Web Resources. As a result, a pre-requisite to using blogs, like all Smart objects, is that you have a valid Serif Web Resources account which you can create as you create your blog.

As a blog owner, you can manage the blog. Articles can be added, edited, or removed, while visitor’s article comments can be deleted. Another feature is the ability to allow multiple authors to add articles to your blog (see WebPlus Help).

💡 If you're on the move or working remotely, you can always monitor and update this managed content by using Serif Web Resources. A republish of your website is not necessary.
**Inserting blogs**

Blogs are like any object in WebPlus, in that you can easily insert one onto a chosen page.

**To insert a blog (on the page):**

1. From the **Quick Build** tab (External / Managed Content category), click **Blog**.

2. Drag the cursor across your page to define the size of your blog region.

If you don't have a Serif Web Resources account (or are logged out), you'll get the Serif Web Resources login dialog. To sign up, click **Create Account** under the **New User?** section.

- or -
If you’re an existing user and are already logged in, you’ll get an Edit Blog dialog.

3. From the dialog, enter a **Name** for your blog. This is the blog title that appears at the top of the published blog.

4. (Optional) Add a **Description** to describe your blog’s subject matter. Other options are described in more detail by clicking the dialog’s Help button.

5. Click **Save**. The light blue region defines the blog area.

**To edit your blog:**

- Double-click the blog.

💡 For more details about Serif Web Resources account control, see Using Smart objects (p. 151).
Managing your blog

Managing your blog lets you add, edit, or delete articles, and even comments associated with articles. You can also select an **Editor group** for multi-author article publishing. For new article (or ones for edit) you can create/edit your article in RTF, add tags, pick article poster, allow trackbacks, and make comments.

**To manage your blog:**

- Select the blog and click **Manage** from the context toolbar.

For more management information and a description of each option, click the Help button in the blog’s Smart object dialog.

For more information about Smart objects, see WebPlus Help.

Inserting a news window

News windows are a great way to present topical basic information on your website, typically on your home page. You can communicate urgent messages such as rescheduled or canceled meeting notices, that may be of relevance for only a short period of time.

The object supports RTF editing as well as paragraph styles, hyperlinks, inserted media, and even HTML source editing.

💡 If you’re on the move or working remotely, you can always monitor and update this managed content by using Serif Web Resources. A republish of your website is not necessary.
To insert a news window:

1. From the **Quick Build** tab (External/Managed Content category), select **News**.
2. Drag the cursor across your page to define the size of your news window.

If you don't have a Serif Web Resources account (or are logged out), you'll get the Serif Web Resources login dialog. To sign up, click **Create Account** under the **New User?** section.
- or -
If you're an existing user and are already logged in, you'll get an Edit dialog.

3. From the dialog, enter a **Name** for your news window. This is the window title that appears at the top of the published window.

4. Click **Save**. The light blue region defines the news window area.

To edit your news window:

- Double-click the news window.

💡 For more details about Serif Web Resources account control, see Using Smart objects (p. 151).

Managing your news window

To manage your news window:

- Select the window and click **Manage** from the context toolbar.
Inserting a forum

WebPlus lets you insert a Forum Smart object into your site which can be structured into separate categories containing one or more subforums.

For example, you could create the categories Philosophers, Branches, and General, while the Philosophers category would include the subforums Plato, Descarte, and Aristotle.

Visitors can view the topics posted in a subforum, the number of replies/views, the topic author, and the last post. The selection of a topic lets the visitor post a reply or start a new unrelated topic.
Within a selected subforum, a topic can be created by a forum visitor which can be viewed and/or optionally replied to by other forum visitors (by posting a message in response). This discussion forms the basis of forum debate, creating a "thread" of visitor replies.

**Forum features**

- Create different **categories** (e.g., Philosophers) containing multiple **subforums** (Plato, Aristotle, Descartes, etc.).
- Establish **access control** for users and moderators.
- Set forum **privacy** as publicly readable or private.
- Apply a **theme** (style) to the whole forum.
- Create, edit, and assign **user ranks**.
- Set **user permissions**.
- Manage and **moderate** the forum without republishing.
If you're on the move or working remotely, you can always monitor and update this managed content by using Serif Web Resources. A republish of your website is not necessary.

Inserting a forum

A forum can be added to the page like any other object, although you have the option to present the forum in a full-size window as an offsite link instead.

To insert a forum:

1. From the Quick Build tab (External/Managed Content category), click Forum.

2. Drag the cursor across your page to define the size of your forum region.

If you don't have a Serif Web Resources account (or are logged out), you'll get the Serif Web Resources login dialog. To sign up, click Create Account under the New User? section.
- or -
If you're an existing user and are already logged in, you'll get an Edit dialog.

3. From the dialog, enter a Name for your forum. This is the forum title that appears at the top of the published forum.

4. Add a Forum Description to describe what the forum is for.

5. Click Save. The forum appears on your page.

If you already have an Access Control smart object present in Serif Web Resources that you would like to use, this will be displayed in the Access Control (Existing) drop-down list for selection. Alternatively, you can just create a new Access Control smart object for the new forum by checking Access Control (New).

You can also create a forum by selecting Smart Object... from the Insert menu.
To edit your forum:

- Double-click the forum.

💡 For more details about Serif Web Resources account control, see Using Smart objects (p. 151).

Managing your forum

Up to now, you’ve just created a single subforum within a single category. To edit category name, subforum name, and add more categories and/or subforums within those categories, WebPlus lets you manage the forum. You can also control forum privacy, moderation, theme, and user ranking (most posts).

To manage your forum:

- Select the forum and click Manage from the context toolbar.

Forum security

By default, your forum is created with the Add new users on signup feature enabled, which means you don't need to do anything except moderate forum content when needed. Forum contributors simply register and enter their own login details to post or reply to topics.

Technically, a forum uses a User List Smart object for access control, which is automatically created along with your forum. Remember that a forum is a Smart object itself! It is possible to use the User List Smart object to manage forum users in several ways:

- **Manually add users.** You can add a set of users for private forums rather than have new users sign up by themselves.

- **Ban/suspend users.** In a lively debating environment, there’s often the need for some timely moderation to keep forum contributor's on-topic and adhering to "house" rules. You're able to ban or suspend users accordingly.
To manually add forum users:

1. Select **Smart Object** from the **Insert** menu.

2. From the Smart Objects library list, select the User List smart object of the same name as your forum.

3. Click **Manage**.

4. Use the Users and Groups tabs to manually add users, and the Bans tab to ban/suspend users.

5. Click **Exit**.

Forums, by their nature, are complex objects. For more configuration details and a description of options, click the Help button in any Smart object dialog.

Inserting an RSS reader

WebPlus lets you include an RSS feed from another website on your own web page.

The addition of the RSS feed reader to your page automatically subscribes yourself to the chosen RSS feed or podcast. There are other ways of subscribing to RSS feeds or podcasts via web browsers and iTunes, but here we'll focus on how to include the feed or podcast on your page and have it automatically receive articles or episodes.
Here's an example of a Reuters RSS news feed added to a WebPlus web page:

To insert an RSS feed or podcast on your page:

1. Locate an RSS feed or podcast from a website on the Internet. Look for one of the following distinctive symbols.

   ![RSS Symbol]

2. Copy the Feed/podcast URL to the clipboard by right-clicking the symbol.

3. From the Quick Build tab (External/Managed Content category), select RSS Reader.

4. A place cursor is displayed. To set the size of the feed window, drag out a region and release the mouse button. Instead, for a window of default size, simply click the mouse.

5. In the dialog, paste the Feed URL into the RSS Feed URL field.

6. Click OK.
The feed window will be filled with a peach color with the URL shown—you'll need to publish the page to view the current new feed. Remember that the content will update automatically as the feed is updated on the original website.

For Podcasts, when the web visitor views the feed, each episode can be played by clicking on the audio link, typically pointing to an MP3 file. Once downloaded and saved, the file can be played on a currently set default player (e.g., Windows Media Player).

**Access control**

Access control lets you apply security to your site, either to restrict access to specific pages or to control user access to forums and other Serif Web Resource features.

- **For page security**: login to a password-protected page(s) or via an on-the-page login box. Typically of use in personal websites or small enterprise websites, you can allow free access to most of your site, with only a limited set of pages accessible to selected web visitors. As an example, a Photo Gallery page can be made "private" but still be shared with a selected group of users (under password control).
The login details are stored in a user group associated with the page which contains a list of authorized users; the users are added manually by the web manager of the site or new users can self-register via sign up.

- **For Smart object security**: provides access control for forums, blogs, and CMS.
  - Forums: for management of users and group moderation.
  - Blogs: for adding and removing articles via an Editors group.
  - CMS: for managing articles in your CMS.

Access control is possible via Serif Web Resources by using a **User List** Smart object, which can be created to manage user groups and users, and how users sign in.

As a brief reminder, Serif Web Resources is a secure online service hosted by Serif that securely stores Smart objects (see p. 151) and any generated data. You can manage your User List Smart object, as for any other Smart object, either from within WebPlus or via www.serifwebresources.com at any time.

Successful establishment of access control on your website, is dependent on following the steps below.

- Setting up your User List Smart object
- Adding users (manual or self-registration)
- Enabling access control
- Adding a login box
- Advanced user control
Setting up your User List Smart object

You'll need to firstly create a User List Smart object then create one or more groups connected to that Smart object. Normally, you'll just need one Smart object per site—the individual groups can then be used to control access to specific pages or Smart object resources.

To create a User List smart object:

1. From the Insert menu, select Smart Object.
2. Login to Serif Web Resources (See Using Smart objects; p. 151). This assumes you have a valid login; otherwise you will have to register.
3. From the dialog, select the New... button at the bottom of the My Smart objects Library pane.
4. In the dialog, use the scroll bar to navigate the list of Smart objects, then select User List, then click OK.
5. From the pop-up dialog, select Access Control.
6. From the dialog, name your Smart object, save it in a profile, and modify colors and fonts for title, text/labels, buttons, or border.
7. Click Create. Your new Smart object is listed in your Smart objects Library, e.g.

![Rainbow_WWW (User List - Access Control Mode)](image)

8. Click Exit to logout of Serif Web Resources.

Once you've created your Smart object, you can create and associate user groups to it using the Manage feature.

To control user signup and security:

1. From the Insert menu, select Smart Object.
2. With your User List Smart object selected, in the My Smart Objects Library pane, click the Manage button to reveal the Users dialog.
3. To switch on self-registration user sign up to the Smart object, check **Enable signups to User List**. This allows a **Sign up** link to be shown on a placed login box.

4. For extra security at user sign in, check **CAPTCHA enabled**. CAPTCHA is an anti-spamming technique where arbitrary server-generated text is displayed; the web visitor enters the text for subsequent validation.

5. Enter a redirect URL in the **Redirect after login** box if you want to direct the user to a specific web page after successful login.

6. Click **Update**.

**To create a user group:**

1. From the dialog, click **Groups** from the top menu.

2. From the Create New Group dialog, enter a **Group Name**; this should reflect how the group is intended to be used, e.g. "Photoaccess".

3. Click the **Create Group** button, verify dialog settings, then click **Done**. The group will be added to the **Group** drop-down list.

**To manage a user group:**

- Select the group name from the **Group** drop-down menu, then click **Manage Group**.

From the dialog, you can rename the group and display the number of group users. You can make changes by clicking the **Update Group** button, or remove the group with the **Delete Group** button.
Adding users (manual or self-registration)

**adding users manually**

Typically, adding users manually is great for controlled environments such as small businesses, organizations, or clubs where users are "known."

For each user group that is created, a group of users can be added to each user group by manual entry or import from a comma-delimited text file.

It's possible to use either one user login (everyone uses the same login) or create a login per user for more user control (e.g., for membership lists).

**self-registration user sign up**

Conversely, user sign up is intended for more public access where controlling users is impractical—the user can simply register then sign in using their login credentials. The web manager still has the option to manage those users within their groups via the User List Smart object.

This method requires an on-screen login box to be placed on the page (normally a master page).

**To add a user manually:**

1. From the **Insert** menu, select **Smart Object**.
2. With your User List Smart object selected in the My Smart objects Library pane, click the object's **Manage** button to reveal the Users dialog.
3. From the **Add New User** section at the bottom of the dialog, enter the user's email address in the **Email** box.
With **Require activation** checked, an activation link will be emailed to the user along with an auto-generated password. When unchecked, only an auto-generated password will be emailed.

With **Email User** checked, an email will be sent to the user; if unchecked, no email is sent but the user is added. The password needs to be communicated to the user via other means (telephone or verbally).

4. Click the **Add User** button. The user is added to the user list in the **Users** section.

5. To assign users to a group, click **Groups** from the top menu.

6. Select the group from the **Group** drop-down list, then add the selected user from the Users box to the Group box by clicking the **Add** button (if adding all users, click **Add All**). The user will now belong to the user group. To remove, use the **Remove** (or **Remove All**) buttons from the group.

If configured, you can make users sign up by themselves, avoiding the need to manually add and manage every user as described above. This is done via Serif Web Resources.

**To enable self-registration user sign up:**

This method requires a login box to be added to the master page. A new visitor to the site can sign up to become a registered user (by clicking the Sign up link on the login box).

1. From the **Insert** menu, select **Smart Object**.

2. With your User List Smart object selected in the My Smart objects Library pane, click the object's **Manage** button to reveal the Users dialog.

3. Click Groups from the top menu.
4. From the dialog, select an existing group from the Group drop-down list, and click Manage Group.

5. Check Add new users on signup—the user’s login details on sign up will be added to the user group during registration. When checked, the sign in process allows access to all groups that are "sign up enabled", otherwise restricted pages will be protected.

6. Click Update Group and then Done.

If you're creating a new group, remember to click Add new users on signup in the Create New Group section.

When users sign up via an on-screen login box they will appear in every user group which is "user sign up enabled".

Enabling access control

To enable access control on your web page:

1. With the web page currently in view, click Page Security on the Default context toolbar.

2. Check Protect page with password to enable access control. You’ll notice that the Change/Manage button becomes active. Click this button to reveal currently available user groups (in bold) and the User List Smart object to which they belong.
3. From the User Groups dialog, select the user group, e.g. Photoaccess, then click OK. Your page's Page Security tab should show that the page is password protected and that the user group has been assigned.

4. Click OK, then OK again to exit the dialogs.

You'll now notice the page in the Site tab showing a key symbol which indicates that page security is set.

### Adding a login box

WebPlus lets you add a login/logout input box onto a page in your website. This means that a registered web visitor can gain access to any restricted pages by signing in to the site.

The login box is actually a visual representation of the User List Smart object; it is placed on the page as well as existing just in Serif Web Resources.

Add the login box to the site's master page. Any web page using the master page will then offer the user the opportunity to sign in to the website.
To add a user login box:

1. Follow the procedure under Enabling access control (see p. 149) but instead of exiting the dialog, pick a page to place your login box, then click the Insert button.

2. Position the Paste cursor where you want the user login box, then click the mouse to insert the object at a default size.

3. Enable self-registration user sign up as described previously (see p. 148).

Advanced user control

Some additional features allow you to import/export, suspend, and ban/unban users within user groups. A banned user is banned globally (access to all User Groups is prevented).

Any user can be deleted or temporarily suspended for breaking site rules (e.g., for posting defamatory statements on a hosted public forums). The next time the user tries to log on the message "Your account has been suspended" is displayed.

If more drastic action is required, a user's IP address can be banned from accessing Serif Web Resource objects (e.g., forums, etc.). As a last resort, even the ISP or organization to which the owner of the email address belongs to can be banned from access. This latter option is not recommended normally but may be necessary to prevent institutional malpractice such as professional spamming.

See WebPlus Help for more details.

Using Smart objects

For managed content, WebPlus uses server-sided Smart objects which store gathered web visitor data on Serif's own secure server space called Serif Web Resources. You can manage your smart objects directly from within WebPlus, or independently, and at any time, via www.serifwebresources.com once your site is published and live.
Let's look at each Smart object you'll find in Serif Web Resources and what you can do with them.

<table>
<thead>
<tr>
<th>Name</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Active Viewers</strong></td>
<td>Use to show how many people are currently viewing the web page.</td>
</tr>
<tr>
<td><strong>Blog</strong></td>
<td>A blog acts as a personal journal on your web page which hosts your own published articles in an easy-to-use text editor. Articles can be commented on by visitors to the web page.</td>
</tr>
<tr>
<td></td>
<td>You can also drag a blog onto the page by using the Quick Build tab. For more details, see Inserting a blog on p. 133.</td>
</tr>
<tr>
<td><strong>Content Management System (CMS)</strong></td>
<td>Lets the web developer add content to web pages remotely without accessing and publishing via WebPlus. Content is article-based where articles can be categorized, created, edited, deleted and arranged into categories. Site visitors can comment on and rate any article.</td>
</tr>
<tr>
<td></td>
<td>Your CMS can be given its own colors.</td>
</tr>
<tr>
<td><strong>Forum</strong></td>
<td>Add a thread-based discussion forum to your site, split into multiple categories and subcategories.</td>
</tr>
<tr>
<td></td>
<td>You can also drag a forum onto the page by using the Quick Build tab. For more details, see Inserting a forum on p. 137.</td>
</tr>
<tr>
<td><strong>Hit Counter</strong></td>
<td>A straightforward count of the number of hits on the current page (reset as needed). Different styles can be adopted.</td>
</tr>
</tbody>
</table>
Add a news window onto your page.

💡 You can also drag a news window onto the page by using the Quick Build tab. For more details, see Inserting a news window on p. 135.

Set up an online poll to canvass web visitor's opinions.

Host the online booking of hotel rooms, meeting rooms, rehearsal rooms, theater tickets, and more. Book by the hour or by the day, as recurring bookings, and with pricing options for different age groups.

Acts as an interactive chat window similar to Windows Messenger. Let your web visitors chat amongst themselves.

The User List Smart object operates in two modes (each mode selectable via a pop-up dialog):

- **Mailing List mode**: Have website visitors sign up to newsletters, party confirmations, information request, and many more. Lists can be controlled manually or by self-subscription. Email addresses can be imported as a delimited text file (CSV) or export to a range of formats.

- **Access Control mode**: Control accessibility to pages, forums, blogs, and CMS by using user groups. See Access Control on p. 143.
  
  - Enable CAPTCHA anti-spam protection during user registration.
  
  - Create user groups (with optional user sign-up, auto-login, and connection to Smart objects).
  
  - Add, remove, suspend, or ban users.
As Smart Objects are stored in Serif Web Resources, you can use Help buttons accompanying each Smart Object (as you create and manage them) for more detailed information.

For security reasons, the objects are only available via a **Serif Web Resources** login accessible from within WebPlus. If you don't have a valid username and password you must create a Serif Web Resources account first.

- If your email address is already known to Serif (maybe you've just registered or have registered previously) you'll be asked for a limited number of questions to complete account registration.

- If you're new to Serif and unregistered you'll have to complete full security as required. Full instructions are provided on login screens.

**To create a Serif Web Resources account:**

1. From the **Insert** menu, select **Smart Object**.

2. In the login dialog, click the **Create Account** link under the login boxes.

3. In the next dialog, enter your current email address, screen name, and a password twice. You'll need to review and agree to Serif's terms and conditions of use (via a check box).

4. Click the **Signup** button.

5. An additional dialog, will ask for personal details, plus a few check boxes if you would like to receive the Serif Community newsletter, Serif offers, and/or other third-party offers.

6. A confirmation email will be sent to your email address. Click the link in the email and you're ready to login to Serif Web Resources (via **Insert>Smart Object**).

**To clear Account details:**

- Go to **Tools>Options** and click **Clear Account Details** shown from the **Options>General** menu option. This will clear the stored login details for Serif Web Resources so that automatic login will no longer work. Details will need to be entered next time so be sure you've remembered your password.
To access Web Resources:

1. From the **Insert** menu, select **Smart Object**.

2. At the login prompt enter your username and your password. Check **Remember account details** to access Web Resources directly in future (bypassing the login screen).

3. Click the **Login** button. The Smart Objects dialog is displayed.

   🌞 Once created, you can check your account details from the Smart Objects dialog by clicking the **My Account** button.

To log out of Serif Web Resources:

1. From the **Insert** menu, select **Smart Object**.

2. Click **Log out**.

Creating Smart objects

Smart objects can be created via Serif Web Resources, by adding to a Smart Object library (the library lets you manage and edit each object). Objects can then be added to the web page immediately or at a later date.

- Some Smart objects such as forums, blogs, and news windows can be dragged onto the page from the Quick Build tab.

- Some Smart objects have interdependencies between each other. An example is the Forum Smart Object which when created, creates a User List smart object for access control as well.

To add an object to the library:

1. From the Smart Objects dialog, click **New**....

2. In the **Create Smart Object** dialog, use the scroll bar to navigate the list, then select a Smart object.

3. (Optional) For your Smart object to operate in a language other than English, select from the **Language** drop-down menu.

4. Select **OK**. Depending on the type of object selected, a different Create dialog will be displayed showing options specific to the Smart object.
5. From the dialog:

- Enter your own Name for the object.

- (Optional) Select a Profile from the drop-down menu if created previously.

- (Optional) A Filter Offsite string (access to the object will be restricted to the domain entered and will prevent the URL from being copied).

- (Optional) Change the object specific settings, e.g. for some objects you can also set the titling, colors (for body, text and border), and border thickness if appropriate.

6. Click Create.

The named object will be shown in a list in the My Smart Objects Library left-hand pane. Here's an example of a selection of Smart objects, some grouped under a custom profile named "Forza".
To add a Smart object to your web page:

1. From the Smart Objects dialog, select the chosen object from the left-hand pane and click the **Insert** button.

2. To insert the object at a default size, position the cursor where you want the object to appear on the page, then simply click the mouse.
   - or -

   Drag the cursor across the page to size the Smart object.

The Smart object will automatically preview on the page so you'll get a good feel for how your published Smart object will look.

Editing Smart objects

Once an object is created it can be edited either in the My Smart Object Library or directly on the page. Typically, you might want to alter the appearance of the object from its original settings, maybe change a Poll question, or reset a Hit Counter back to zero.

Editing an object only affects the object itself and does not alter any collected data.

The dialog options for editing and creating a Smart object are identical.

**To edit a Smart object in your library:**

- From the Smart Objects dialog, click the **Edit...** button at the bottom of the My Smart Objects Library pane.

**To edit a Smart object on your page:**

- Double-click the object to reveal the object's Edit dialog.

If you edit an object on the web page the change is also reflected in the Objects library and vice versa.
Managing Smart objects

While editing Smart objects affects how the object operates, managing Smart objects can be used to manage the object’s "gathered" data when the web page is published. Some Smart objects such as Hit Counters don't need to be managed as they just increment on each web visit (you can reset the counters though). However, other more complex Smart objects (e.g., Forums, Blogs, Resource Booker, User List, Poll, and Shout Box) store collected visitor data such as article comments, email addresses, poll results, and a chat messaging log. For Blog and User List smart objects creating and managing articles or users, respectively, is a fundamental part of the management process.

**To manage a Smart object from your library:**

- From the Smart Objects dialog, click the **Manage** button at the bottom of the My Smart Objects Library pane. The management options differ for each Smart object type.

**To manage Smart objects directly over the Internet:**

- Login to www.serifwebresources.com to control all your Smart objects independently of your WebPlus site. Use your usual Web Resources login as before.

For more management information and a description of each option, click the Help button in the any Smart object dialog.

The CMS Smart object can only be managed via www.serifwebresources.com.
Social Media
Inserting a Facebook widget

Facebook widgets can be added to your page to stream various types of live feeds to display on your page or a Like button that allows users to share and promote your page via their Facebook pages.

A Facebook account is recommended to use these widgets. For more information about Facebook, visit www.facebook.com.

Facebook widget types

There are several different types of widgets that can be added to a page to allow visitors to engage with site content in different ways.

<table>
<thead>
<tr>
<th>Widget type</th>
<th>Features</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity Feed</td>
<td>Displays the most recent activity occurring on your site, such as likes,</td>
</tr>
<tr>
<td></td>
<td>comments, and interactions made by the site visitor.</td>
</tr>
<tr>
<td>Like Feed</td>
<td>Lets visitors Like (recommend) your Facebook page and displays its most</td>
</tr>
<tr>
<td></td>
<td>recent posts. Also shows how many other users already like your page.</td>
</tr>
<tr>
<td>Recommendations</td>
<td>Shows personalized suggestions for content on your site that visitors</td>
</tr>
<tr>
<td>Feed</td>
<td>might like.</td>
</tr>
<tr>
<td>Like Button</td>
<td>Lets visitors recommend pages from your site by sharing your content</td>
</tr>
<tr>
<td></td>
<td>on their Facebook page.</td>
</tr>
</tbody>
</table>
Inserting a Facebook widget

The widget is placed directly on the page, the same as any other object.

To insert a Facebook widget:

1. From the Quick Build tab (Social Media category), click Facebook Widget then click on the page to place.

2. In the dialog, from the Type drop-down list, select either Activity Feed, Like Feed, Recommendations Feed, or Like Button.

3. Customize the behavior of your widget:
   
   • **Use Current Site URL**  
     Check to use the current URL of your site. Uncheck to enter a custom web address below. For Like Feed, enter the exact URL of a Facebook page.
   
   • **Link Target** (Recommendations Feed only)  
     Select Blank to open links in a new window, select Parent or Top to open links in the same window.
   
   • **Verb to Display** (Like Button only)  
     Select Like or Recommend as the word that appears on the button.

4. (Optional) Customize the appearance of your widget using additional options (these differ according to Type).

5. Click OK.

Editing a Facebook widget

Once added to the page, the Facebook widget can be edited at any time.

To edit a Facebook widget:

1. Double-click the widget. The Edit dialog is displayed. The options available are the same as those available when the widget was created.

2. Make your changes and click OK.
Inserting a Twitter widget

Twitter widgets can be added to your page to stream various types of live feeds to display on your page or a Tweet (or Follow) button that interfaces directly with Twitter.

A Twitter account is recommended to use these widgets. For more information about Twitter, visit www.twitter.com.

Twitter widget types

There are several different types of widgets that can be added to a page to allow visitors to engage with site content in different ways.

<table>
<thead>
<tr>
<th>Widget type</th>
<th>Features</th>
</tr>
</thead>
<tbody>
<tr>
<td>Favorites Feed</td>
<td>Displays individual tweets you've starred as a Favorite.</td>
</tr>
<tr>
<td>List Feed</td>
<td>Displays tweets by users added to a custom Twitter list. By adding users to a list, all their individual tweets will show when the list is viewed.</td>
</tr>
<tr>
<td>Profile Feed</td>
<td>Displays tweets on a specific user's profile.</td>
</tr>
<tr>
<td>Search Feed</td>
<td>Displays all tweets based on a chosen search query.</td>
</tr>
<tr>
<td>Tweet Button</td>
<td>Allows visitors to share your website by tweeting your site content to their Twitter profile.</td>
</tr>
<tr>
<td>Follow Button</td>
<td>Allows visitors to follow your account on Twitter.</td>
</tr>
</tbody>
</table>
Inserting a Twitter widget

The widget is placed directly onto the page, the same as any other object. There are different ways to insert different widget types.

To insert a Favorites, List, Profile, or Search Feed:

1. From the Quick Build tab (Social Media category), click Twitter Widget then click on the page to place.

2. In the dialog, from the Type drop-down list, select Favorites Feed, List Feed, Profile Feed, or Search Feed.

3. Customize the behavior of your feed:

   • Title (except Profile Feed)
     Enter text to show as the title of your feed. It is recommended to enter your Twitter username in this field.

   • Caption (except Profile Feed)
     Enter text to show as the caption for your feed. It is recommended to enter the feed type in this field.

   • Username (except Search Feed)
     Enter the name of the Twitter account you wish to stream from.

   • List (List Feed only)
     Enter the name of the list you wish to stream from. The list needs to exist on the Twitter account in the Username field.

   • Search Query (Search Feed only)
     Enter a phrase to search for. All recent public tweets containing the search phrase will appear in the feed.

   • Number of Tweets
     Enter a number (between 1-100) of tweets to appear in the feed.

   • Poll for new Tweets
     Check to poll Twitter for new tweets.

   • Load at Intervals/Load all
     Check to load tweets at intervals or load all at once (in seconds).
4. (Optional) Customize the appearance of your feed in the Appearance section.

5. Click OK.

To insert a Tweet Button:

1. From the Quick Build tab (Social Media category), click Twitter Widget then click on the page to place.

2. In the dialog, from the Type drop-down list, select Tweet Button.

3. Customize the behavior of your button:
   
   • Use Current Site URL
     Check to use the current URL of your site. Uncheck to enter a custom web address in URL to Tweet.

   • Tweet Text
     Enter Tweet Text. This text gets displayed in the Tweet field and is modifiable prior to Tweet submission.

   • Via
     Enter the name of a Twitter account to add to the end of the tweet as a "via @<username>". It is recommended to enter your username in this field.

   • Recommend
     Offers a recommended Twitter username that web visitors can follow. This appears after a Tweet has been submitted.

   • Hashtag
     Enter a phrase as a hashtag (phrases cannot have spaces). Tweets will be searchable by that hashtag.

4. (Optional) Customize the appearance of your widget using additional options (these differ according to Type).

5. Click OK.
To insert a Follow Button:

1. From the Quick Build tab (Social Media category), click Twitter Widget then click on the page to place.

2. In the dialog, from the Type drop-down list, select Follow Button.

3. In User to Follow, enter a Twitter username. Visitors will follow this account on Twitter when they click your button.

4. (Optional) Customize the appearance of your widget using additional options (these differ according to Type).

5. Click OK.

Editing a Twitter widget

Once added to the page, the Twitter widget can be edited at any time.

To edit a Twitter widget:

1. Select the widget already present on your page.

2. Double-click the widget. The Edit dialog is displayed. The options available are the same as those available when the widget was created.

3. Make your changes and click OK.

Once a widget is placed on the page you can resize it by click-and-dragging the edges or corners (except Tweet Button or Follow Button). Use the Shift key while dragging to maintain the aspect ratio.
Inserting a Google +1 button

Promote your site by using a Google +1 button to let visitors recommend your site content to Google+. When visitors click your button they will be able to share your web page by posting on their live stream or the +1 tab on their Google+ profiles. The +1 tab displays all links a user recommends to the public. The Google +1 button can also display how many others have recommended your web page.

A Google+ account is recommended to use this button. To find out more about Google+, visit plus.google.com.

To insert a Google +1 button:

1. From the Quick Build tab (Social Media category), click Google +1 Button then click on the page.

2. In the Configuration pane, check +1 Current Page to use the current URL of your site. Uncheck to enter a custom web address in Custom URL.

3. (Optional) From the Size drop-down list, select a size for your widget.

4. (Optional) From the Annotation drop-down list, select an annotation style.

5. Click OK.

To edit a Google +1 button:

1. Select the button already present on your page.

2. Double-click the button. The Edit dialog is displayed. The options available are the same as those available when the button was created.

3. Make your changes and click OK.

💡 You can add an anchor to your button by clicking Anchor on the context toolbar. For more information on anchors, see Adding an anchor on p. 112.
Inserting a social bookmarking button strip

If you add a strip containing a selection of social bookmarking buttons, your web visitors can share and promote your site via whichever social media or social news site is clicked. WebPlus lets you to create a strip with some of the most popular social websites including Facebook, Twitter, Reddit, Digg, etc.

Although not considered social media, the strip also lets visitors share your site's URL via email or simply print the current page.

💡 Why not position your button strip on a master page? This will make the strip available across all pages that use that master page.

To insert a social bookmarking button strip:

1. From the Quick Build tab (Social Media category), click Social Bookmarking Button Strip then click anywhere on the page to place it.

2. From the dialog, select a website from the Not Included in Strip list and click Add to add that website’s button to the strip. To remove a button from the strip, select a website from the Included in Strip list and click Remove.

3. (Optional) Click Up or Down to change the order icons appear on your strip.

4. Select a Share option: Site to share your entire site, or Page to share just the page.

5. Click OK.
To edit a social bookmarking button strip:

1. Select the button strip already present on your page.

2. Double-click the button strip. The Configuration dialog is displayed. The options available are the same as those available when the button was created.

3. Make your changes and click OK.
Adding sound and video

WebPlus lets you augment your web pages with sound and video files in a variety of standard formats, including both non-streaming and streaming media. In addition, WebPlus lets you include third-party videos already hosted on YouTube.

Sound

There are actually two sound playback options—background sound, where a sound loads and plays automatically when a specific page is first displayed in the visitor’s web browser, and linked sound, triggered by a mouse click (for example, on an icon or hyperlinked object). The supported audio formats are AIFF, AU, MIDI (.mid, .midi), MP3, RealAudio (.ra, .ram), and WAV.

Video

Linked video works like linked sound. Supported video formats are AVI, QuickTime (.mov, .qt), MPEG (.mpg, .mpeg, .mpe, .mpv), and RealVideo (.ram, .rv). (Non-streaming files must download in entirety to a user's computer before they begin playing; streaming files require a special player that buffers incoming data and can start playing before the whole clip has arrived.)

With both background and linked sound (or video), you have the option of embedding the source file in your site, as opposed to keeping it separate. Although embedding any file adds to the size of the site, it is the default option because you'll no longer have to worry about juggling separate files or the chance of accidentally deleting one of them. When you publish your site, WebPlus takes care of exporting and copying both embedded and non-embedded files.

To add background sound to a page:

1. Right-click the page in the workspace and choose Page Properties....
2. In the Page Properties dialog, select Sound and then check Use Sound File.
3. From the Choose Sound File dialog, browse to the sound file you want to add, select it and click OK.
4. If you do **not** wish to embed the file, uncheck the **Embed sound file in site** option.

5. To have the sound play back as a continuous loop, check **Loop sound**. Otherwise, it will play just once.

6. (Optional) Set **Export Options...** to define an exported file name and physical location. (See Setting image export options in WebPlus Help.)

7. Click **OK**.

The sound file will download and play back when the web page displays in a browser.

**To link from an icon, picture, or inline player:**

1. From the **Quick Build** tab (Media category), click **Sound** or **Video** and then click on your page.

2. Select your media location, either available locally (**File**) or via the Internet (**URL**).

3. Select a link display option (icon, inline, or picture).

4. Click **OK** to close the dialog, then click (or click and drag) with the cursor to place the icon, picture, or marker on your page.

**To add linked sound or video to a selected object or hotspot:**

1. For a hyperlink object, select a portion of text, picture or page object and then click **Hyperlink** on the **Web Properties** toolbar.
   - or -
   For a hotspot, select **Hotspot** from the **Insert** menu and then click and drag on your page.

2. In the dialog, select **File** to create a hyperlink to a sound (or video) file on your hard disk.

3. Click **Browse...**, locate and select the media file, and click **Open**.

4. If you do **not** wish to embed the file, uncheck **Embed file in site**.
5. (Optional) Set Export Options... to define an exported file name and physical location. (See Setting image export options in WebPlus Help.)

6. In the dialog’s Target Window tab, a range of target windows or frames can be chosen depending on how you want the link destination to be displayed. (See Adding hyperlinks and actions on p. 108.).

7. Click OK.

Inserting Flash SWF files

A Flash SWF file is a viewable movie using the Flash™ Player format. (Flash is a vector-based program designed to create and display small files on the web.)

You can preview the Flash file and/or customize the effect. Once placed into your site, the animation will appear static, but they will spring to life once the site has been exported and a visitor views your page in a web browser.

To insert a Flash file:

1. From the Quick Build tab’s Media category, select Flash and then click on your page.

2. Use the dialog to select the Flash file to open (click Browse... then select your SWF file). Click Export Options... to optionally define a different file name and/or file location. To keep the animation separate from the WebPlus file (using a link to the source file) uncheck Embed Flash files in site.

3. (Optional) In the Parameters window, click the Add... (or Edit) button to add (or edit) parameters as name/value pairs.

4. (Optional) In the Additional Files window, build up a library of files (e.g., images) which are used to make up your Flash movie. Think of it as a local library in which supporting files are easily at hand and easily referenced. Click the Add... button to navigate to then select files for addition (use Ctrl-click or Shift-click for contiguous or non-contiguous file selection, respectively).
5. (Optional) The Display box controls how the Flash movie is presented on your WebPlus page. Experiment with the options for different looping, transparency, alignment, scaling, and quality options.

6. Click OK.

To edit a Flash movie:

- Double-click your Flash movie.

If you experience any playback problems when Flash files are placed on your page, it is possible to uncheck Preview Flash objects in Tools>Options (User Interface>View menu). Exported web pages containing Flash files are unaffected.

Inserting YouTube videos

YouTube videos which are already published on the Internet can be included on your web page. Videos themselves are not embedded in your site; instead, just the unique YouTube video ID is embedded as you place the YouTube video on your page—a link is created from your web page back to www.youtube.com. This lets you add media content to your pages while avoiding uploading large videos as part of your site.
To embed a YouTube video:

1. Open the www.youtube.com website in your browser, and choose the YouTube video that you want to link to.

2. Copy the URL address for the video (or embed code). This contains an alphanumeric ID which uniquely identifies the video clip.

3. From the Quick Build tab (Media category), select YouTube and click on your page.

4. From the dialog, paste the video URL into the input box.

5. (Optional) Check/Uncheck the boxes to enable/disable video options.

6. Click OK.

Some websites may require their YouTube video(s) to be swapped for another on an occasional or more regular basis. For example, the site may host regularly changing top ten videos with topical content. Either way, WebPlus can replace videos without affecting their placement.

To swap your YouTube video for another, double-click an existing YouTube video. From the dialog, paste a previously copied video URL into the input box.
10 Forms
Inserting forms

Web-based forms allow information to be collected from visitors to your website in an efficient and modern manner. Some common form types include request forms, feedback forms, and guest books.

Form data can be collected in a variety of ways—by email, to a local/remote script file, or via Serif Web Resources.

Form Structure

The building blocks of a form comprise a mixture of text, graphics and form controls. A control can be a button, edit box, date picker, text area, combo box, check box, radio button, file browser, or CAPTCHA object. A typical form, perhaps an email feedback form, is made up of a combination of some of these controls.

From the web visitor's perspective, information is typed into text boxes or selected from check boxes, radio buttons, or drop-down boxes. The information entered can be numeric, textual, or a mixture of both, depending on the type of field. The tab order by which fields are to be completed is configurable, as is validation of input data. (See WebPlus Help for more about tab order and validation).
Each field has its own set of properties relating to its appearance, its value(s), validation, or the action expected of the field.

A form’s functionality only becomes active when your website is published (of course you can still preview your forms from within WebPlus, see Previewing your site on p. 233). When a web visitor enters data into, or selects a form option, the data will be sent back to a chosen destination when the form is submitted.

**Where is data sent?**

After submission, form data can be sent to one of the following:

- An email address (of the web developer).
- A script file (stored locally or remotely); this could write text to a text file or into a server database.
- Serif Web Resources; for transit of form data to your email (via Serif).

See Submission of forms on p. 184 for more information.

**Creating forms**

Several methods exist for creating forms: you can create a pre-defined ready-to-go standard form (opposite), select individual form controls for your form, or create a form from scratch; the first two methods use an easy-to-use Form Wizard.
To create a standard form:

1. From the Quick Build tab, select Form from the Forms category and click on the page.

2. In the dialog, click the Use and adapt a standard form icon and then Next>.

3. From the list of forms, select a form type while using the lower Preview pane.

4. Click Next>.

5. In the next screen, choose to add, modify or delete controls.
   - To add, click a button in the Add section.
   - To modify a standard object, select an existing control in the window and click Edit Control....
   - To delete a standard object, select an existing control in the window and click Delete (or press the Delete key).
   - To rearrange the control order, use the Move Up and Move Down buttons.

6. After clicking Next>, choose a destination for your form data by clicking a destination button. See Submission of forms on p. 184 for more information.

7. Select Finish to complete the wizard.
If you're looking for design freedom, WebPlus provides a blank form and form objects from which you can design your form from scratch. You can add form controls or standard form objects, or both. You can also customize and replace form submit and reset buttons. (See WebPlus Help for more details.)

Submission of forms

All forms have one thing in common—they must be submitted to allow data to be collected. To do this you can either create a custom Submit button or, more usually, use the ready-made button in the Form Wizard. The button needs to be present on the form and is typically used with a Reset button to clear all form controls of data.

Form data submission is possible via several methods.

No action

Form data is not submitted. This option is useful if you want to temporarily disable data collection or if you haven't yet set up scripting or Serif Web Resources. At a later time you can edit the form (right-click then choose Edit Form Properties...) and select a valid submission method.

An email address

Use this option to bypass the usual POST/GET submission methods. When the Submit button is pressed the web visitor's default email program is launched. The form data (passed in as a single string of text) is added to the email body and is ready to be sent to the configured email destination.

To set up email directly:

1. With the icon enabled, add a Form name.
2. Enter the destination Email address (or select an already known email address from the drop-down menu).
This option is for experienced web developers with scripting expertise.

**To set up a local script file:**

1. With the *Script file* icon enabled, add a **Form name**.
2. Navigate to your local script file, typically a .php, .js, .cfm, .cgi, .pl, .dll, or .exe file with the **Browse...** button.
3. Check **Embed file** to include the script within the site. If unchecked, the script file will be unconnected to the site (any updates to the script will be invisible to the site).
4. Optionally, the **Export Options...** button lets you define a web file name and folder for the script.
5. Choose a submission method, encoding type, target window/frame, and Character set.

Use if your web host will not allow you to run your own scripts on your web space. Instead, your web host may supply a basic script file that can be linked to from your web page. Typically, the script will send the form data back to your email address (already setup with your web host).

**To set up a remote script file:**

1. With the *Remote script* icon enabled, add a **Form name**.
2. Enter a URL pointing directly to a script file.
3. Choose a submission method, encoding type, target window/frame, and Character set.
Not everyone will have access to or even want to operate their own web server so, as an alternative to this, you can use Serif Web Resources (see p. 154). This is a free web to email gateway service which will transit valued form data via Serif and send it to your personal email address(es).

The service does require that you firstly have a Serif Web Resources login (for security reasons), which will allow you to create, edit and delete your own email destinations; these are called Form Email Targets.

**To set up Serif Web Resources:**

1. With the **Serif Web Resources** icon enabled, add a **Form name**.
2. Click the **Select** button (log in to Serif Web Resources if you’re not already logged in).
3. From the dialog, enter your target address details:
   - Enter a target email address in the **Email Address** box.
   - Enter a **Custom subject**, the subject line string that you’ll see in your web visitor’s email, e.g. Email Submission from Rainbow_WWW: Contact Details.
   - Add a **Confirmation message** which will be displayed to the web visitor after they click their Submit button.
   - In the **Language** field set the language in which the confirmation message will be sent.
4. Click **Add new**. The email entry is created and added to the Available Email Targets list. You'll notice that the entry is classed as "*Not Confirmed*". Before the service commences, you'll get an email confirmation message sent to your email address. By clicking the link, the service will be activated and the entry will change to "*Confirmed*".

5. (Optional) Repeat the above procedure to add further email targets, then select an email entry to make it active.

6. Click **OK** to exit.

The web visitor will receive a basic confirmation page generated by Serif Web Resources to acknowledge successful receipt of form data. As a useful tip you can create and assign your very own acknowledgment web page to be used instead of this basic page. Your own page is just like any other web page so you can add your own information, and design the page in the same style and appearance as the rest of your site.

**To add your own acknowledgment page:**

1. Right-click on the form (must submit data via Serif Web Resources) and choose **Edit Form Properties**....

2. Click the **Select...** button opposite the **Redirect To** box.

3. In the dialog, select **Site Page** and then select a **Page name** from the drop-down list.

4. Click **OK** twice to exit both dialogs. The new web page will display on the next form submission.

No personal data will be stored on Serif web servers. All form data is redirected in real time.
CAPTCHA gateway

To protect against spam emails, Serif Web Resources uses a CAPTCHA gateway if you've not added a CAPTCHA form control directly to your form (see Form controls in WebPlus Help). On form submission, this enables a security check offering a random text string for the web visitor to reproduce in an text box.

Passing the check initiates form submission.
11
E-Commerce Objects
Understanding e-commerce

E-commerce entails the buying and selling of goods on the Internet. It’s difficult to escape online retailing in any Internet session these days—you’ve more than likely used some form of Internet shopping at some point, when buying online CDs, books, vacations, etc. Any site that supports this kind of e-commerce activity will typically make use of a shopping cart system and a payment processing system. A shopping cart is a virtual basket (think of a supermarket basket) which stores your chosen items and is used in conjunction with a payment processing system (taking the place of the supermarket’s checkout).

For major companies, the shopping cart technology is developed in-house (maybe the payment processing is carried out by a third party company). For smaller companies or organizations, the shopping cart is normally a brought-in third-party solution due to the cost/resource limitations. There are many third-party shopping cart providers that can be used—all account-based and equipped to accept credit cards instead of using a traditional payment gateway (e.g., by phone).

So where does WebPlus fit into all this? Firstly, WebPlus allows you to choose one of several specially chosen shopping cart providers and, secondly, it allows you to connect to the shopping cart provider via a form or link on the WebPlus page. Forms allow for buying options (colors, quantity) to be set, as well as calculate tax rates, shipping, bulk items, etc. Links offer simple one-click purchasing without buying options. The features are provider-specific and as a result, vary widely.
Configuring your shopping cart provider

A number of different shopping cart providers can be configured within WebPlus. These are the most commonly used and some, like PayPal®, you may have come across directly as an eBay® customer. The configuration process directs you to the provider's own site from where you can sign-up as a registered user.

Use the provider's website to find out more about unique shopping cart features.

To set up a shopping cart provider:

1. From the Quick Build tab (E-commerce category), click E-Commerce then click on the page to place.

2. From the E-Commerce Configuration dialog, you have two options depending on whether you are an existing or new user of one of the shopping cart providers, i.e.
   - If you're a new user, select a shopping cart provider by enabling its radio button, then click the Sign Up Now button. The provider's website is shown in a new browser window from where you can register with the shopping cart provider.
   - If you're an existing user, enable the button next to your chosen provider, and click Next>. This option simply sets the default provider for your site (rather than set up a provider account).

3. The dialog is provider-specific and may show different options. As an example, choosing PayPal lets you define (via dialog) an email address to receive payments, cart handling charge, and use a "Sandbox" test tool for trying out your shopping cart before going live. Click Next>. For Sandbox testing, click the Find Out More button to setup a separate Sandbox login in addition to your "live" PayPal login.
4. (Optional; PayPal only) In the next dialog, check **Use the PayPal Minicart** to display a pop-up cart (as an overlay) that appears as products are added to the cart (the cart is subsequently minimized to the top-left of your browser window while items remain in your cart before checking out).

You can also configure, via the dialog, the minicart position in your browser window and edit or delete the default text displayed in the Minicart.

5. Click the **Finish** button to complete shopping cart configuration.

Once you've configured the shopping cart, you'll need to insert an e-commerce object.
Inserting an e-commerce object (PayPal)

The creation of e-commerce objects within WebPlus takes a Wizard-based approach. An e-commerce object can be added to the web page as a form or link (i.e., a simple button) by completion of a series of dialogs. Whether you choose to use forms or links depends on the characteristics of the items you are planning to sell, and how you want to sell your goods.

For example, if you are a trader you could create an E-Commerce button (as a Buy Now link). This option would make an assumption about the potential transaction, i.e. that the quantity, size, style, and color are fixed.

This is because a link is only a button and cannot host any "interactive" buying options that would be needed for more complex purchases. One buyer's click will buy a standard product offering—nothing more. Useful in some situations but completely inadequate in others.

More typical purchases use E-Commerce Forms which offer interactive buying options such as quantity, size, etc.

Here the web visitor can choose a quantity and a size for the item.

For e-commerce scenarios, where many items are to be offered for sale, it's possible to store items for sale in a Serif database (SDB) specially structured for use with e-commerce. By adding repeating forms (or areas) on your page, the database items can be listed after database merging, and offered for sale. See Using database merge with e-commerce in WebPlus Help.
The dialog that is displayed when you add an e-commerce object will entirely depend on the currently enabled shopping cart provider (see Configuring your shopping cart provider on p. 192).

The following procedures assume that PayPal is configured as your shopping cart.

To insert an e-commerce form or button:

1. From the Quick Build tab (E-commerce category), click E-Commerce then click on the page to place.

2. In the Add PayPal Object dialog, pick the email address which is to receive the payment information. WebPlus will already assume that the email address set during shopping cart configuration is used. Alternatively, uncheck the Use the site default account box and set a different email address to override the site default.

3. Pick an object type from the PayPal Form box. Select a "Form" radio button if you want to create an E-Commerce Form which will contain buying options (e.g., color or quantity). If the product for sale has no buying options then you can use a "Link" object (i.e., to create a clickable E-Commerce Button). Repeating form and area options let you add items from a database rather than defining them explicitly in an Item Details dialog (see Using database merge with e-commerce in WebPlus Help). Click Next>.

(Optional) If a Form or Button is not what you are looking for, enable the last option instead to paste code in a subsequent dialog. This would be code generated from PayPal's website (after login, look under Merchant Services). Click Next> to exit the wizard and paste the HTML code fragment onto your page.
4. In the next dialog, define a button for use. It’s possible to enable a standard text button (when enabled, enter any text string) or a standard image button (when enabled, pick from an attractive selection of presets in the scrollable window). Some images support automatic rollovers.

Click **Next >**.

5. Item identification, pricing, tax, and weight information can be defined in the **Item Details** dialog. Options to be selected are:

- **Item Name**: The item name for sale. Shown on the form and shopping cart.

- **Allow customer to specify the item name**: Check to swap the above Item Name for a box in which the web visitor can enter their own item name (also good for specifying donation details).

- **Item ID**: Add an easily identifiable string to track the item through PayPal.

- **Currency**: Set the currency in which the transaction will be made in.

- **Price**: The price for the item. Shown on-screen by default.

- **Allow customer to specify the amount**: Check to swap the above Price for a box in which the web visitor can enter their own price. Use with donation forms, where the customer sets the amount.

- **Override the tax settings**: Check to override provider's profile's tax setting for the item. If checked, specify a flat tax rate for the item, e.g. 0% for tax-free charitable donations.
• **Weight**: Set an item weight if you’re using weight-based shipping (US only), set in your PayPal profile. Typically, pounds (lb) are used as measurement, but kilograms (kg) can also be set if needed.

Choose from the above settings and click Next>.

If you're using e-commerce database merging, this Item Details dialog will instead let you choose an e-commerce database for use with your chosen provider. Remember to set the currency you wish to trade in.

6. For e-commerce forms only, two subsequent dialogs are shown:

• The **Item Description** dialog lets you optionally include an image (e.g., to preview the item for sale), and short and long descriptions that will show in the form. Click Next>.

• The **Item Options** dialog lets you create edit boxes, combo boxes, radio buttons, and fixed names (up to 10 options can be selected per form in PayPal; only one price-changing option) as appropriate—you can design from scratch or use previously saved options fields. Click Next>. Not shown for repeating forms.

7. In the **Item Details** dialog, set a default quantity in the input box, or check the box to let the user specify an amount at checkout (not shown for repeating forms).

- or -

Set the **Add Edit box** option to let the customer define the quantity to be ordered.

For shipping and handling associated with the order, enter a set amount for **Handling**, **Shipping**, and **Extra Shipping** charges. If left blank, the default PayPal's profile will be used instead. Not shown for repeating forms. Click Next>.

8. In the **Extra Customer Information** dialog, choose to prompt the customer for an address, don't prompt, or require the customer to enter an address. Optionally, ask a question using the text box. Click Next>.
9. The Payment Pages dialog offers some payment settings, i.e.

- Enter the name of your Checkout Page Style (if setup in advance via your PayPal login).
- Set a language for the PayPal login page. Pick for the drop-down list.
- Change the text for the Continue button on the Successful Payment Page.
- If needed, define Successful Payment Pages and/or Canceled Payment Pages. Enter the page's URL or select an entry from the drop-down list.

10. For e-commerce forms only, choose a **form layout** from the Form Layout dialog. Several check box options let you control what gets shown on the form layout. You can disable price, and if repeating area forms are used, hide/show the item image, short/long descriptions, fixed options, and a dummy quantity edit box. Forms can be reformatted with the **Reformat form now** check box.

11. Click **Finish**.

12. To insert the form or button, position the cursor where you want it to appear on the page, then simply click the mouse.

**To edit an e-commerce form or button:**

1. Double-click the form or button.


**To convert to a standard form:**

- Right-click on the existing e-commerce form and choose **Convert to Form**.
Importing text from a file

Importing text from a word-processor file is a quick way to build up text content for your site (but you can also create a story using WritePlus). If you use your current word processor (such as Microsoft Word) to create the text files for your site, you can import any number of files into one site.

As well as the WritePlus format (.stt), a range of popular word processing and text formats can be imported, including:

- ANSI text .txt
- MS Works .wps
- Open Office text .odt
- Rich Text Format .rtf
- Wordperfect .wpd
- Write .wri

For Microsoft Word formats created in any Windows operating system you don't need to have Microsoft Word installed locally. This means you can reuse third-party text content in WebPlus without the supporting application.

WebPlus will import text into a selected text frame or create a new text frame if one is not selected. See Adding text frames on p. 67 for more information.

- WebPlus will preserve the formatting of imported word-processor text. However, if you're using your word processor to create text specifically for WebPlus, you'll save time by typing as text only, and applying formatting later in WebPlus.

- Tables cannot be imported.
To import text from a file:

1. (Optional) If using an existing empty text frame, select the frame. If inserting text into a populated text frame, click for an insertion point (or select a portion of text to be replaced).

2. Choose Insert > Text File... from the Text menu.

3. From the Open dialog, select the format of the source file to be imported and locate the file itself.

4. Check the Retain Format box to retain the source file's formatting styles. Uncheck the box to discard this information. In either case, WebPlus will preserve basic character properties like italic, bold, and underline, and paragraph properties like alignment (left, center, right, justified).

5. Click Open.

6. The text will be imported into the pre-selected text object or a new text frame. For text frames, the text may overflow your frame. To resolve this, see Controlling overflowing frame text on p. 70.

Using artistic text

Artistic text is standalone text you type directly onto a page. Especially useful for headlines, pull quotes, and other special-purpose text, it's easily formatted with the standard text tools.

Here are some similarities between frame text and artistic text. Both text types let you:

- Vary character and paragraph properties, apply named text styles, edit text in WritePlus, and import text.
• Apply different line styles, fills (including gradient and bitmap fills), and transparency.

• Embed inline images.

• Apply filter effects and rotate/flip.

• Use proofing options such as AutoSpell/Spell Checker, Proof Reader, and Thesaurus.

• Manage their content and track font usage via the Site Manager.

And some differences:

• You can initially "draw" artistic text at a desired point size, and drag it to adjust the size later. Frame text reflows in its frame upon frame resize.

• Artistic text can be applied to a path but frame text cannot.

• Artistic text won't automatically line wrap like frame text.

• Text-fitting functions aren't applicable to artistic text.

To create artistic text:

1. Choose the **Artistic Text Tool** from the **Drawing** toolbar.

2. Click anywhere on the page for an insertion point using a default point size, or drag to specify a particular size as shown here.

3. Set initial text properties (font, style, etc.) as needed before typing, using the Text context toolbar, Text menu, or right-click (choose Text Format>).

4. Type directly on the page to create the artistic text.
Once you’ve created an artistic text object, you can select, move, resize, delete, and copy it just as you would with a text frame. Solid colors, gradient(bitmap fills and transparency can all be applied.

**To resize or reproportion an artistic text object:**

- Drag the object’s corner handles to resize it while maintaining the object’s proportions.

- To resize freely, hold down the **Shift** key while dragging.

**To edit artistic text:**

- Drag to select a range of text, creating a blue selection.

You can also double-click to select a word.

Now you can type new text, apply character and paragraph formatting, edit the text in WritePlus, apply proofing options, and so on.
Putting text on a path

"Ordinary" straight-line artistic text is far from ordinary—but you can extend its creative possibilities even further by flowing it along a curved path.

The resulting object has all the properties of artistic text, plus its path is a Bézier curve that you can edit with the Pointer Tool as easily as any other line! In addition, text on a path is editable in some unique ways, as described on p. 207.

**To apply a preset curved path to text:**

1. Create an artistic text object.

2. With the text selected, on the Text context toolbar, click the down arrow on the Preset Text Paths flyout and choose a preset path.

The text now flows along the specified path, e.g., for "Path - Top Circle".
To add artistic text along an existing line or shape:

1. Create a freehand, straight, or curved line or a shape (see WebPlus Help for details).

2. Select **Artistic Text Tool** on the **Drawing** toolbar.

3. Bring the cursor very close to the line. When the cursor changes to include a curve, click the mouse where you want the text to begin. Your line appears as a dashed path with an insertion point at its starting end.

4. Begin typing at the insertion point. Text flows along the line, which has been converted to a path.

To fit existing text to an existing line or shape:

1. Create an artistic text object.

2. Create a freehand, straight, curved line or a shape.

3. Select both objects. On the **Text** menu, choose **Fit Text to Path**. The text now flows along the specified path.

To remove the text path:

1. Select the path text object.

2. Click the **Path-None** button on the Text context toolbar's Path flyout.

The text remains as a straight-line artistic text object; the path is permanently removed.
Editing text on the page

You can use the Pointer Tool to edit frame text, table text, or artistic text directly. On the page, you can select and enter text, set paragraph indents and tab stops, change text properties, apply text styles, and use Find and Replace (see p. 216). For editing longer stories, and for more advanced options, choose WritePlus (Edit Story from the Text menu).

Selecting and entering text

The selection of frame text, artistic text, and table text follows the conventions of the most up-to-date word-processing tools. The selection area is shaded in semi-transparent blue for clear editing.

Nulla vestibulum eleifend
nulla. Suspendisse potenti.
Aliquam turpis nisi, venenatis
non, accum san nec, imperdiet
laoreet, lacus.

Double-, triple-, or quadruple-click selects a word, paragraph or all text, respectively. You can also make use of the Ctrl-click or drag for selection of non-adjacent words, and the Shift key for ranges of text.

To edit text on the page:

1. Select the Pointer Tool, then click (or drag) in the text object. A standard insertion point appears at the click position (see below).
   - or -
   Select a single word, paragraph or portion of text.

2. Type to insert new text or overwrite selected text, respectively.

Nulla vestibulum eleifend
nulla. Suspendisse potenti.
Aliquam turpis nisi, venenatis
non, accum san nec, imperdiet
laoreet, lacus.
To start a new paragraph:

- Press Enter.

To start a new line within the same paragraph (using a "line break" or "soft return"):

- Press Shift+Enter.

To switch between insert mode and overwrite mode:

- Press the Insert key.

Copying, pasting and moving text

You can easily copy and paste text using standard commands; drag and drop of text is also supported.

If you don't place an insertion point, the text can be pasted into a new text frame directly.

Setting text properties

WebPlus gives you a high degree of control over the fine points of typographic layout, whether you're working with frame text, table text, or artistic text.

To apply basic text formatting:

1. Select the text.
2. Use buttons on the Text context toolbar to change text style, typeface, point size, attributes, paragraph alignment, or level.

To clear local formatting (restore plain/default text properties):

1. Select a range of text with local formatting.
2. Select Ctrl-Space Bar on your keyboard.
Using fonts

One of the most dramatic ways to change your site's appearance is to change the fonts used in your artistic text, frame text, or table text. Applying different fonts to a character or entire paragraph can communicate very different messages to your intended readership.

Font assignment is very simple in WebPlus, and can be done from the Fonts tab, Text context toolbar, or in the Character dialog (via right-click, or from the Text menu).

The Fonts tab is switched off by default, but can be viewed by clicking Show Fonts Tab (Studio toolbar). The Fonts tab is located on the left of your workspace.

Websafe fonts are a specially selected and configurable subset of fonts which offer the best font matches between your site (during design) and your web visitors' computers (during browsing).

Generally speaking, it is advisable to keep to the standard list of Websafe fonts shown in the Fonts tab unless you can be sure of font usage amongst your target audience.

To assign a font:

- Select some text, then click on the font name in the Fonts tab to assign the font to the text.
Using text styles

WebPlus lets you use named text styles (pre- or user-defined), which can be applied to frame text, table text, or artistic text. A text style is a set of character and/or paragraph attributes saved as a group. When you apply a style to text, you apply the whole group of attributes in just one step. For example, you could use named paragraph styles for particular layout elements, such as "Heading", "Quote", or "Body", and character styles to convey meaning, such as "Emphasis", "Code", or "Reference".

Styles can be applied to characters or paragraphs using either the Text context toolbar or the Text Styles tab. Both paragraph and character styles can be managed from the Text Style Palette.

The Text Styles tab also lets you create new styles from scratch, create named styles from existing text properties, and swap a style for another across your site in one operation. Any style can be previewed against any selected paragraph directly on the page. See WebPlus Help for more details on these features.
Paragraph styles and character styles

A paragraph style is a complete specification for the appearance of a paragraph, including all its font and paragraph format attributes. Every paragraph in WebPlus has a paragraph style associated with it.

A character style includes only font attributes (name, point size, bold, italic, etc.), and you apply it at the character level—that is, to a range of selected characters—rather than to the whole paragraph.

Working with named styles

The named style of the currently selected text is displayed in either the Text Styles tab or the drop-down Styles box on the Text context toolbar. A character style (if one is applied locally) may be shown; otherwise it indicates the paragraph style.

To apply a named style:

1. Using the Pointer Tool, click in a paragraph (if applying a paragraph style) or select a range of text (if applying a character style).

2. Display the Text Styles tab and select a style from the style list.
   - or -
   On the Text context toolbar, click the arrow to expand the Styles drop-down list and select a style name.

The Text Styles tab highlights the paragraph or character style applied to any selected text.

As both paragraph and character formatting can be applied to the same text, all of the current text’s formatting is displayed in the Current format box on the tab.
To modify an existing style:

1. From the Text Styles tab:
   - Right-click on the character or paragraph style you want to modify and then choose Modify <style>....
   - or -
   - With a style selected, pick the Manage button from the Text Styles tab, then choose the Modify... button.

2. From the Text Style dialog, define (or change) the style name, base style, and any character, paragraph or hyperlink attributes, tabs, bullets, and drop caps you want to include in the style definition.

3. Click OK to accept style properties, or Cancel to abandon changes.

4. Click Apply to update text, or click Close to maintain the style in the site for future use.

Alternatively, choose Text Style Palette... from the Text menu to modify styles and to change text defaults (see WebPlus Help).

To delete one or more text styles:

1. Right-click a text style and select Delete <style>....

2. From the dialog, click Remove. For deletion of multiple styles, check multiple style names first. For removal of all or unused styles, use appropriate buttons.

⚠️ Take care when deleting styles. Styles based on a checked "parent" style will be checked for deletion.
Changing common styles

Changing one character or paragraph style for another is very simple for a single portion of text. However, in WebPlus, it’s just as easy to swap one style for another by selecting multiple instances of the style and choosing an alternative style. This swaps styles across paragraphs and throughout entire stories all at the same time.

To select (and change) a style throughout your site:

1. Right-click a style displayed on the Text Styles tab.
2. If the style is used in your site, you'll see a "Select All n instance(s)" message (n is the number of times the style is used).

   If there are no occurrences of the style, the option is grayed out.
3. Hover over style names in your styles list. Click on a chosen style to apply the style to the selected text.

Creating a bulleted or numbered list

For any text frame it’s possible to apply bullets and numbering to lists and paragraphs alike. Bullets are especially useful when listing items of interest in no specific order of preference and numbered lists for presenting step-by-step procedures (by number or letter). WebPlus lets you apply the list style to normal text (as local formatting) or to text styles equally.

Within text frames, basic bullet icons, numbers (numeric and Roman) and letters can be applied.
To apply a bulleted or numbered list:

1. Select one or more paragraphs.
   - or -
   Click in a paragraph’s text.

2. Select **Bulleted List** or **Numbered List** from the Text context toolbar.

Each time you insert a following return, a new line will begin with the specified symbol or number. In addition, typing two returns in a row (pressing Enter twice) cancels bullets or numbers and resumes regular paragraph formatting.

To update a bulleted or numbered list:

1. Select one or more paragraphs.
   - or -
   Click in a paragraph’s text.

2. Select **Bullets and Numbering**... from the Text menu (or right-click Text Format>Bullets and Numbering...).

3. Select a bullet character or number style from the range of displayed symbols. You can set the Text indent distances, and define other attributes, including color.

4. For numbered lists, check **Restart numbering** to restart numbering from the current cursor position in the list; otherwise, leave the option unchecked.

5. Click **OK** to apply list formatting.

To remove bullets or numbering formatting:

1. Select the paragraph with list formatting.

2. Click the or buttons on the Text context toolbar.

WebPlus also lets you assign bullets and numbers to styles. (See WebPlus Help.)
Inserting user details

You can take advantage of the User Details dialog to store frequently-used or updated user information so you don't need to keep re-entering it.

These fields need to be present on your site pages in advance of updates and may have to be inserted manually via Insert>Information>User Details on the Text menu.

You can also use this User Details dialog to define global and site-specific variables for use in all WebPlus sites or just the current site, respectively. (See Inserting variables in WebPlus Help)

To add, edit or change User Details:

1. Click User Details on the Default context toolbar (deselect objects to view).

2. For business user details, enter new information in the Business Sets tab. Ensure the Select Set drop-down list is set to Default if you're only likely to use one set of business details. The drop-down list lets you select a different set of business user details, if created. (See Creating business sets in WebPlus Help).
3. For home users details, use the **Home** tab. These fields are distinct from those set in the Business Sets tab.

A **Calendars** tab will appear if there is a calendar in your site. This lets you change the year and show/hide public holidays and personal events.

**Inserting and updating user details**

You can insert one or more User Details fields into your site at any time.

**To insert a User Detail field:**

1. Click in the text for an insertion point.
2. Choose **Insert>Information** from the **Text** menu, then select **User Details...** from the submenu.
3. Select a User Detail entry, and optionally any text **Prefix** or **Suffix** (postfix) to include with your user details, e.g. *Name:*
4. Click **OK**.

For existing sites, the fields (once edited) can be updated at the click of a button.

**To update fields:**

- Enter new information in the User Details dialog (via **Tools>Set User Details...**).
- Click the **Update** button to automatically update any altered field currently placed in your site. This field will remain linked to User Details until it is deleted or converted to "static" text (see WebPlus Help).

**Using Find and Replace**

From **Text>Find & Replace...**, you can search site text for an extraordinary variety of items: not just words or parts of words, but a host of character and paragraph attributes such as fonts, styles, alignment, bullets and numbering, missing fonts, drop caps... even inline graphics and more! See WebPlus Help for details.
Using assets

An **asset** is a general term for any object or page element that can be added to your page to enhance its appearance, increase efficiency, or personalize your design. Assets range from graphics, pictures, picture frames, buttons, sliders/panels, and backgrounds, to more complex page content and entire pages.

To use assets, WebPlus provides the **Assets tab**, powered by both an Asset Browser and Asset Manager (see p. 221 and WebPlus Help, respectively). The former browses your assets, the latter lets you create and manage custom Asset Packs.

---

Theme Layout design templates come complete with their own built-in assets, all themed to the site's design. When you start from a theme layout the **Assets tab** will be populated with associated assets automatically!
Using the Assets tab

The Assets tab is a powerful design resource that exclusively hosts your browsed assets, ready for adding to your web page.

Assets can be placed into the following categories.

- **My Designs**: Stores custom assets dragged from the page.
- **Graphics**: Stores professional clipart from Asset Packs.
- **Pictures**: Stores added pictures from your hard disk (or from Asset Pack, if containing pictures).
- **Buttons**: Stores a range of pre-designed buttons from Asset Packs.
- **Sliders / Panels**: Stores sliders (each containing an animated set of panels) and individual panels for Asset Packs.
- **Picture Frames**: Stores picture frames from Asset Packs.
- **Page Content**: Stores page content (pre-assembled from various page objects) from Asset Packs. Navigation bars, and groups of text frames, shapes, and column backgrounds are included.
- **Backgrounds**: Stores backgrounds from Asset Packs.
- **Pages**: Stores complete ready-to-go pages from Asset Packs.
The tab also lets you create custom designs for reuse globally or just in your site. You'll be able to:

- Store your own designs to the tab's My Designs category for global use.
- Store your own designs to any other tab's category for current site use.
- Create custom picture frames from drawn shapes.
- Create custom page backgrounds from pictures or filled page objects.
- Create custom page content (combinations of assets).

Although initially empty, the tab can be populated with assets of your choice by using an Asset Browser.

**The Asset Browser**

The Asset Browser lets you browse by asset category and Asset Pack (Pack Files), as well as search (by tag) for assets. Once displayed, the asset can be selected for inclusion in the **Assets** tab. See Asset browsing below for more information.

**The Asset Manager**

Use the **Asset Manager** to create your own Asset Packs by using assets from other Asset Packs and/or by importing pictures, graphics, or backgrounds. You can tag assets and then save or export your custom asset pack. See WebPlus Help.

**Asset browsing**

The **Asset Browser** offers a whole range of professional ready-to-go designs, called **assets**, that you can use directly in your site. These designs are provided in categorized pack files (also known as Asset Packs), installed with WebPlus.
There are two ways to browse assets before adding assets to your workspace—by category or by pack file.

You can also use the search controls at the top-right of the dialog to narrow your search, or to find a specific assets in the pack files.

**To browse assets (by category):**

1. From the Assets tab, click **Browse**....

2. In the Asset Browser, select an asset category from the Categories section. You'll see installed assets appear in the main pane.

3. Scroll through the asset packs to browse assets included in each pack.
To browse assets (by Pack File):

1. From the Assets tab, click **Browse**.

2. In the Asset Browser, on the left-hand side of the dialog, select a pack file category (e.g., Backgrounds) or asset pack name from the Pack Files section. You may need to click the right arrow to expand a category for the latter. The pack file(s) will appear in the main pane.

3. Scroll through to browse the assets included in each pack file. To make browsing easier, you can expand and collapse the categories or pack files to hide or reveal the assets.

4. (Optional) To narrow your search, filter assets by entering an asset name in the Search box at the top-right of the Asset Browser.

**Searching for assets**

The search facility filters assets based on preset and custom tags applied to all of the pack files shown in the Asset Browser.

**To apply a search filter:**

- For a simple tag search, type the word or letter you want to search for in the Search text box, situated at the top right of the dialog. This is useful for retrieving assets with custom tags attached.

   ![Search Text Box](image)

   ![Search Results](image)

  💡 If your search results are being restricted to the currently highlighted category, Smart folder, Smart tag, or pack file, you can click the appropriate section header to remove this restriction.
Filtering assets

Filtering means that you can restrict the amount of assets on display.

- For **category and/or pack file filtering**, select a category or pack file (or multiple instances using Ctrl-click). You can also search for category and pack file combinations. For example, selecting the Buttons category and then a Theme Layout gives you just buttons from that theme layout.

- For **Smart tag filtering**, select a tag name from the **Smart Tags** section (scroll down the left-hand pane). Smart tags let you filter assets logically by subject matter using a hierarchical and alphabetic tag structure. For example, if you select the "Wildlife & Nature" tag you'll see all assets tagged with that tag; if you want Animal-only assets, you could select "Animal", nested under that Occasions tag.

- For **tag-specific filtering**, select a tag name from the **Tags** section of the Asset Browser (below the Smart tags section). Use Ctrl-click to manually select multiple tags.
Adding assets to your Assets tab

To add a specific asset:

- Select the category or pack file in the Asset Browser, and then simply click the asset. A check mark shows on the thumbnail.

To add all assets:

- Click Add All from the upper-right corner of each Asset Pack's thumbnail gallery. Check marks will show on all thumbnails.

With either method, asset(s) will be available to you from the Assets tab when you close the Asset Browser.

Any asset stored in your Assets tab (but not added to the page) will be available to you the next time you open your site. Assets can be made globally available by pinning in the relevant tab category. Custom designs can also be made global by dragging page objects to the tab's My Designs category.

Adding assets to your page

To add an asset to the page:

- Click its thumbnail in the design category and drag it out onto the page.
Storing designs

WebPlus lets you create custom assets to be used again, either just in your site or globally in any site in the future. Assets can be created and stored from objects already placed on the page. Example designs that can be stored include:

- Graphics (from drawn vector shapes, line art, and artistic/frame text)
- Pictures (from adjusted or cutout pictures)
- Sliders / Panels
- Buttons
- Picture frames
- Selected arrangement of page objects
- Backgrounds
- Pages

Normally, designs are added to the Assets tab by dragging a design from the page, then dragging it back onto your page where (and when) you want it. However, backgrounds and pages can’t be dragged off your workspace but are added from within the tab category instead.

Storing to My Designs

If you’re keen on storing your own designs for global use, the Assets tab’s My Designs category is ideal—designs will always be available in any new site you create.

When you first install WebPlus, the My Designs gallery will be empty, ready for custom designs to be added to it.

If you drag an object to any other category, then the stored design will only be available to the current site.
To store a design in My Designs:

- Drag the object from the page and drop it onto the **Assets** tab's My Designs category. You don't need to expand the category in advance, as it will automatically expand for you.

Saving My Designs

When WebPlus closes, any designs you store in your My Designs category will be saved as a MyDesigns.wpack file to your Windows Application Data folder.

Storing pages and backgrounds

Any page already present in your site can be stored in the **Assets** tab (Pages category).

**To store a page:**

1. From the **Assets** tab’s Pages category, click **Add**....
2. From the dialog, check a page (or master page) that exists in your site.
3. Click **OK**. The page appears in the Pages category.

Like pages, any custom background you've used in your site can be stored in the **Assets** tab (Background category).

**To store a background:**

1. From the **Assets** tab’s Background category, click **Add**....
2. From the dialog, check a site-wide or page-specific background that exists in your site.
3. Click **OK**. The background appears in the Background category.
Storing to other categories

Designs can also be added to other categories, but will only be available to the current site (unless pinned—see below). Typically, you can store vector shapes, line art, artistic text, and text frames in the Graphics category, unless you want to make it globally available via the My Designs category.

When you close your site, any custom design you've stored in these categories will need to be saved. You'll be prompted to save the design to a custom Asset Pack specific to the site.

To save a design to other categories:

• Drag the object from the page and drop it onto any other category.

Pinning categories and individual assets

Individual assets and entire categories within the Assets tab can be made available for all sites (i.e., globally) if they are pinned.

To pin and unpin assets:

• To pin all the assets in a category, click Pin All on the category header.
  - or -
  To pin an individual asset, click the icon on the individual asset.

• To unpin all the assets in a category, click Unpin All on the category header.
  - or -
  To unpin an individual asset, click the icon on the individual asset.
Using Site Checker

In advance of publishing, the Site Checker searches your website for common layout problems relating to site navigation, text formatting, forms, E-Commerce, and many more, and reports detected problems. A wide variety of commonly encountered problems can be located but typical problems include:

- Duplicate object HTML IDs.
- Invalid Anchors or Hyperlinks.
- Web Forms: No Submit button or form objects have the same name.
- W3C validation failure warnings.
- Large JPG images exported as PNG.
- Overlapping, rotated, or cropped text.
- Non-WebSafe fonts.

A full list of checks performed are shown via the Site Checker’s Filter Site Problems... button.

If problems are found, the Site Checker reports each problem in a problem list along with either options to fix directly or provide hints to resolve the issue.

WebPlus can attempt to either manually fix selected problems or fix all listed problems automatically. Primary and secondary fixes may be offered—these represent WebPlus’s recommended first- and second-choice solutions to layout problems. For example, detected text which has been incorrectly assigned a non-WebSafe font may be reassigned a different Websafe font instead.

If you’re not concerned with certain problem types or you would like to postpone resolution to a later date you can use problem filtering. (See WebPlus Help.)
To scan for site problems:

1. Click **Site Manager** on the Default context toolbar, then select **Site Checker**. The Site Manager is launched with Site Checker shown by default.

2. In the **Type** drop-down menu, choose to view **All Site Problems** or selectively choose to view problems relating to:
   - **Site Navigation**
   - **Text Formatting**
   - **Form and E-commerce**

3. Click the **Start** button to begin the search for problems, which will be listed automatically in the list window.

By default, resources are listed according to the Page column order, but the contents of any column can be reordered by clicking its column header.

![Click on an individual problem entry in the list to view any suggested Primary or Secondary fix (shown in lower text box).]

To fix multiple problems automatically:

1. Check the **Page** check box at the top left of the problem list to select all problems.

2. Click the **Fix All** cell at the bottom right of the list. The row will show multiple problems selected (e.g. 6/6 Selected).

3. From the **Apply Multiple Fix** dialog, click a button to apply either a **Primary fix** (most recommended) or **Secondary fix**. Problems that can be resolved automatically will be fixed and removed from the problem list once the appropriate button is clicked. However, some fixes may require modification of settings via additional dialogs.

4. Click **Close** to exit Site Manager.

![When you've fix a problem, a green check mark appears under the Status column of the specific problem entry.]
To fix selected problems manually:

1. Double-click the Fix cell at the end of a specific problem list entry.

2. From the dialog, follow the displayed instructions as recommended, using the Display button to jump to the problem object (e.g., form) or page.

3. If the Edit button isn't grayed out, it can be clicked to launch the appropriate dialog needed to remedy the problem. If grayed, just follow the instructions for resolution.

4. Click Close to exit.

If you want to temporarily (or permanently) ignore specific problems, click Ignore Problems Of This Type. See Filtering site problems in WebPlus Help.

Previewing your site

Previewing your site in a web browser is an essential step before publishing it to the web. It's the only way you can see just how your site will appear to a visitor. You can preview a page or site at any time, either within WebPlus (using an internal window based on the Internet Explorer browser) or separately using any browser installed on your system.

To preview your site:

1. Click the down arrow on the Preview site button on the Standard toolbar.

2. Select an option from the submenu:

   • Preview in Window (shortcut Alt+P) opens the site in a new internal WebPlus window with its own tab for convenient switching.

   • Choose Preview Page... or Preview Site... to use an external browser. The names will reflect which browsers are currently installed, e.g. the entry may read “Preview Page in Internet Explorer.” The page or site is exported to a temporary folder and appears in the specified browser.
WebPlus allows you to view estimated download time for each page of your site, and provides information such as the number of files on each page and the total size of the files. This is carried out via the Standard toolbar's Preview site flyout.

Publishing to the web

Publishing to the web involves uploading your site to your web host provider, turning your site into a live website, viewable by the whole world! You can specify that all web pages are published or, if updating your site, only pages changed since the last "publish."

To publish your site to the web:

- Click the down arrow on the Publish site button on the Standard toolbar and click Publish to Web.

If you've not set up FTP account information, you'll be prompted to add FTP details (either Serif web hosting or third-party hosting) via a pop-up dialog.

To set up FTP account information:

1. From the pop-up dialog, click Add Details.
2. In the **Account Details** dialog, enter:

- **The Account name.** This can be any name of your choice. You'll use it to identify this account in WebPlus (in case you have more than one).

- **The FTP address** of your web space—this is a specific URL that will be provided by your web host.

- **Port number:** Unless directed by your provider, you can leave this set at "21."

- Leave the **Folder** box blank unless directed by your provider, or if you want to publish to a specific subfolder of your root directory.

- You'll also need a **Username** and **Password** as pre-assigned by the provider. Most likely these will correspond to email login settings. Be sure to enter the password exactly as given to you, using correct upper- and lower-case spelling, or the host server may not recognize it.

- Check **Save password** to record the password on your computer, if you don't want to re-enter it with each upload.

- **Passive mode:** Leave checked unless you are experiencing FTP connection problems.

  If you are certain your FTP details are correct, unchecking **Passive mode** might fix the problem. ISPs and web hosts can operate passive or active FTP modes of operation, so it is worth checking this with them.

- **Web site URL:** Set your site's URL. This allows you to view the web site from a dialog after FTP upload.

- Click **OK** to close Account Details.

3. Back in the Upload to server dialog, click the **Test** button to test your FTP Account. If the test is successful a dialog will display stating that a connection has been established.
4. Choose to Save FTP account details either:
   - to your machine (account details will be saved into WebPlus and won’t be lost, even after Ctrl-Runup)
   - or -
   - into the current site (for details see Handling FTP account information in WebPlus Help).

5. Click **Update Account** to return to the Publish To Web dialog.

If you’ve set up at least one account, the **Publish to Web** dialog appears with the last used account name shown in the drop-down menu and its settings in subsequent boxes.

**To upload your site:**

1. In the Publish To Web dialog, select the **FTP Account** you want to use from the drop-down list.

2. If your site is using a database, the **Merge before publishing** option is checked. Clear this option only if you do not wish to merge changes (the option will be grayed out if no database/changes are detected). For more on databases, see Using database merge in WebPlus Help.

3. For the greatest control over the publishing, ensure that the **Unattended upload** check box is cleared. This will allow you to review the changes that will take place to your published website before they are made. It will also give you the option to cancel the upload if you discover a problem. (See Automatic Operation in WebPlus Help.)

4. Choose which pages you want to upload—check specific page(s) in the window or **Publish All Pages**.

5. To safeguard your WebPlus site, check the **Back-up the document to the remote server** option. If the site is unsaved you'll be prompted to save it.
6. Click **OK**.

   WebPlus seeks an Internet connection, then:

7. If uploading for the first time, selected files will be uploaded directly.

   - or -

   If uploading to an existing site, an Uploading Files dialog is displayed showing local file action (whether files will be added (Add), will replace the live file (Replace) or not updated (Leave)).

   In the dialog, check the option to **Delete unused remote files** if you want WebPlus to automatically remove any unused graphic and page files.

   Select either the **Incremental Update** or **Full upload** Button. Choose the former to upload only files that have altered since the last upload. When doing an incremental update, you can get WebPlus to **Check for missing files** by checking the option box. However, as this can dramatically slow the upload, this option is unchecked by default.

   You'll see a message when all files have been successfully copied.

   Click **Close**.

8. From the drop-down menu in the Website Publishing dialog, select the browser in which you wish to view your live site and click **View this URL**. You will now be able to view your live site.

If you rename/delete files and then republish one or a few pages to the web, the old files are not deleted automatically so you'll need to delete these manually by using **Publish Site>Maintain Website...** on the **File** Menu. However, if you republish the whole site to the web automatically (using Automatic Operation), you can choose to delete any unused files; check the **Delete unused files** check box.
Viewing your published site

Once published, you have the option to View site online from the Preview site drop-down list on the Standard toolbar. This displays your site in its most recently published state in the default web browser. The first time View site online is used, a dialog pops up asking for the default site URL. This can be amended later using Edit>Site Properties... and then selecting Publishing in the dialog.

It is important to remember that any changes made since publishing will not be reflected. To see unpublished changes, use the Preview site button. (See Previewing your site on p. 233.)

Setting up your web space

Serif provides competitively priced web hosting that offers various levels of service to suit your individual requirements. See www.serif.com/hosting for more details.

Alternatively, if you already have a hosting account, the contract with your service provider may also allow you a certain amount of file space on their server where you can store files, including the files that comprise a website.
Quick Publish

Quick Publish allows you to quickly upload and view the currently displayed page—useful for live verification of individual pages as you build your website. In order for Quick Publish to function, you must first setup your account details using the Quick Publish Configuration dialog.

If you attempt to use Quick Publish without configuring your account settings first, a pop-up dialog appears which lets you add account details. You'll be able to set up Serif web hosting or click Add Details to enter existing account details.

To configure Quick Publish:

1. Click the Publish site flyout on the Standard toolbar and then click Quick Publish Configuration.

2. In the dialog:
   - Enter the details of, or select from the drop-down menu, the URL of the site you want to publish to.
   - Select the browser in which you wish to view your page once it has been published.
   - Select the FTP account you want to use from the drop-down menu. To update account settings, or add a new account, click Manage Accounts.

3. Click OK.

To Quick Publish to Web:

- Click the Publish site flyout on the Standard toolbar and then click Quick Publish to Web.

The Uploading Files dialog briefly appears before your page is displayed in your chosen browser.
Validating your website

If you plan to use various Google or Bing interactive web services it is necessary for your website to be validated to prove your ownership of the site. This ensures that sensitive information is restricted to just Google (or Bing) and yourself.

Google validation

Google Webmaster tools such as AdSense and Analytics are available from Google which let you provide advertising and tracking of your website. To use these features you'll need to validate your site with Google in advance.

In WebPlus, two methods for validation are possible—by HTML download (recommended) or Meta tag cut and paste.

To validate your site with Google:

1. From Edit>Site Properties..., select Search Engine>Google Validation.

2. Click Visit the Google Webmaster Tools site.

3. From the Google page in your web browser, follow the Verify ownership online instructions, and either download a generated HTML verification file, or copy the meta tag (e.g., <meta name="google-site-verification" content="NFGHRVfcdfDFBFVCC">).


5. Enable either the Validate with a file... or Validate with a meta tag... option, depending on the above validation method. For the former, locate and select your downloaded HTML file, then click Open. For the latter, click the Paste button to paste the meta tag.

6. Click OK.

7. Publish your site.

8. From the Google page in your web browser, click the Verify button to confirm that the site has been verified by Google.
Site Validation and Analysis

Bing validation

Bing is a Microsoft web search engine, formerly Live Search and MSN Search, which also offers web services for webmasters. Like Google, you have to validate your WebPlus site to make use of these services.

To validate your site with Bing:

1. From Edit>Site Properties..., select Search Engine>Bing Validation.
2. Follow the instructions as for Google validation.

Instead of an HTML file being downloaded, an XML file is required for validation.

Analyzing web statistics

Statistics can be gathered for your website in order to monitor usage, page popularity, and generally assess whether the website is meeting its objectives. With a wealth of data in front of you, you're in a stronger position to make choices about how to improve your website.

In WebPlus, you use Google Analytics to gather statistics—you'll need to switch on the web analytics feature in WebPlus, then paste the generated code, copied from www.google.com/analytics, into your site.

Google Analytics

Google Analytics offers a free and comprehensive Google-based service for gathering statistics about your website. Once your site is published, visits to your website by the general public, customers, colleagues, friends and family will be recorded, analyzed and presented visually. You'll be able to access your web statistics at any time via Google Analytics.
To use it you must have a Google account and sign up for the Analytics service (www.google.com/analytics), where you'll be able to create Website profiles for one or more websites on your domain. Profiles let you configure and store settings for gathering a specific set of statistics which will help you understand demographics, visitor behavior, visitor flow, and other technological, social and mobile data.

**To log in to Google Analytics:**

1. Visit www.google.com/analytics to sign up or sign in to Google Analytics. Click the **Sign Up Now** link if you’re a new user or click **Access Analytics** to login using your existing user details.

2. Follow the instructions for creating a new profile.

3. Copy the profile's generated code snippet provided in the **Paste this code on your site** window. You'll need this to paste into WebPlus.

4. Click **Finish**.
To enable Google Analytics:

1. Choose Site Properties... from the Edit menu.

2. Select the Features>Analytics menu option, then check Enable web analytics.

3. Paste the Tracking Code snippet previously copied from the Google Analytics website by clicking Paste from Clipboard. The snippet appears in your dialog and cannot be edited.

4. Click OK.

💡 To work correctly, the code snippet in your Google Analytics profile and in your WebPlus site must use the same Web Property ID, e.g. UA-10378445-7. You'll find this embedded within the code.

💡 If you're changing the code snippet for your site it's recommended to subsequently perform a Full Upload when publishing to the web.

To analyze your statistics:

- Login to Google Analytics, then click View report on your Website Profile entry.
Contacting Serif

Contacting Serif Support

Our support mission is to provide fast, friendly technical advice and support from a team of experts.

<table>
<thead>
<tr>
<th>Serif Support on the web</th>
</tr>
</thead>
<tbody>
<tr>
<td>Service and Support</td>
</tr>
<tr>
<td><img src="twitter.com/serifsupport" alt="Twitter" /></td>
</tr>
<tr>
<td><img src="www.facebook.com/SerifSupport" alt="Facebook" /></td>
</tr>
</tbody>
</table>

Additional Serif information

<table>
<thead>
<tr>
<th>Serif on the web</th>
</tr>
</thead>
<tbody>
<tr>
<td>Serif website</td>
</tr>
<tr>
<td>Forums</td>
</tr>
<tr>
<td><img src="youtube.com/serifsoftware" alt="YouTube" /></td>
</tr>
</tbody>
</table>

Main office (UK, Europe)

<table>
<thead>
<tr>
<th>Address</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Software Centre, PO Box 2000</td>
</tr>
<tr>
<td>Nottingham, NG11 7GW, UK</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Phone (Registration)</th>
</tr>
</thead>
<tbody>
<tr>
<td>(0800) 376 1989</td>
</tr>
<tr>
<td>+44 800 376 1989</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Phone (Sales)</th>
</tr>
</thead>
<tbody>
<tr>
<td>(0800) 376 7070</td>
</tr>
<tr>
<td>+44 800 376 7070</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Phone (Service and Support)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0845 345 6770</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Fax</th>
</tr>
</thead>
<tbody>
<tr>
<td>(0115) 914 2020</td>
</tr>
</tbody>
</table>
### North American office (US, Canada)

<table>
<thead>
<tr>
<th>Service</th>
<th>Phone</th>
</tr>
</thead>
<tbody>
<tr>
<td>Phone (Registration)</td>
<td>800-794-6876</td>
</tr>
<tr>
<td>Phone (Sales)</td>
<td>800-489-6703</td>
</tr>
<tr>
<td>Phone (Customer Service)</td>
<td>800-489-6720</td>
</tr>
</tbody>
</table>

For international enquiries, please contact our main office.
Credits

This User Guide, and the software described in it, is furnished under an end user License Agreement, which is included with the product. The agreement specifies the permitted and prohibited uses.

Trademarks

Serif is a registered trademark of Serif (Europe) Ltd.

WebPlus is a registered trademark of Serif (Europe) Ltd.

All Serif product names are trademarks of Serif (Europe) Ltd.

Microsoft, Windows, and the Windows logo are registered trademarks of Microsoft Corporation. All other trademarks acknowledged.

Windows Vista and the Windows Vista Start button are trademarks or registered trademarks of Microsoft Corporation in the United States and/or other countries.

Google+ social service, Google Analytics web analytics service, and Google AdSense advertising service are trademarks of Google Inc.

Copyrights

Digital Images ©2008 Hemera Technologies Inc. All Rights Reserved.

Digital Images ©2008 Jupiterimages Corporation, All Rights Reserved.


Content ©2008 Jupiterimages Corporation. All Rights Reserved.


This application was developed using LEADTOOLS, copyright © 1991-2007 LEAD Technologies, Inc. ALL Rights Reserved.

THE PROXIMITY HYPHENATION SYSTEM © 1989 Proximity Technology Inc. All rights reserved.

THE PROXIMITY/COLLINS DATABASE® © 1990 William Collins Sons & Co. Ltd.; © 1990 Proximity Technology Inc. All rights reserved.

THE PROXIMITY/MERRIAM-WEBSTER DATABASE® © 1990 Merriam-Webster Inc.; © 1990 Proximity Technology Inc. All rights reserved.

The Sentry Spelling-Checker Engine © 2000 Wintertree Software Inc.

The ThesDB Thesaurus Engine © 1993-97 Wintertree Software Inc.
Additional Information

WGrammar Grammar-Checker Engine © 1998 Wintertree Software Inc.
Andrei Stcherbatchenko, Ferdinand Prantl
PayPal © 1999-2012 PayPal. All rights reserved.
Roman Cart © 2008 Roman Interactive Ltd. All rights reserved.
Mal’s © 1998 to 2003 Mal’s e-commerce Ltd. All rights reserved.
iTunes © 2000 to 2008 Apple, Inc. All rights reserved.
YouTube © 2008 YouTube, LLC
Facebook © 2008 Facebook Inc.
Twitter © 2012 Twitter Inc.
Portions of this software are copyright © 2008 The FreeType Project (www.freetype.org). All rights reserved.
ODF Translator © 2006-2008, Clever Age, DIaLOGIKa, Sonata Software Ltd. All rights reserved.
Office Binary Translator to OpenXML Copyright © 2008-2009, DIaLOGIKa. All rights reserved.
Anti-Grain Geometry - Version 2.4
Copyright © 2002-2005 Maxim Shemanarev (McSeem)
SlideShowPro © Dominey Design Inc. All rights reserved.
Clipart samples from Serif ArtPacks © Serif (Europe) Ltd. & Paul Harris
TrueType font samples from Serif FontPacks © Serif (Europe) Ltd.
© 2012 Serif (Europe) Ltd. All rights reserved. No part of this User Guide may be reproduced in any form without the express written permission of Serif (Europe) Ltd.
Serif WebPlus X6 © 2012 Serif (Europe) Ltd. All rights reserved.
Companies and names used in samples are fictitious.
access control, 143, 153
  enabling, 149
  signing in, 150
  signing up users, 147
  user groups, 146
Account Details (FTP), 234
actions, 111
  panels, 79
Active Viewers (Smart object), 152
adjustment (of pictures), 75
Adsense (Google), 126
advertising, 126
Analytics (Google), 244
anchors, 112
artistic text, 202
  create, 203
  edit, 204
  on a path, 205
  resize, 204
Artistic Text Tool, 203
Asset Browser, 221
Asset Manager, 221
Asset Pack, 219, 223
assets, 219
  adding to Assets tab, 225
  adding to page, 225
  browsing, 221
  filtering, 224
  pinning, 228
  searching, 223
  storing, 226
Assets tab, 220
attaching master pages, 44
audio files, 173
AutoFit (text), 70
AutoFlow (pictures), 72
background, 54
  color, 57
  custom, 58
  picture, 55
  multiple, 56
  storing, 227
banners (animated), 92
Bing validation, 244
blogs, 133, 152
  accessing, via offsite links, 52
  inserting, 134
  managing, 135
browser preview, 233
bulleted lists, 213
Button Studio, 107
buttons, 104
  creating custom, 107
  social bookmarking strip, 168
Calendar Event Manager, 88
Calendar Wizard, 88
calendars, 88
  events for, 91
  public holidays for, 90
character styles (text), 211
child/parent pages, 38, 50, 100
clear text formatting, 208
CMS (Content Management System), 152
color
  background, 57
  on-page, 57
  schemes, 59
  named, 62
  selecting, 61
Content Management System (CMS), 152
counters (Smart object), 152
Cutout Studio, 74

cutting out (pictures), 74

Design Studio, 80
design template, 27
document frames, 131
dynamic guides, 62
e-commerce, 191

  adding forms and buttons
    (PayPal), 194
effects (for pictures), 75
events (calendar), 91
Facebook (widget), 161
edit, 162
features (new), 4
Find and Replace, 216
Fit Text to Path, 205
fix site problems, 232
Flash
  movies, 175
  Photo Gallery, 82
fonts, 209
formatting text, 208
forms, 181
  creating, 182
  submission of data in, 184
forums, 137, 152
  accessing, via offsite links, 52
  inserting, 139
  managing, 140
  security, 140
frame text, 67
  controlling overflow, 70
  creating, 67
  fitting text to, 70
  margins, 69
  setup, 69
framed documents, 131
FTP account details, 234

Getting site online, 9

Google
  +1 button (widget), 167
  AdSense, 126
  Analytics, 244
  Maps, 125
  validation, 243
groups, user (access control), 146
guides, dynamic, 62
Hit Counter (Smart object), 152
home page, 38
  changing, 53
hosting (web), 238
  Serif, 20
HTML pages, 50
hyperlinks, 108
  anchors for, 112
  to lightboxes, 113
  to target window/frame, 110
iFrames, 131
importing text, 201
installation, 7
JavaScript Photo Gallery, 82
layout aids, dynamic guides, 62
lightboxes, 113
  for pictures, 73
  hyperlinking using, 115
  Photo Gallery, 116
  settings, 116
  slideshows, 115
lines, fitting text to, 206
lists
  bulleted, 213
  numbered, 213
login box, 150
mailing lists, 153
Mal's (shopping cart), 192
maps (Google), 125
margins (text frames), 69
master pages, 42
    adding, 49
    attaching, 44
    multiple, 44
    objects, 46
    properties, 53
    removing, 49
media (streamed), 173
mobile sites, 34
    redirecting to, 37
navigation bars, 99
    buttons for, 104
    creating, 99
    customizing, 101
    pop-up menus, 102
new features, 4
news window, 135, 153
    managing, 136
numbered lists, 213
offsite links, 52
on-page color, 57
    custom, 58
opening an existing site, 31
pages, 42
    add template page, 51
    adding and removing, 47
    background for, 54
    login box, 150
    on-page color, 57
    parent and child, 38, 50, 100
    properties, 53
    rearranging, 50
    security, 143
    storing, 227
panels, 76
    actions, 79, 111
    add content, 79
creating custom, 80
    in sliders, 92
    show/hide, 79
paragraph text styles, 211
parent/child pages, 38, 50, 100
path text, 205
PayPal
    adding forms and buttons to, 194
    configuring, 192
    Minicart, 193
Photo Gallery, 81
    edit, 84
    from Flickr photos, 85
    from SlideShowPro Director, 85
    live feed, 85
PhotoLab, 75
pictures, 70
    adjustments, 75
    as backgrounds, 55
    AutoFlow, 72
    cutting out, 74
    effects, 75
    lightboxes, 73, 113
    popup, 121
    replacing, 73
Poll (Smart object), 153
pop-up
    menus, 102
    rollovers, 121
previewing sites, 233
proofing tools, 231
publishing
    Quick Publish to web, 239
    to web, 234
Quick Build tab, 5
Quick Publish, 239
redirect pages to mobile pages, 37
removing pages/master pages, 49
Resource Booker, 153
reverting to saved version, 32
rollovers, 119
   pop-up, 121
RomanCart (shopping cart), 192
RSS feeds (third-party), 141
RSS Reader, 141
schemes (color), 59
searching websites, 123
Serif contact information, 249
Serif Web Hosting, 20
Serif Web Resources
   for Smart objects, 151
   form submission, 181, 186
   login to, 154
shapes, fitting text to, 206
shopping cart, 191
Shout Box (Smart object), 153
site
   login box, 150
   map (navigation), 99
   opening existing, 31
   preview, 233
   problems, 232
   properties, 41
   search, 123
   starting from scratch, 33
   structure, 38
   viewing, 40
Site Checker, 231
Site Manager (for checking layout), 231
Site Structure view, 40
Site tab, 39, 43, 47
   sliders, 92
   actions, 111
   edit, 94
   select, 94
   slideshows
      lightboxes, 115
      Photo Gallery, 81, 116
Smart objects, 151
   account for, 154
   creating, 155
   editing, 157
   managing, 158
Smart phone websites, 34
social bookmarking button strip, 168
Social Media
   Facebook (widget), 161
   Google +1 button, 167
   Twitter (widget), 163
sound, 173
   adding to page, 174
   background, 173
Start New Site, 33
Startup Wizard, 28, 33
statistics (web page), 244
storing designs/text, 226
story text, flowing in frame, 70
streamed media, 173
submission (of forms), 184
support, 249
SWF files, 175
Table Tool, 88
tables, 87
technical support, 249
template (design), 27
   creating site with, 28
text, 202
  artistic (standalone), 202
bullets and numbering, 213
editing on the page, 207
Find and Replace, 216
fitting to frames, 70
formatting, 208
  clear, 208
frame, 67
  adding to, 68
  margins, 69
importing from file, 201
on a path, 205
overflow (in frames), 70
Text Frame Tool, 67
Text Style Palette, 210
text styles, 210
  apply, 211
  change/swap, 213
delete, 212
modify, 212
theme layouts, 27
Tool
  Artistic Text, 203
Table, 88
  Text Frame, 67
Twitter (widget), 163
  edit, 166
upgrading, 3
upload site to web, 236
user details, 215
  inserting, 216
  updating, 216
user groups (access control), 146
  signing into, 150
  signing up to, 148
User List (Smart object), 145, 153
users (access control)
  adding, 147
  banning, 151
  suspending, 151
validation, 243
  Bing, 244
  Google, 243
video, 173
  adding, 174
  adding YouTube, 176
viewing published sites, 238
web hosting, 238
  Serif, 20
Welcome, 3
widgets
  Facebook, 161
  Google +1 button, 167
  Twitter, 163
YouTube video, 176